aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2008-02-28 05:41:17 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2008-02-28 05:41:17 +0000
commit059e574edaec0f83db4e425d2ac359aafb7c04c0 (patch)
tree7071be38f8dae75bb10e3730da6f33b5e4ad5ea5 /multimedia/audacious-plugins
parentf53c15158d2fa8b447a051c884191dd2e6552254 (diff)
Notes
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile136
-rw-r--r--multimedia/audacious-plugins/distinfo6
-rw-r--r--multimedia/audacious-plugins/pkg-plist187
3 files changed, 205 insertions, 124 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index d01b5e8a4f02..af158cac371d 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -6,19 +6,15 @@
#
PORTNAME= audacious-plugins
-PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTVERSION= 1.4.5
CATEGORIES= multimedia audio
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://static.audacious-media-player.org/release/
-MASTER_SITE_SUBDIR=oliver
+MASTER_SITES= http://distfiles.atheme.org/
EXTRACT_SUFX= .tgz
MAINTAINER= oliver@FreeBSD.org
COMMENT= Plugins needed for audacious
BUILD_DEPENDS= audacious:${PORTSDIR}/multimedia/audacious
-LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -27,8 +23,9 @@ CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include" \
CPP=${CPP}
CONFIGURE_ARGS= --disable-evdevplug --disable-alsa --disable-amidiplug \
- --disable-pulse --disable-projectm
+ --disable-pulse --disable-projectm --disable-projectm-1.0
WANT_GNOME= yes
+WANT_EFL= yes
WANT_SDL= yes
PORTDOCS= AUTHORS ChangeLog NEWS
@@ -38,12 +35,15 @@ PORTDOCS= AUTHORS ChangeLog NEWS
# COREAUDIO "Enable CoreAudio output plugin" off \
# PROJECTM "Enable projectM vis plugin" off \
-OPTIONS= ESOUND "Enable Esound output output" off \
+OPTIONS= AUDIOCD "Enable audiocd plugin" off \
+ ESOUND "Enable Esound output output" off \
MP3 "Enable mp3 plugin" on \
ROCKLIGHT "Enable Rocklight vis plugin" on \
LIRC "Enable LIRC plugin" off \
STATUSICON "Enable X11 Status Icon plugin" on \
AOSD "Enable X11 Audacious OSD plugin" on \
+ AOSDXCOMP "Enable X11 Audacious OSD X Composite Support" on \
+ ROOTVIS "Enable X11 RootWindow vis plugin" on \
ADPLUG "Enable AdPlug plugin" off \
VORBIS "Enable Ogg Vorbis input plugin" off \
WAVPACK "Enable WavPack input plugin" off \
@@ -56,17 +56,28 @@ OPTIONS= ESOUND "Enable Esound output output" off \
ARTS "Enable arts output plugin" off \
SID "Enable sid input plugin" off \
OSS "Enable OSS output plugin" on \
- TIMIDITY "Enable timidity plugin" on \
+ TIMIDITY "Enable timidity plugin" off \
+ CDAUDIO "Enable cdaudio-ng input plugin" on \
+ NEON "Enable neon support (experimental)" on \
MMS "Enable mms support" off \
+ MTP "Enable MTP upload support" off \
PARANORMAL "Enable paranormal vis plugin" on \
XSPF "Enable XSPF support" on \
TTA "Enable TrueAudio plugin" on \
- LAME "Enable liblame plugin" off \
GNOME "Build with gnomevfs/gconf support" off \
NLS "Native Language Support" on
.include <bsd.port.pre.mk>
+.if defined(WITH_AUDIOCD)
+LIB_DEPENDS+= cdio.7:${PORTSDIR}/sysutils/libcdio
+CONFIGURE_ARGS+=--enable-cdaudio
+PLIST_SUB+= AUDIOCDPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-cdaudio
+PLIST_SUB+= AUDIOCDPLUGIN="@comment "
+.endif
+
.if defined(WITH_ESOUND)
USE_GNOME+= esound
CONFIGURE_ARGS+=--enable-esd
@@ -98,6 +109,15 @@ CONFIGURE_ARGS+=--disable-rocklight
PLIST_SUB+= ROCKLIGHTPLUGIN="@comment "
.endif
+.if !defined(WITHOUT_ROOTVIS)
+USE_EFL= imlib2
+CONFIGURE_ARGS+=--enable-rootvis
+PLIST_SUB+= ROOTPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-rootvis
+PLIST_SUB+= ROOTPLUGIN="@comment "
+.endif
+
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
CONFIGURE_ARGS+=--enable-lirc
@@ -125,6 +145,15 @@ CONFIGURE_ARGS+=--disable-aosd
PLIST_SUB+= AOSDPLUGIN="@comment "
.endif
+.if !defined(WITHOUT_AOSDXCOMP)
+LIB_DEPENDS+= Xcomposite.1:${PORTSDIR}/x11/libXcomposite
+CONFIGURE_ARGS+=--enable-aosd-xcomp
+PLIST_SUB+= AOSDXCOMPPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-aosd-xcomp
+PLIST_SUB+= AOSDXCOMPPLUGIN="@comment "
+.endif
+
.if defined(WITH_ADPLUG)
LIB_DEPENDS+= binio.1:${PORTSDIR}/devel/libbinio
CONFIGURE_ARGS+=--enable-adplug
@@ -136,14 +165,22 @@ PLIST_SUB+= ADPLUGPLUGIN="@comment "
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-CONFIGURE_ARGS+=--enable-vorbis --enable-flac # it uses an internal flac-lib copy
+CONFIGURE_ARGS+=--enable-vorbis
PLIST_SUB+= VORBISPLUGIN=""
-CFLAGS+= -I. -I../libflac -Ilibflac # to not use system flac if it is installed
.else
-CONFIGURE_ARGS+=--disable-vorbis --disable-flac
+CONFIGURE_ARGS+=--disable-vorbis
PLIST_SUB+= VORBISPLUGIN="@comment "
.endif
+.if defined(WITH_FLAC)
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+=--enable-flacng --enable-filewriter_flac
+PLIST_SUB+= FLACPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-flacng --disable-filewriter_flac
+PLIST_SUB+= FLACPLUGIN="@comment "
+.endif
+
.if defined(WITH_WAVPACK)
LIB_DEPENDS+= wavpack.1:${PORTSDIR}/audio/wavpack
CONFIGURE_ARGS+=--enable-wavpack
@@ -198,7 +235,8 @@ PLIST_SUB+= WMAPLUGIN="@comment "
.endif
.if defined(WITH_JACK)
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack \
+ samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-jack
PLIST_SUB+= JACKPLUGIN=""
.else
@@ -240,13 +278,34 @@ CONFIGURE_ARGS+=--disable-timidity
PLIST_SUB+= TIMIDITYPLUGIN="@comment "
.endif
-.if !defined(WITHOUT_PARANORMAL)
-CONFIGURE_ARGS+=--enable-paranormal --disable-mms
-PLIST_SUB+= PARANORMALPLUGIN="" MMSPLUGIN="@comment "
-USE_SDL= sdl
+.if defined(WITH_CDAUDIO)
+LIB_DEPENDS+= cdio.7:${PORTSDIR}/sysutils/libcdio \
+ cddb.4:${PORTSDIR}/audio/libcddb
+CONFIGURE_ARGS+=--enable-cdaudio
+PLIST_SUB+= CDAUDIOPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-cdaudio
+PLIST_SUB+= CDAUDIOPLUGIN="@comment "
+.endif
+
+.if defined(WITH_PARANORMAL)
+CONFIGURE_ARGS+=--enable-paranormal
+PLIST_SUB+= PARANORMALPLUGIN=""
+USE_SDL+= sdl
.else
CONFIGURE_ARGS+=--disable-paranormal
PLIST_SUB+= PARANORMALPLUGIN="@comment "
+.endif
+
+.if !defined(WITHOUT_NEON)
+LIB_DEPENDS+= neon.26:${PORTSDIR}/www/neon
+CONFIGURE_ARGS+=--enable-neon
+PLIST_SUB+= NEONPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-neon
+PLIST_SUB+= NEONPLUGIN="@comment "
+.endif
+
.if defined(WITH_MMS)
LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
CONFIGURE_ARGS+=--enable-mms
@@ -255,6 +314,14 @@ PLIST_SUB+= MMSPLUGIN=""
CONFIGURE_ARGS+=--disable-mms
PLIST_SUB+= MMSPLUGIN="@comment "
.endif
+
+.if defined(WITH_MTP)
+LIB_DEPENDS+= mtp.6:${PORTSDIR}/audio/libmtp
+CONFIGURE_ARGS+=--enable-mtp_up
+PLIST_SUB+= MTPPLUGIN=""
+.else
+CONFIGURE_ARGS+=--disable-mtp_up
+PLIST_SUB+= MTPPLUGIN="@comment "
.endif
.if !defined(WITHOUT_XSPF)
@@ -274,15 +341,6 @@ CONFIGURE_ARGS+=--disable-tta
PLIST_SUB+= TTAPLUGIN="@comment "
.endif
-.if defined(WITH_LAME)
-LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
-CONFIGURE_ARGS+=--enable-lame
-PLIST_SUB+= LAMEPLUGIN=""
-.else
-CONFIGURE_ARGS+=--disable-lame
-PLIST_SUB+= LAMEPLUGIN="@comment "
-.endif
-
.if defined(WITH_GNOME)
USE_GNOME+= gnomevfs2 gconf2
CONFIGURE_ARGS+=--enable-gnome-vfs --enable-gconf
@@ -297,8 +355,30 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+pre-everything::
+.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "Make sure you select the PARANOIA option when installing libcdio!"
+ @${ECHO_CMD} ""
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|$$EGREP|egrep|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$EGREP|egrep|g; \
+ s| -ldl||g' ${WRKSRC}/configure
+##cpp complains about to many input files otherwise:
+#.for i in console sexypsf alac vtx madplug adplug vorbis flacng wavpack aac modplug wma sid timidity tta esd jack OSS filewriter audiocompress cdaudio-ng
+# @${ECHO} ' ' > ${WRKSRC}/src/${i}/.deps
+#.endfor
+
+pre-configure:
+.if defined(WITH_AUDIOCD) && !exists(${LOCALBASE}/lib/libcdio_cdda.so)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "sysutils/libcdio got not installed with PARANOIA enabled!"
+ @${ECHO_CMD} "To use the audiocd option you have to install libcdio with"
+ @${ECHO_CMD} "PARANOIA support! So please reinstall it properly."
+ @${ECHO_CMD} ""
+ @exit 1
+.endif
post-install:
.if defined(WITH_GNOME)
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index b713f3d97173..fd29611853d3 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacious-plugins-1.3.5.tgz) = ff6b5901367337f8149e15c8fb1fdf95
-SHA256 (audacious-plugins-1.3.5.tgz) = aae72d89135e7989b2149d51a1ed3fba2d2b8293c4852e2d6bf8eacb79113f70
-SIZE (audacious-plugins-1.3.5.tgz) = 2983930
+MD5 (audacious-plugins-1.4.5.tgz) = ecb7802c1800ed2b10b44e7e9fea46aa
+SHA256 (audacious-plugins-1.4.5.tgz) = 5ffe377f6df0b701c8a7de7bb63c1ba1951b0a1b0f95a8841765b39204e64d07
+SIZE (audacious-plugins-1.4.5.tgz) = 3176785
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index 30b93743d804..3a0c7bf1d98f 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -1,105 +1,106 @@
%%ARTSPLUGIN%%bin/audacious-arts-helper
-lib/audacious/Container/libm3u.so
-lib/audacious/Container/libpls.so
-lib/audacious/Container/libstdio.so
-%%XSPFPLUGIN%%lib/audacious/Container/libxspf.so
-lib/audacious/Effect/libaudiocompress.so
-lib/audacious/Effect/libladspa.so
-lib/audacious/Effect/libecho.so
-lib/audacious/Effect/libsndstretch.so
-lib/audacious/Effect/libstereo.so
-lib/audacious/Effect/libvoice_removal.so
-lib/audacious/General/libalarm.so
-%%AOSDPLUGIN%%lib/audacious/General/libaosd.so
-lib/audacious/General/libcurl.so
-%%LIRCPLUGIN%%lib/audacious/General/liblirc.so
-lib/audacious/General/libsong_change.so
-lib/audacious/General/libscrobbler.so
-lib/audacious/General/libstatusicon.so
-%%AACPLUGIN%%lib/audacious/Input/libaac.so
-%%ADPLUGPLUGIN%%lib/audacious/Input/libadplug.so
-lib/audacious/Input/libalac.so
-lib/audacious/Input/libcdaudio.so
-lib/audacious/Input/libconsole.so
-lib/audacious/Input/libcuesheet.so
-%%VORBISPLUGIN%%lib/audacious/Input/libflac.so
-%%MP3PLUGIN%%lib/audacious/Input/libmadplug.so
-lib/audacious/Input/libmetronom.so
-%%MODPLUG%%lib/audacious/Input/libmodplug.so
-%%MPCPLUGIN%%lib/audacious/Input/libmpc.so
-lib/audacious/Input/libsexypsf.so
-%%SIDPLUGIN%%lib/audacious/Input/libsid.so
-%%TIMIDITYPLUGIN%%lib/audacious/Input/libtimidity.so
-lib/audacious/Input/libtonegen.so
-%%TTAPLUGIN%%lib/audacious/Input/libtta.so
-%%VORBISPLUGIN%%lib/audacious/Input/libvorbis.so
-lib/audacious/Input/libvtx.so
-lib/audacious/Input/libwav.so
-%%WAVPACKPLUGIN%%lib/audacious/Input/libwavpack.so
-%%WMAPLUGIN%%lib/audacious/Input/libwma.so
-%%OSSPLUGIN%%lib/audacious/Output/libOSS.so
-%%ESDPLUGIN%%lib/audacious/Output/libESD.so
-%%ARTSPLUGIN%%lib/audacious/Output/libarts.so
-lib/audacious/Output/libdisk_writer.so
-%%LAMEPLUGIN%%lib/audacious/Output/liblame.so
-lib/audacious/Output/libnull.so
-lib/audacious/Visualization/libbscope.so
-%%PARANORMALPLUGIN%%lib/audacious/Visualization/libparanormal.so
-%%ROCKLIGHTPLUGIN%%lib/audacious/Visualization/librocklight.so
-%%PARANORMALPLUGIN%%lib/audacious/Visualization/librovascope.so
-lib/audacious/Visualization/libspectrum.so
-%%PARANORMALPLUGIN%%share/audacious-plugins/paranormal/Presets/aerdan_-_bloody_vortex.pnv
-share/audacious-plugins/paranormal/Presets/aerdan_-_cloudscape.pnv
-share/audacious-plugins/paranormal/Presets/aerdan_-_cloudscape2.pnv
-share/audacious-plugins/paranormal/Presets/aerdan_-_dancing_snow.pnv
-share/audacious-plugins/paranormal/Presets/aerdan_-_portal_to_hell.pnv
-share/audacious-plugins/paranormal/Presets/aerdan_-_telestatic.pnv
-share/audacious-plugins/paranormal/Presets/nazca_-_smoke_on_the_water.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_3d_wave.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_aquamarine_dream.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_beatscope.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_branchscope.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_bumblebees.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_cubism.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_flying_into_pastels.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_interlaced.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_kaliedoscope.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_phosphor_flame.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_psuedo_starfield.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_purple_flower.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_quakingscope.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_quasar.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_retroscope.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_rush.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_scopefun.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_simple_yet_pretty.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_smoke.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_swarm.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_technicolour_nightmare.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_transform_fun.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_trapped.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_tunnel_vision.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_value_replace_fun.pnv
-share/audacious-plugins/paranormal/Presets/nenolod_-_worms.pnv
-share/audacious-plugins/paranormal/Presets/ticpu_-_colored_beat-o-scope.pnv
+lib/audacious/Container/m3u.so
+lib/audacious/Container/pls.so
+%%XSPFPLUGIN%%lib/audacious/Container/xspf.so
+lib/audacious/Effect/audiocompress.so
+lib/audacious/Effect/ladspa.so
+lib/audacious/Effect/echo.so
+lib/audacious/Effect/sndstretch.so
+lib/audacious/Effect/stereo.so
+lib/audacious/Effect/voice_removal.so
+lib/audacious/General/alarm.so
+%%AOSDPLUGIN%%lib/audacious/General/aosd.so
+lib/audacious/General/gnomeshortcuts.so
+lib/audacious/General/hotkey.so
+%%LIRCPLUGIN%%lib/audacious/General/lirc.so
+lib/audacious/General/song_change.so
+lib/audacious/General/statusicon.so
+%%AACPLUGIN%%lib/audacious/Input/aac.so
+%%ADPLUGPLUGIN%%lib/audacious/Input/adplug.so
+lib/audacious/Input/alac.so
+%%AUDIOCDPLUGIN%%lib/audacious/Input/cdaudio-ng.so
+lib/audacious/Input/console.so
+lib/audacious/Input/cuesheet.so
+%%VORBISPLUGIN%%lib/audacious/Input/flacng.so
+%%MP3PLUGIN%%lib/audacious/Input/madplug.so
+lib/audacious/Input/metronom.so
+%%MODPLUG%%lib/audacious/Input/modplug.so
+%%MTPPLUGIN%%lib/audacious/General/mtp_up.so
+%%MPCPLUGIN%%lib/audacious/Input/musepack.so
+lib/audacious/Input/sexypsf.so
+%%SIDPLUGIN%%lib/audacious/Input/sid.so
+%%TIMIDITYPLUGIN%%lib/audacious/Input/timidity.so
+lib/audacious/Input/tonegen.so
+%%TTAPLUGIN%%lib/audacious/Input/tta.so
+%%VORBISPLUGIN%%lib/audacious/Input/vorbis.so
+lib/audacious/Input/vtx.so
+lib/audacious/Input/wav.so
+%%WAVPACKPLUGIN%%lib/audacious/Input/wavpack.so
+%%WMAPLUGIN%%lib/audacious/Input/wma.so
+%%OSSPLUGIN%%lib/audacious/Output/OSS.so
+%%ESDPLUGIN%%lib/audacious/Output/ESD.so
+%%ARTSPLUGIN%%lib/audacious/Output/arts.so
+lib/audacious/Output/filewriter.so
+lib/audacious/Output/null.so
+%%NEONPLUGIN%%lib/audacious/Transport/neon.so
+lib/audacious/Transport/stdio.so
+lib/audacious/Visualization/blur_scope.so
+%%PARANORMALPLUGIN%%lib/audacious/Visualization/paranormal.so
+%%ROCKLIGHTPLUGIN%%lib/audacious/Visualization/rocklight.so
+%%ROOTPLUGIN%%lib/audacious/Visualization/rootvis.so
+lib/audacious/Visualization/spectrum.so
+share/audacious/paranormal/Presets/aerdan_-_cloudscape.pnv
+share/audacious/paranormal/Presets/aerdan_-_cloudscape2.pnv
+share/audacious/paranormal/Presets/aerdan_-_dancing_snow.pnv
+share/audacious/paranormal/Presets/aerdan_-_portal_to_hell.pnv
+share/audacious/paranormal/Presets/aerdan_-_telestatic.pnv
+share/audacious/paranormal/Presets/nazca_-_smoke_on_the_water.pnv
+share/audacious/paranormal/Presets/nenolod_-_3d_wave.pnv
+share/audacious/paranormal/Presets/nenolod_-_aquamarine_dream.pnv
+share/audacious/paranormal/Presets/nenolod_-_beatscope.pnv
+share/audacious/paranormal/Presets/nenolod_-_branchscope.pnv
+share/audacious/paranormal/Presets/nenolod_-_bumblebees.pnv
+share/audacious/paranormal/Presets/nenolod_-_cubism.pnv
+share/audacious/paranormal/Presets/nenolod_-_flying_into_pastels.pnv
+share/audacious/paranormal/Presets/nenolod_-_interlaced.pnv
+share/audacious/paranormal/Presets/nenolod_-_kaliedoscope.pnv
+share/audacious/paranormal/Presets/nenolod_-_phosphor_flame.pnv
+share/audacious/paranormal/Presets/nenolod_-_psuedo_starfield.pnv
+share/audacious/paranormal/Presets/nenolod_-_purple_flower.pnv
+share/audacious/paranormal/Presets/nenolod_-_quakingscope.pnv
+share/audacious/paranormal/Presets/nenolod_-_quasar.pnv
+share/audacious/paranormal/Presets/nenolod_-_retroscope.pnv
+share/audacious/paranormal/Presets/nenolod_-_rush.pnv
+share/audacious/paranormal/Presets/nenolod_-_scopefun.pnv
+share/audacious/paranormal/Presets/nenolod_-_simple_yet_pretty.pnv
+share/audacious/paranormal/Presets/nenolod_-_smoke.pnv
+share/audacious/paranormal/Presets/nenolod_-_swarm.pnv
+share/audacious/paranormal/Presets/nenolod_-_technicolour_nightmare.pnv
+share/audacious/paranormal/Presets/nenolod_-_transform_fun.pnv
+share/audacious/paranormal/Presets/nenolod_-_trapped.pnv
+share/audacious/paranormal/Presets/nenolod_-_tunnel_vision.pnv
+share/audacious/paranormal/Presets/nenolod_-_value_replace_fun.pnv
+share/audacious/paranormal/Presets/nenolod_-_worms.pnv
+share/audacious/paranormal/Presets/ticpu_-_colored_beat-o-scope.pnv
+%%PARANORMALPLUGIN%%share/audacious/paranormal/Presets/aerdan_-_bloody_vortex.pnv
%%NLS%%share/locale/ca/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/cs/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/cy/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/de/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/ja/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/ru/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/sk/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/tr/LC_MESSAGES/audacious-plugins.mo
-share/audacious/images/audioscrobbler.png
-share/audacious/images/audioscrobbler_badge.png
-@dirrm include/audacious-plugins
+@dirrm lib/audacious/Effect
@dirrm lib/audacious/Container
-@dirrm lib/audacious/Visualization
-@dirrm lib/audacious/Output
-@dirrm lib/audacious/Input
@dirrm lib/audacious/General
-@dirrm lib/audacious/Effect
+@dirrm lib/audacious/Input
+@dirrm lib/audacious/Output
+@dirrm lib/audacious/Transport
+@dirrm lib/audacious/Visualization
@dirrmtry lib/audacious
-%%PARANORMALPLUGIN%%@dirrm share/audacious-plugins/paranormal/Presets
-%%PARANORMALPLUGIN%%@dirrm share/audacious-plugins/paranormal
-%%PARANORMALPLUGIN%%@dirrm share/audacious-plugins
+%%PARANORMALPLUGIN%%@dirrm share/audacious/paranormal/Presets
+%%PARANORMALPLUGIN%%@dirrm share/audacious/paranormal
+@dirrmtry share/audacious