aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-04 22:40:12 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-04 22:40:12 +0000
commitda0a8755d094e0cd43d811cfa91b94884444c721 (patch)
treee5eab3827a20f1ac8a75e990d28a4572c27eb262 /multimedia/audacious/Makefile
parentaa08bbffb5e08652f0549eb02ede3e40f65a5c30 (diff)
downloadports-da0a8755d094e0cd43d811cfa91b94884444c721.tar.gz
ports-da0a8755d094e0cd43d811cfa91b94884444c721.zip
Notes
Diffstat (limited to 'multimedia/audacious/Makefile')
-rw-r--r--multimedia/audacious/Makefile105
1 files changed, 105 insertions, 0 deletions
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
new file mode 100644
index 000000000000..4f18981317c6
--- /dev/null
+++ b/multimedia/audacious/Makefile
@@ -0,0 +1,105 @@
+# New ports collection makefile for: audacious
+# Date created: 2006-01-01
+# Whom: Zastupov Stepan [RedChrom] <redchrom@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= audacious
+PORTVERSION= 0.1.2
+CATEGORIES= multimedia audio
+MASTER_SITES= http://audacious-media-player.org/release/
+DISTNAME= audacious-${PORTVERSION}
+EXTRACT_SUFX=.tgz
+
+MAINTAINER= redchrom@mail.ru
+COMMENT= A media player based on BMP and XMMS
+
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
+
+USE_GNOME= gtk20 libglade2
+WANT_GNOME= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+LIBTOOLFILES= configure
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstdc++" \
+ INPUT_PLUGINS="${INPUT_PLUGINS}" \
+ OUTPUT_PLUGINS="${OUTPUT_PLUGINS}" \
+ VISUALIZATION_PLUGINS="${VISUALIZATION_PLUGINS}"
+MAN1= audacious.1
+
+INPUT_PLUGINS= cdaudio,mpg123,wav,tonegen,wma,console
+OUTPUT_PLUGINS= OSS,disk_writer,crossfade
+VISUALIZATION_PLUGINS= blur_scope
+
+OPTIONS= VORBIS "Enable Ogg Vorbis input" on \
+ FLAC "Enable flac input" on \
+ ESOUND "Enable Esound output" off \
+ ID3V2 "Enable id3v2 editing" off \
+ SIMD "build with x86 SIMD(3DNow!/MMX) instructions support" on \
+ SDL "Enable SDL support" off \
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_VORBIS)
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+INPUT_PLUGINS+= vorbis
+PLIST_SUB+= VORBISPLUGIN:=""
+.else
+CONFIGURE_ARGS+= --disable-vorbis
+PLIST_SUB+= VORBISPLUGIN:="@comment "
+.endif
+
+.if !defined(WITHOUT_FLAC)
+INPUT_PLUGINS+= flac
+PLIST_SUB+= FLACPLUGIN:=""
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+.else
+PLIST_SUB+= FLACPLUGIN:="@comment "
+CONFIGURE_ARGS+= --disable-flac
+.endif
+
+.if defined(WITH_ESOUND)
+USE_GNOME+= esound
+OUTPUT_PLUGINS+= esd
+PLIST_SUB+= ESDPLUGIN:=""
+.if defined(PKGNAMESUFFIX)
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-esound
+.else
+PKGNAMESUFFIX= -esound
+.endif
+.else
+CONFIGURE_ARGS+= --disable-esd
+PLIST_SUB+= ESDPLUGIN:="@comment "
+.endif
+
+.if defined(WITH_ID3V2)
+LIB_DEPENDS+= id3-3.8.3:${PORTSDIR}/audio/id3lib
+.endif
+
+.if ${ARCH} != "i386"
+WITHOUT_SIMD= yes
+.endif
+
+.if !defined(WITHOUT_SIMD) && ${OSVERSION} >= 400021
+CONFIGURE_ARGS+= --enable-simd
+.endif
+
+.if defined(WITH_SDL)
+USE_SDL= sdl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
+ ${WRKSRC}/configure
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>