aboutsummaryrefslogtreecommitdiff
path: root/multimedia/avifile/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-06-08 13:11:07 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-06-08 13:11:07 +0000
commitd1a6ae4207e528165b9a71b1bcb7f05de3361936 (patch)
treeee4a6118bc99baa4ee33d9451587a3aab7e7ef3b /multimedia/avifile/Makefile
parent82697c520e77410e902ff017f45e980b9774e01d (diff)
downloadports-d1a6ae4207e528165b9a71b1bcb7f05de3361936.tar.gz
ports-d1a6ae4207e528165b9a71b1bcb7f05de3361936.zip
Notes
Diffstat (limited to 'multimedia/avifile/Makefile')
-rw-r--r--multimedia/avifile/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 529dd15dca58..defce24ec892 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avifile
PORTVERSION= 0.60.20010429
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
http://divx.euro.ru/ \
@@ -34,9 +35,6 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
--enable-release --with-gnu-ld
-.if defined(WITH_MGA)
-CONFIGURE_ARGS+=--enable-mga
-.endif
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -59,10 +57,11 @@ DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>
pre-extract:
-.if !defined(WITH_MGA)
- @${ECHO_MSG} "You can enable special MGA support by building with -DWITH_MGA."
-.endif
-
+ @if [ -f ${LOCALBASE}/lib/libpth.so ]; then \
+ ${ECHO_MSG} "Error: This packet does not compile when the \
+packet 'pth' is installed.";\
+ ${FALSE};\
+ fi
do-configure:
(cd ${WRKSRC} && aclocal && ./autogen.sh &&\
${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS})