aboutsummaryrefslogtreecommitdiff
path: root/multimedia/beep-media-player
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-08-25 15:09:26 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-08-25 15:09:26 +0000
commit9e55cb845f6fd3fdf3eed2a6639acdc6eef8919d (patch)
treebe209a62d97b2bbf86f4f21266ea6842288ddcf9 /multimedia/beep-media-player
parente139e5a754c9a492afad3241dce4c0333208e95f (diff)
downloadports-9e55cb845f6fd3fdf3eed2a6639acdc6eef8919d.tar.gz
ports-9e55cb845f6fd3fdf3eed2a6639acdc6eef8919d.zip
Notes
Diffstat (limited to 'multimedia/beep-media-player')
-rw-r--r--multimedia/beep-media-player/Makefile9
-rw-r--r--multimedia/beep-media-player/distinfo4
-rw-r--r--multimedia/beep-media-player/files/patch-Input::mpg123::fileinfo.c61
-rw-r--r--multimedia/beep-media-player/files/patch-Input::mpg123::mpg123.c42
-rw-r--r--multimedia/beep-media-player/files/patch-Input::vorbis::fileinfo.c88
-rw-r--r--multimedia/beep-media-player/files/patch-Input::vorbis::vorbis.c16
-rw-r--r--multimedia/beep-media-player/files/patch-Output::OSS::audio.c10
-rw-r--r--multimedia/beep-media-player/files/patch-beep::controlsocket.c10
-rw-r--r--multimedia/beep-media-player/files/patch-beep::dirbrowser.c177
-rw-r--r--multimedia/beep-media-player/files/patch-beep::playlist_list.c19
-rw-r--r--multimedia/beep-media-player/files/patch-beep::pluginenum.c18
-rw-r--r--multimedia/beep-media-player/files/patch-beep::skin.c42
-rw-r--r--multimedia/beep-media-player/files/patch-beep::skinwin.c18
-rw-r--r--multimedia/beep-media-player/files/patch-beep::softvolume.c16
-rw-r--r--multimedia/beep-media-player/files/patch-beep::textbox.c15
-rw-r--r--multimedia/beep-media-player/pkg-message12
-rw-r--r--multimedia/beep-media-player/pkg-plist50
17 files changed, 74 insertions, 533 deletions
diff --git a/multimedia/beep-media-player/Makefile b/multimedia/beep-media-player/Makefile
index dc2fabf57754..8425569cbc6b 100644
--- a/multimedia/beep-media-player/Makefile
+++ b/multimedia/beep-media-player/Makefile
@@ -6,23 +6,22 @@
#
PORTNAME= beep-media-player
-PORTVERSION= 0.9.6.1
-PORTREVISION= 2
+PORTVERSION= 0.9.7.r1
PORTEPOCH= 1
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= beepmp
-DISTNAME= bmp-${PORTVERSION}
+DISTNAME= bmp-${PORTVERSION:R}rc${PORTVERSION:C/^.*r//}
MAINTAINER= flynn@energyhq.es.eu.org
COMMENT= GTK2 mp3 player
-USE_GNOME= gtk20
+USE_GNOME= gtk20 libglade2
WANT_GNOME= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
-LIBTOOLFILES= configure libbeep/configure
+LIBTOOLFILES= configure
USE_GMAKE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/multimedia/beep-media-player/distinfo b/multimedia/beep-media-player/distinfo
index bdd78026afd9..49e2ab63ca18 100644
--- a/multimedia/beep-media-player/distinfo
+++ b/multimedia/beep-media-player/distinfo
@@ -1,2 +1,2 @@
-MD5 (bmp-0.9.6.1.tar.gz) = 0102233416eb8efaec775c415f5308eb
-SIZE (bmp-0.9.6.1.tar.gz) = 1472078
+MD5 (bmp-0.9.7rc1.tar.gz) = e50c82c4bcb76e93ac183414d01b3591
+SIZE (bmp-0.9.7rc1.tar.gz) = 1674199
diff --git a/multimedia/beep-media-player/files/patch-Input::mpg123::fileinfo.c b/multimedia/beep-media-player/files/patch-Input::mpg123::fileinfo.c
deleted file mode 100644
index 4ee68be7bafb..000000000000
--- a/multimedia/beep-media-player/files/patch-Input::mpg123::fileinfo.c
+++ /dev/null
@@ -1,61 +0,0 @@
---- Input/mpg123/fileinfo.c.orig Sat Feb 7 18:24:23 2004
-+++ Input/mpg123/fileinfo.c Sat Feb 7 18:34:26 2004
-@@ -299,6 +299,13 @@
- {
- gint i;
- gchar *title;
-+ GtkWidget *pixmapwid;
-+ GdkPixbuf *pixbuf;
-+ PangoAttribute *attr;
-+ PangoAttrList *attrs;
-+ GtkWidget *test_table;
-+ GtkWidget *urk, *blark;
-+ struct stat mstat;
-
- emphasis[0] = _("None");
- emphasis[1] = _("50/15 ms");
-@@ -323,8 +330,6 @@
- filename_vbox = gtk_hbox_new(FALSE, 5);
- gtk_box_pack_start(GTK_BOX(vbox), filename_vbox, FALSE, TRUE, 0);
-
-- GtkWidget *pixmapwid;
-- GdkPixbuf *pixbuf;
- pixbuf = gdk_pixbuf_new_from_xpm_data((const char **)
- gnome_mime_audio_xpm);
- pixmapwid = gtk_image_new_from_pixbuf(pixbuf);
-@@ -335,9 +340,6 @@
-
- label = gtk_label_new(NULL);
-
-- PangoAttrList *attrs;
-- PangoAttribute *attr;
--
- attrs = pango_attr_list_new();
-
- attr = pango_attr_weight_new(PANGO_WEIGHT_BOLD);
-@@ -382,7 +384,7 @@
- //// MPEG Layer Info
-
- // FIXME: Obvious...
-- GtkWidget *test_table = gtk_table_new(2, 10, FALSE);
-+ test_table = gtk_table_new(2, 10, FALSE);
- gtk_container_set_border_width(GTK_CONTAINER(test_table), 0);
- gtk_container_add(GTK_CONTAINER(mpeg_box), test_table);
-
-@@ -457,8 +459,6 @@
- gtk_table_attach(GTK_TABLE(test_table), mpeg_filesize_val, 1, 2, 4,
- 5, GTK_FILL, GTK_FILL, 10, 2);
-
-- GtkWidget *urk, *blark;
--
- urk = gtk_label_new("");
- blark = gtk_label_new("");
- gtk_misc_set_alignment(GTK_MISC(urk), 1, 0.5);
-@@ -756,7 +756,6 @@
- return;
- }
-
-- struct stat mstat;
- stat(filename, &mstat);
- gtk_widget_set_sensitive(id3_frame,
- ((mstat.st_mode & S_IWRITE) == S_IWRITE));
diff --git a/multimedia/beep-media-player/files/patch-Input::mpg123::mpg123.c b/multimedia/beep-media-player/files/patch-Input::mpg123::mpg123.c
deleted file mode 100644
index 21ce08febedc..000000000000
--- a/multimedia/beep-media-player/files/patch-Input::mpg123::mpg123.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- Input/mpg123/mpg123.c.orig Sat Feb 7 18:21:05 2004
-+++ Input/mpg123/mpg123.c Sat Feb 7 18:23:32 2004
-@@ -635,6 +635,7 @@
- gchar ** genre, guint * tracknum)
- {
- FILE *file;
-+ int result_seek, result_read;
- struct id3v1tag_t id3v1tag;
- struct id3tag_t id3tag;
-
-@@ -669,12 +670,12 @@
- if (!id3) {
-
-
-- int result_seek = fseek(file, -1 * sizeof(id3v1tag), SEEK_END);
-+ result_seek = fseek(file, -1 * sizeof(id3v1tag), SEEK_END);
- if (result_seek)
- return;
-
-
-- int result_read = fread(&id3v1tag, 1, sizeof(id3v1tag), file);
-+ result_read = fread(&id3v1tag, 1, sizeof(id3v1tag), file);
- if (result_read != sizeof(id3v1tag))
- return;
- if (strncmp(id3v1tag.tag, "TAG", 3) != 0)
-@@ -1111,6 +1112,8 @@
-
- static void play_file(char *filename)
- {
-+ pthread_attr_t pta;
-+
- memset(&fr, 0, sizeof(struct frame));
- memset(&temp_fr, 0, sizeof(struct frame));
-
-@@ -1124,7 +1127,6 @@
- output_opened = FALSE;
- dopause = FALSE;
-
-- pthread_attr_t pta;
- (void) pthread_attr_init(&pta);
- (void) pthread_attr_setschedpolicy(&pta, PTHREAD_INHERIT_SCHED);
- (void) pthread_attr_setscope(&pta, PTHREAD_SCOPE_SYSTEM);
diff --git a/multimedia/beep-media-player/files/patch-Input::vorbis::fileinfo.c b/multimedia/beep-media-player/files/patch-Input::vorbis::fileinfo.c
deleted file mode 100644
index 6fd3696b7ec8..000000000000
--- a/multimedia/beep-media-player/files/patch-Input::vorbis::fileinfo.c
+++ /dev/null
@@ -1,88 +0,0 @@
---- Input/vorbis/fileinfo.c.orig Sat Jul 31 22:46:58 2004
-+++ Input/vorbis/fileinfo.c Sat Jul 31 22:52:22 2004
-@@ -200,7 +200,7 @@
- gchar *errorstring;
- errorstring = g_strdup_printf(_("An error occured:\n%s"), error);
-
-- xmms_show_message_test(_("Error!"),
-+ xmms_show_message(_("Error!"),
- errorstring, _("Ok"), FALSE, NULL, NULL);
-
- g_free(errorstring);
-@@ -488,12 +488,21 @@
-
- static GtkWidget *filename_entry, *tag_frame;
-
-+ GtkWidget *hbox, *label, *filename_hbox, *vbox, *left_vbox;
-+ GtkWidget *table, *bbox, *cancel_button;
-+ GtkWidget *pixmapwid;
-+ GdkPixbuf *pixbuf;
-+ PangoAttrList *attrs;
-+ PangoAttribute *attr;
-+ GtkWidget *boxx;
-+ GtkImage *img;
-+ GtkWidget *test_table;
-+ struct stat mstat;
-+
- g_free(vte.filename);
- vte.filename = g_strdup(fn);
-
- if (!window) {
-- GtkWidget *hbox, *label, *filename_hbox, *vbox, *left_vbox;
-- GtkWidget *table, *bbox, *cancel_button;
-
- window = gtk_window_new(GTK_WINDOW_TOPLEVEL);
- gtk_window_set_policy(GTK_WINDOW(window), FALSE, FALSE, FALSE);
-@@ -508,17 +517,13 @@
- filename_hbox = gtk_hbox_new(FALSE, 5);
- gtk_box_pack_start(GTK_BOX(vbox), filename_hbox, FALSE, TRUE, 0);
-
-- GtkWidget *pixmapwid;
-- GdkPixbuf *pixbuf = gdk_pixbuf_new_from_xpm_data((const char **)
-+ pixbuf = gdk_pixbuf_new_from_xpm_data((const char **)
- gnome_mime_audio_ogg_xpm);
- pixmapwid = gtk_image_new_from_pixbuf(pixbuf);
- gtk_misc_set_alignment(GTK_MISC(pixmapwid), 0, 0);
- gtk_box_pack_start(GTK_BOX(filename_hbox), pixmapwid, FALSE, FALSE,
- 0);
-
-- PangoAttrList *attrs;
-- PangoAttribute *attr;
--
- attrs = pango_attr_list_new();
-
- attr = pango_attr_weight_new(PANGO_WEIGHT_BOLD);
-@@ -722,7 +727,6 @@
- GTK_FILL | GTK_EXPAND | GTK_SHRINK, 0, 5);
- #endif
-
-- GtkWidget *boxx;
- boxx = gtk_hbutton_box_new();
- gtk_hbutton_box_set_layout_default(GTK_BUTTONBOX_SPREAD);
-
-@@ -739,7 +743,7 @@
- gtk_table_attach(table, boxx, 0, 5, 6, 7, GTK_FILL, 0, 0, 8);
-
- rg_show_button = gtk_toggle_button_new();
-- GtkImage *img = gtk_image_new_from_stock(GTK_STOCK_GO_FORWARD,
-+ img = gtk_image_new_from_stock(GTK_STOCK_GO_FORWARD,
- GTK_ICON_SIZE_MENU);
- gtk_container_add(rg_show_button, img);
- g_signal_connect(G_OBJECT(rg_show_button), "toggled",
-@@ -832,7 +836,7 @@
- gtk_box_set_spacing(GTK_BOX(info_box), 0);
-
- // FIXME: Obvious...
-- GtkWidget *test_table = gtk_table_new(2, 10, FALSE);
-+ test_table = gtk_table_new(2, 10, FALSE);
- gtk_container_set_border_width(GTK_CONTAINER(test_table), 0);
- gtk_container_add(GTK_CONTAINER(info_box), test_table);
-
-@@ -1073,7 +1077,6 @@
- gtk_window_set_title(GTK_WINDOW(window), tmp);
- // rg_show_cb(rg_show_button, NULL);
-
-- struct stat mstat;
- stat(fn, &mstat);
- gtk_widget_set_sensitive(tag_frame,
- ((mstat.st_mode & S_IWRITE) == S_IWRITE));
diff --git a/multimedia/beep-media-player/files/patch-Input::vorbis::vorbis.c b/multimedia/beep-media-player/files/patch-Input::vorbis::vorbis.c
deleted file mode 100644
index 416255b9040a..000000000000
--- a/multimedia/beep-media-player/files/patch-Input::vorbis::vorbis.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- Input/vorbis/vorbis.c.orig Sat Feb 7 19:26:13 2004
-+++ Input/vorbis/vorbis.c Sat Feb 7 19:32:10 2004
-@@ -521,12 +521,12 @@
-
- static void vorbis_play(char *filename)
- {
-+ pthread_attr_t pta;
- vorbis_playing = 1;
- vorbis_bytes_streamed = 0;
- vorbis_eos = 0;
- output_error = FALSE;
-
-- pthread_attr_t pta;
- (void) pthread_attr_init(&pta);
- (void) pthread_attr_setschedpolicy(&pta, PTHREAD_INHERIT_SCHED);
- (void) pthread_attr_setscope(&pta, PTHREAD_SCOPE_SYSTEM);
diff --git a/multimedia/beep-media-player/files/patch-Output::OSS::audio.c b/multimedia/beep-media-player/files/patch-Output::OSS::audio.c
new file mode 100644
index 000000000000..39849db1cb20
--- /dev/null
+++ b/multimedia/beep-media-player/files/patch-Output::OSS::audio.c
@@ -0,0 +1,10 @@
+--- Output/OSS/audio.c.orig Tue Aug 24 22:26:01 2004
++++ Output/OSS/audio.c Tue Aug 24 22:26:17 2004
+@@ -26,6 +26,7 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <sys/ioctl.h>
++#include <sys/time.h>
+
+ #include "OSS.h"
+
diff --git a/multimedia/beep-media-player/files/patch-beep::controlsocket.c b/multimedia/beep-media-player/files/patch-beep::controlsocket.c
new file mode 100644
index 000000000000..705363c30764
--- /dev/null
+++ b/multimedia/beep-media-player/files/patch-beep::controlsocket.c
@@ -0,0 +1,10 @@
+--- beep/controlsocket.c.orig Mon Aug 23 21:23:19 2004
++++ beep/controlsocket.c Mon Aug 23 21:27:43 2004
+@@ -26,6 +26,7 @@
+
+ #include <unistd.h>
+ #include <errno.h>
++#include <sys/time.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
diff --git a/multimedia/beep-media-player/files/patch-beep::dirbrowser.c b/multimedia/beep-media-player/files/patch-beep::dirbrowser.c
deleted file mode 100644
index 5d18f7431fca..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::dirbrowser.c
+++ /dev/null
@@ -1,177 +0,0 @@
---- beep/dirbrowser.c.orig Sat Feb 7 18:04:24 2004
-+++ beep/dirbrowser.c Sat Feb 7 18:18:23 2004
-@@ -263,15 +263,17 @@
- static gchar *bmp_db_sanify_tag(gchar * value)
- {
-
-- if (!value)
-- return "(unknown)";
--
-+ GString *chunk;
- gchar *frag = NULL;
- gchar **branches;
- guint ctr = 0;
- gboolean bracket_open = FALSE;
-
-- GString *chunk = g_string_new(NULL);
-+ if (!value)
-+ return "(unknown)";
-+
-+
-+ chunk = g_string_new(NULL);
- branches = g_strsplit(g_strstrip(value), " ", 0);
-
- while (frag || (ctr == 0)) {
-@@ -346,6 +348,7 @@
- GList *list = NULL;
- gboolean first = TRUE;
- gchar *from_real;
-+ GdkPixbuf *buf_dir, *buf_file, *buf_cda;
-
- from = g_locale_from_utf8(from, -1, NULL, NULL, NULL);
- from_real = bmp_db_get_path_real(from, model, &parent_iter);
-@@ -353,18 +356,19 @@
-
- /* It's not really a waste creating both beforehand since we will
- * certainly need the folder one at least once, and most probably
-- * the audio one too anyway */
-- GdkPixbuf *buf_dir = gdk_pixbuf_new_from_inline(sizeof(folder_pixbuf),
-+ * the audio one too anyway.
-+ */
-+ buf_dir = gdk_pixbuf_new_from_inline(sizeof(folder_pixbuf),
- folder_pixbuf,
- TRUE,
- NULL);
-
-- GdkPixbuf *buf_file = gdk_pixbuf_new_from_inline(sizeof(audio_pixbuf),
-+ buf_file = gdk_pixbuf_new_from_inline(sizeof(audio_pixbuf),
- audio_pixbuf,
- TRUE,
- NULL);
-
-- GdkPixbuf *buf_cda = gdk_pixbuf_new_from_inline(sizeof(cda_pixbuf),
-+ buf_cda = gdk_pixbuf_new_from_inline(sizeof(cda_pixbuf),
- cda_pixbuf,
- TRUE,
- NULL);
-@@ -654,6 +658,7 @@
-
- GtkTreeModel *model;
- GtkTreeView *treeview;
-+ GtkWidget *store;
-
- treeview = gtk_tree_selection_get_tree_view(sel);
- model = gtk_tree_view_get_model(treeview);
-@@ -681,7 +686,7 @@
- paths = paths->next;
- }
-
-- GtkWidget *store =
-+ store =
- GTK_WIDGET(bmp_db_return_filestore_model_fresh(paths_f));
-
- gtk_tree_view_set_model(user_data, GTK_TREE_MODEL(store));
-@@ -706,6 +711,7 @@
-
- struct stat statbuf;
- GtkTreeModel *model;
-+ gboolean valid;
-
- model = gtk_tree_view_get_model(treeview);
- paths = bmp_db_get_paths_from_selection(treeview);
-@@ -735,7 +741,7 @@
- if (gtk_tree_model_iter_children(model, &iter_child, &iter)) {
- if (click_play)
- playlist_clear();
-- gboolean valid = TRUE;
-+ valid = TRUE;
- while (valid) {
- gtk_tree_model_get(GTK_TREE_MODEL(model), &iter_child,
- FILENAME_COL, &node_name, -1);
-@@ -1308,12 +1314,15 @@
- {
-
- GtkTreeStore *file_store;
--
-+ GtkTreeModel *sort_model;
-+ gdouble length_pl, frac;
-+ int ctr=0;
-+ GList *files;
-
- file_store =
- gtk_tree_store_new(5, GDK_TYPE_PIXBUF, G_TYPE_STRING, G_TYPE_INT,
- G_TYPE_STRING, G_TYPE_INT);
-- GtkTreeModel *sort_model =
-+ sort_model =
- gtk_tree_model_sort_new_with_model(GTK_TREE_MODEL(file_store));
-
-
-@@ -1321,17 +1330,16 @@
- bmp_db_mdb_sort_func, NULL, NULL);
-
-
-- gdouble length_pl = g_list_length(paths);
-+ length_pl = g_list_length(paths);
- gtk_progress_bar_set_fraction(GTK_PROGRESS_BAR(progressbar_db), 0.0);
-
-- int ctr = 0;
-
- while (paths) {
-
- gchar *path = paths->data;
- ctr++;
-
-- GList *files = bmp_db_return_files_from_path(path);
-+ files = bmp_db_return_files_from_path(path);
-
- while (files) {
- gchar *title;
-@@ -1356,7 +1364,7 @@
- files = files->next;
- }
-
-- gdouble frac = 1 / length_pl;
-+ frac = 1 / length_pl;
- gtk_progress_bar_set_fraction(GTK_PROGRESS_BAR(progressbar_db),
- frac * ctr);
- while (gtk_events_pending()) {
-@@ -1411,15 +1419,17 @@
- GtkWidget *treeview = NULL;
- GtkWidget *label_header;
- GtkWidget *paned;
-+ GtkWidget *fstore;
-+ GList *paths = NULL;
-+ PangoAttrList *attrs;
-+ PangoAttribute *attr;
-+ GtkTreeSelection *sel;
-
- if (!window) {
-
- /* create window, etc */
- /* yes this is all messed up */
-
-- PangoAttrList *attrs;
-- PangoAttribute *attr;
--
- window = gtk_window_new(GTK_WINDOW_TOPLEVEL);
- gtk_window_set_title(GTK_WINDOW(window), "bmp :: Add Files...");
- gtk_container_set_border_width(GTK_CONTAINER(window), 8);
-@@ -1489,17 +1499,15 @@
- G_CALLBACK(bmp_db_keypress), window);
-
- gtk_container_add(GTK_CONTAINER(sw), treeview);
-- GtkWidget *fstore;
-
- /* FIXME: clean up variables, move them to start */
-
- /* FIXME: paths is not freed, and is resetted every iteration */
-- GList *paths = NULL;
- paths = g_list_append(paths, g_strdup(g_get_home_dir()));
- fstore = bmp_db_return_filestore_fresh(paths);
- gtk_container_add(GTK_CONTAINER(sw_right), fstore);
-
-- GtkTreeSelection *sel =
-+ sel =
- gtk_tree_view_get_selection(GTK_TREE_VIEW(treeview));
- g_signal_connect(G_OBJECT(sel), "changed",
- G_CALLBACK(bmp_db_row_activated), fstore);
diff --git a/multimedia/beep-media-player/files/patch-beep::playlist_list.c b/multimedia/beep-media-player/files/patch-beep::playlist_list.c
deleted file mode 100644
index 78101074d5f1..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::playlist_list.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- beep/playlist_list.c.orig Sat Feb 7 17:53:46 2004
-+++ beep/playlist_list.c Sat Feb 7 17:54:59 2004
-@@ -372,6 +372,7 @@
- gint i, tw, max_first;
- guint padding;
- guint max_time_len = 0;
-+ gchar **frags;
-
- gc = pl->pl_widget.gc;
- width = pl->pl_widget.width;
-@@ -507,7 +508,7 @@
-
-
-
-- gchar **frags = g_strsplit(tail, ":", 0);
-+ frags = g_strsplit(tail, ":", 0);
-
- layout =
- gtk_widget_create_pango_layout(GTK_WIDGET(playlistwin),
diff --git a/multimedia/beep-media-player/files/patch-beep::pluginenum.c b/multimedia/beep-media-player/files/patch-beep::pluginenum.c
deleted file mode 100644
index 6c3c82832508..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::pluginenum.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- beep/pluginenum.c.orig Wed Dec 24 15:03:17 2003
-+++ beep/pluginenum.c Sat Feb 7 22:08:41 2004
-@@ -238,6 +238,7 @@
-
-
- #ifndef DISABLE_USER_PLUGIN_DIR
-+if(0) {
- dir = g_build_filename(g_get_home_dir(), BMP_RCPATH, "plugins");
- bmp_scan_plugins(dir);
- g_free(dir);
-@@ -259,6 +260,7 @@
- g_free(dir);
- }
- dirsel = 0;
-+}
- #endif
-
- while (plugin_dir_list[dirsel]) {
diff --git a/multimedia/beep-media-player/files/patch-beep::skin.c b/multimedia/beep-media-player/files/patch-beep::skin.c
deleted file mode 100644
index 1bd7b7d43628..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::skin.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- beep/skin.c.orig Sat Feb 7 17:42:34 2004
-+++ beep/skin.c Sat Feb 7 17:46:18 2004
-@@ -168,6 +168,7 @@
- const SMID_Mapping *sm_inf;
- GdkPixmap *gpm;
- gboolean retval = FALSE;
-+ SkinPixmap *pm;
-
- if (id >= SKIN_PMID_LAST) {
- g_warning("skin pixmap id out of range (%u).", id);
-@@ -201,7 +202,7 @@
- }
- g_free(tmpstr);
-
-- SkinPixmap *pm = &sk->pixmaps[id];
-+ pm = &sk->pixmaps[id];
- gpm = read_bmp(filename);
-
- if (!gpm) {
-@@ -733,9 +734,9 @@
- GdkBitmap *skin_get_mask(MaskIndex mi, gboolean doublesize,
- gboolean shaded)
- {
-+ GdkBitmap **masks;
- g_assert(skin != NULL);
-
-- GdkBitmap **masks;
-
- g_assert(mi < SKIN_MID_LAST);
- masks = (doublesize ? skin->ds_masks : skin->masks);
-@@ -813,8 +814,10 @@
- gint i;
- GdkPixmap *pixmap;
- GdkImage *img;
-+ SkinPixmap *eqmainpm;
-+
- g_assert(skin != NULL);
-- SkinPixmap *eqmainpm = &skin->pixmaps[SKIN_EQMAIN];
-+ eqmainpm = &skin->pixmaps[SKIN_EQMAIN];
- if (eqmainpm->pixmap != NULL &&
- eqmainpm->current_width >= 116 && eqmainpm->current_height >= 313)
- pixmap = eqmainpm->pixmap;
diff --git a/multimedia/beep-media-player/files/patch-beep::skinwin.c b/multimedia/beep-media-player/files/patch-beep::skinwin.c
deleted file mode 100644
index 075c12473770..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::skinwin.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- beep/skinwin.c.orig Sat Feb 7 18:16:37 2004
-+++ beep/skinwin.c Sat Feb 7 18:17:50 2004
-@@ -216,11 +216,12 @@
- int i;
- char *str, *skinsdir;
- gchar **list;
-+ GtkTreeView *treeview;
-+ GtkTreeSelection *selection = NULL;
-+ GtkListStore *store;
-
- gtk_widget_set_sensitive(scrolled_win, FALSE);
-- GtkTreeView *treeview = GTK_TREE_VIEW(data);
-- GtkTreeSelection *selection = NULL;
-- GtkListStore *store;
-+ treeview = GTK_TREE_VIEW(data);
-
- selection = gtk_tree_view_get_selection(GTK_TREE_VIEW(treeview));
- store = GTK_LIST_STORE(gtk_tree_view_get_model(treeview));
diff --git a/multimedia/beep-media-player/files/patch-beep::softvolume.c b/multimedia/beep-media-player/files/patch-beep::softvolume.c
deleted file mode 100644
index 18d8e2e060ac..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::softvolume.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- beep/softvolume.c.orig Sat Feb 7 18:18:57 2004
-+++ beep/softvolume.c Sat Feb 7 18:20:03 2004
-@@ -27,11 +27,12 @@
- void soft_volume_load(char *section, SoftVolumeConfig * c)
- {
- ConfigFile *cfgfile;
-+ char *sec;
-
- if (c == NULL)
- return;
-
-- char *sec = (section == NULL ? "xmms" : section);
-+ sec = (section == NULL ? "xmms" : section);
-
- c->enabled = FALSE;
- c->volume_left = 0;
diff --git a/multimedia/beep-media-player/files/patch-beep::textbox.c b/multimedia/beep-media-player/files/patch-beep::textbox.c
deleted file mode 100644
index 4cf2b31b8525..000000000000
--- a/multimedia/beep-media-player/files/patch-beep::textbox.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- beep/textbox.c.orig Sat Feb 7 17:49:22 2004
-+++ beep/textbox.c Sat Feb 7 17:49:58 2004
-@@ -142,9 +142,9 @@
-
- void textbox_set_text(TextBox * tb, gchar * text)
- {
--
-- lock_widget(tb);
-- gchar *utf8text;
-+ gchar *utf8text;
-+
-+ lock_widget(tb);
- if (tb->tb_text) {
- if (!strcmp(text, tb->tb_text)) {
- unlock_widget(tb);
diff --git a/multimedia/beep-media-player/pkg-message b/multimedia/beep-media-player/pkg-message
index f08e7f569df6..ba8e5eb034da 100644
--- a/multimedia/beep-media-player/pkg-message
+++ b/multimedia/beep-media-player/pkg-message
@@ -1,2 +1,14 @@
beep supports Gzipped and uncompressed skins. If you would like to use
Zip format skins you will need to ensure archivers/unzip is installed.
+
+FreeBSD 5.x users should add the following to their /etc/libmap.conf
+
+# Might crash if used with libpthread
+[beep-media-player]
+libc_r.so.5 libc_r.so.5
+libc_r.so libc_r.so
+
+[/usr/X11R6/bin/beep-media-player]
+libc_r.so.5 libc_r.so.5
+libc_r.so libc_r.so
+
diff --git a/multimedia/beep-media-player/pkg-plist b/multimedia/beep-media-player/pkg-plist
index a5d4a745a201..63fe4102fe7e 100644
--- a/multimedia/beep-media-player/pkg-plist
+++ b/multimedia/beep-media-player/pkg-plist
@@ -1,24 +1,26 @@
-bin/beep-config
bin/beep-media-player
-include/beep/beepctrl.h
-include/beep/configfile.h
-include/beep/dirbrowser.h
-include/beep/formatter.h
+include/bmp/beepctrl.h
+include/bmp/configfile.h
+include/bmp/dirbrowser.h
+include/bmp/formatter.h
include/bmp/fullscreen.h
include/bmp/plugin.h
-include/beep/titlestring.h
-include/beep/util.h
+include/bmp/titlestring.h
+include/bmp/util.h
+include/bmp/vfs.h
+include/bmp/rcfile.h
+include/bmp/configdb.h
lib/libbeep.a
lib/libbeep.so
-lib/libbeep.so.1
+lib/libbeep.so.2
lib/bmp/Input/libcdaudio.so
lib/bmp/Input/libmpg123.so
%%VORBISPLUGIN:%%lib/bmp/Input/libvorbis.so
lib/bmp/Output/libOSS.so
%%ESDPLUGIN:%%lib/bmp/Output/libesdout.so
lib/bmp/Visualization/libbscope.so
-libdata/pkgconfig/beep.pc
-share/aclocal/beep.m4
+libdata/pkgconfig/bmp.pc
+share/applications/bmp.desktop
share/bmp/Skins/Default/Avs.bmp
share/bmp/Skins/Default/Balance.bmp
share/bmp/Skins/Default/Eq_ex.bmp
@@ -39,16 +41,36 @@ share/bmp/Skins/Default/pLedit.txt
share/bmp/Skins/Default/readme.txt
share/bmp/Skins/Default/screenshot.bmp
share/bmp/Skins/Default/vIscolor.txt
-share/bmp/beep_logo.xpm
-share/bmp/beep.svg
-share/applications/beep.desktop
+share/icons/bmp.svg
+share/bmp/glade/equalizerwin_preset_menu.glade
+share/bmp/glade/prefswin.glade
+share/bmp/images/appearance.png
+share/bmp/images/mouse.png
+share/bmp/images/playlist.png
+share/bmp/images/plugins.png
+share/bmp/images/eq.png
share/locale/fr/LC_MESSAGES/bmp.mo
+share/locale/cy/LC_MESSAGES/bmp.mo
+share/locale/de/LC_MESSAGES/bmp.mo
+share/locale/es/LC_MESSAGES/bmp.mo
+share/locale/it/LC_MESSAGES/bmp.mo
+share/locale/ja/LC_MESSAGES/bmp.mo
+share/locale/ko/LC_MESSAGES/bmp.mo
+share/locale/lt/LC_MESSAGES/bmp.mo
+share/locale/nl/LC_MESSAGES/bmp.mo
+share/locale/pl/LC_MESSAGES/bmp.mo
+share/locale/ru/LC_MESSAGES/bmp.mo
+share/locale/sv/LC_MESSAGES/bmp.mo
+share/locale/zh_CN/LC_MESSAGES/bmp.mo
+@dirrm share/beep/Skins
+@dirrm share/beep
@dirrm share/bmp/Skins/Default
@dirrm share/bmp/Skins
+@dirrm share/bmp/glade
+@dirrm share/bmp/images
@dirrm share/bmp
@dirrm lib/bmp/Visualization
@dirrm lib/bmp/Output
@dirrm lib/bmp/Input
@dirrm lib/bmp
@dirrm include/bmp
-@dirrm include/beep