aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bmpx
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-09-09 12:52:58 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-09-09 12:52:58 +0000
commit7d32b40c8a541a122326030846bfeeaa89c7a732 (patch)
tree46131172a76f9e98562bff457ba9b77421b4cc92 /multimedia/bmpx
parent035ba269ea1694932951753c544219c27ba9329e (diff)
downloadports-7d32b40c8a541a122326030846bfeeaa89c7a732.tar.gz
ports-7d32b40c8a541a122326030846bfeeaa89c7a732.zip
Notes
Diffstat (limited to 'multimedia/bmpx')
-rw-r--r--multimedia/bmpx/Makefile6
-rw-r--r--multimedia/bmpx/distinfo6
-rw-r--r--multimedia/bmpx/files/patch-docs-Makefile.am23
-rw-r--r--multimedia/bmpx/files/patch-src-lastfm.cc33
-rw-r--r--multimedia/bmpx/pkg-plist127
5 files changed, 49 insertions, 146 deletions
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index a9d3d245f85c..3516194a334d 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bmpx
-PORTVERSION= 0.40.1
-PORTREVISION= 1
+PORTVERSION= 0.40.3
CATEGORIES= multimedia
MASTER_SITES= http://files.beep-media-player.org/releases/0.40/
@@ -41,7 +40,8 @@ USE_SQLITE= 3
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-pkgconfig-dir=${PREFIX}/libdata/pkgconfig \
--with-dbus-services-dir="${PREFIX}/share/dbus-1/services" \
- --with-libintl-prefix="${LOCALBASE}"
+ --with-libintl-prefix="${LOCALBASE}" \
+ --disable-doc
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/multimedia/bmpx/distinfo b/multimedia/bmpx/distinfo
index 8dec6de979b2..367ba8fff89b 100644
--- a/multimedia/bmpx/distinfo
+++ b/multimedia/bmpx/distinfo
@@ -1,3 +1,3 @@
-MD5 (bmpx-0.40.1.tar.bz2) = 0bcc992610a9c700b2fef4337e194f7a
-SHA256 (bmpx-0.40.1.tar.bz2) = ccbaf3b0520f993ec96e54912fcf15e9feef05d37456cb235f86821ca1f5dc67
-SIZE (bmpx-0.40.1.tar.bz2) = 1793356
+MD5 (bmpx-0.40.3.tar.bz2) = 1288b8c605c5f1dc45f13bf372023483
+SHA256 (bmpx-0.40.3.tar.bz2) = 24b856a2ceb6d10e1301b951371b8f1c9e53ed1eb5d89b6a948ccd0ca5bf509c
+SIZE (bmpx-0.40.3.tar.bz2) = 1756642
diff --git a/multimedia/bmpx/files/patch-docs-Makefile.am b/multimedia/bmpx/files/patch-docs-Makefile.am
deleted file mode 100644
index 0b4824b11756..000000000000
--- a/multimedia/bmpx/files/patch-docs-Makefile.am
+++ /dev/null
@@ -1,23 +0,0 @@
---- docs/Makefile.am.orig 2007-08-11 22:41:52.000000000 +0400
-+++ docs/Makefile.am 2007-08-18 00:24:09.000000000 +0400
-@@ -1,19 +1,8 @@
- EXTRA_DIST = book.xml style.css
--SUBDIRS = images chapters xsl
-+SUBDIRS = chapters xsl
-
--if GENERATE_DOC
--
--all-local: *.html
--pkgdoc_DATA = *.html
--pkgdocdir=$(prefix)/share/doc/@PACKAGE@/html
--*.html:
-- @XSLTPROC@ --output . $(top_srcdir)/docs/xsl/bump.xsl $(top_srcdir)/docs/book.xml
--clean-local:
-- rm -f *.html
--else
- all-local:
- clean-local:
--endif
-
- CLEANFILES=*.html
- DISTCLEANFILES=$(CLEANFILES)
diff --git a/multimedia/bmpx/files/patch-src-lastfm.cc b/multimedia/bmpx/files/patch-src-lastfm.cc
deleted file mode 100644
index daaa5e47a025..000000000000
--- a/multimedia/bmpx/files/patch-src-lastfm.cc
+++ /dev/null
@@ -1,33 +0,0 @@
---- src/lastfm.cc.orig 2007-08-13 11:41:28.000000000 +0200
-+++ src/lastfm.cc 2007-08-13 11:41:17.000000000 +0200
-@@ -607,7 +607,7 @@
- Radio::get_xspf_playlist ()
- {
- XSPF::Playlist playlist;
-- std::string uri ((boost::format ("http://%s/%s/xspf.php?sk=%s&discovery=%d&desktop=1.3.0.58")
-+ std::string uri ((boost::format ("http://%s%s/xspf.php?sk=%s&discovery=%d&desktop=1.3.0.58")
- % m_session.base_url
- % m_session.base_path
- % m_session.session
-@@ -618,6 +618,8 @@
-
- if (code == 401)
- {
-+ m_connected = false;
-+ signal_disconnected_.emit ();
- throw LastFMStreamTuningError (_( "Invalid Session, please re-handshake." ));
- }
-
-@@ -1023,6 +1025,12 @@
- void
- Scrobbler::scrobble_request_run ()
- {
-+ if (!Network::check_connected())
-+ {
-+ save_lqm (m_queue_filename);
-+ return;
-+ }
-+
- static boost::format
- f_queue_head ("s=%s&");
- static boost::format
diff --git a/multimedia/bmpx/pkg-plist b/multimedia/bmpx/pkg-plist
index 0d8c69005bce..09fe9307b08d 100644
--- a/multimedia/bmpx/pkg-plist
+++ b/multimedia/bmpx/pkg-plist
@@ -1,14 +1,9 @@
bin/beep-media-player-2
-bin/bmp-enqueue-files-2.0
-bin/bmp-enqueue-uris-2.0
bin/bmp-play-files-2.0
-bin/bmp-play-lastfm-2.0
+bin/bmp-play-uris-2.0
bin/bmp2
include/bmp-2.0/bmp/bmp.hh
include/bmp-2.0/bmp/dbus.hh
-lib/libbmp_id3v2_reader.so.0
-lib/libbmp_id3v2_reader.so
-lib/libbmp_id3v2_reader.la
lib/bmpx/plugins/taglib/libtaglib_plugin_flac.la
lib/bmpx/plugins/taglib/libtaglib_plugin_flac.so
lib/bmpx/plugins/taglib/libtaglib_plugin_flac.so.0
@@ -53,7 +48,6 @@ libexec/beep-media-player-2-bin
libexec/beep-media-player-2-sentinel
share/applications/bmp-2.0-offline.desktop
share/applications/bmp-2.0.desktop
-share/applications/bmp-enqueue-2.0.desktop
share/applications/bmp-play-2.0.desktop
%%DATADIR%%/glade/dialog-add-podcast.glade
%%DATADIR%%/glade/dialog-equalizer.glade
@@ -64,6 +58,7 @@ share/applications/bmp-play-2.0.desktop
%%DATADIR%%/glade/dialog-lastfm-tag.glade
%%DATADIR%%/glade/dialog-play-uri.glade
%%DATADIR%%/glade/dialog-progress.glade
+%%DATADIR%%/glade/dialog-remove-update-podcast.glade
%%DATADIR%%/glade/dialog-simple-entry.glade
%%DATADIR%%/glade/dialog-simple-progress.glade
%%DATADIR%%/glade/dialog-track-details.glade
@@ -143,76 +138,13 @@ share/applications/bmp-play-2.0.desktop
%%DATADIR%%/icons/tray-icons/tray-icon-default.png
%%DATADIR%%/icons/tray-icons/tray-icon-paused.png
%%DATADIR%%/icons/tray-icons/tray-icon-playing.png
-%%DATADIR%%/images/audio-default-no-background.png
-%%DATADIR%%/images/audio-default.png
-%%DATADIR%%/images/cdda/audiocd-big.png
-%%DATADIR%%/images/cdda/audiocd-unplayable.png
-%%DATADIR%%/images/collections/collection.png
%%DATADIR%%/images/cover-frame.png
-%%DATADIR%%/images/hal/dev-cdrom.png
-%%DATADIR%%/images/hal/dev-volume-1394.png
-%%DATADIR%%/images/hal/dev-volume-ide.png
-%%DATADIR%%/images/hal/dev-volume-usb.png
-%%DATADIR%%/images/hal/device-camera.png
-%%DATADIR%%/images/hal/device-cdrom.png
-%%DATADIR%%/images/hal/device-cf-card.png
-%%DATADIR%%/images/hal/device-floppy.png
-%%DATADIR%%/images/hal/device-harddrive-1394.png
-%%DATADIR%%/images/hal/device-harddrive-usb.png
-%%DATADIR%%/images/hal/device-harddrive.png
-%%DATADIR%%/images/hal/device-ipod.png
-%%DATADIR%%/images/hal/device-ms.png
-%%DATADIR%%/images/hal/device-removable-1394.png
-%%DATADIR%%/images/hal/device-removable-usb.png
-%%DATADIR%%/images/hal/device-removable.png
-%%DATADIR%%/images/hal/device-sdmmc-card.png
-%%DATADIR%%/images/hal/device-sm-card.png
-%%DATADIR%%/images/lastfm/audioscrobbler.png
-%%DATADIR%%/images/lastfm/header-logo-left.png
-%%DATADIR%%/images/lastfm/header-logo-right.png
-%%DATADIR%%/images/lastfm/header-logo-slice.png
-%%DATADIR%%/images/lastfm/lastfm-album.png
-%%DATADIR%%/images/lastfm/lastfm-artist.png
-%%DATADIR%%/images/lastfm/lastfm-friend.png
-%%DATADIR%%/images/lastfm/lastfm-mainuser.png
-%%DATADIR%%/images/lastfm/lastfm-neighbour.png
-%%DATADIR%%/images/lastfm/lastfm-recommended-radio.png
-%%DATADIR%%/images/lastfm/lastfm-station-small.png
-%%DATADIR%%/images/lastfm/lastfm-station.png
-%%DATADIR%%/images/lastfm/lastfm-tag.png
-%%DATADIR%%/images/lastfm/lastfm-track.png
-%%DATADIR%%/images/lastfm/lastfm-user.png
-%%DATADIR%%/images/logo-about.png
%%DATADIR%%/images/logo-splash.png
-%%DATADIR%%/images/main/header-logo-left.png
-%%DATADIR%%/images/main/header-logo-right.png
-%%DATADIR%%/images/main/header-logo-slice.png
-%%DATADIR%%/images/main/warning.png
-%%DATADIR%%/images/main/yingyang.gif
-%%DATADIR%%/images/main/yingyang_paused.gif
-%%DATADIR%%/images/main/yingyang_seeking.png
-%%DATADIR%%/images/podcast/feed-default.png
-%%DATADIR%%/images/podcast/feed-expired.png
-%%DATADIR%%/images/preferences/lastfm.png
-%%DATADIR%%/images/preferences/library.png
-%%DATADIR%%/images/preferences/misc.png
-%%DATADIR%%/images/preferences/museek.png
-%%DATADIR%%/images/preferences/musicbrainz.png
-%%DATADIR%%/images/preferences/playback.png
-%%DATADIR%%/images/preferences/podcasts.png
-%%DATADIR%%/images/rating/stars_0.png
-%%DATADIR%%/images/rating/stars_1.png
-%%DATADIR%%/images/rating/stars_2.png
-%%DATADIR%%/images/rating/stars_3.png
-%%DATADIR%%/images/rating/stars_4.png
-%%DATADIR%%/images/rating/stars_5.png
-%%DATADIR%%/images/sources/audiocd.png
-%%DATADIR%%/images/sources/jamendo.png
-%%DATADIR%%/images/sources/lastfm.png
-%%DATADIR%%/images/sources/library.png
-%%DATADIR%%/images/sources/playlist.png
-%%DATADIR%%/images/sources/podcasts.png
-%%DATADIR%%/images/sources/radio.png
+%%DATADIR%%/images/logo-about.png
+%%DATADIR%%/images/audio-default.png
+%%DATADIR%%/images/throbber.gif
+%%DATADIR%%/images/svg/button-background.svg
+%%DATADIR%%/images/svg/button-outline.svg
%%DATADIR%%/images/stock/approve-partial.png
%%DATADIR%%/images/stock/approve.png
%%DATADIR%%/images/stock/artist-blackstar.png
@@ -253,7 +185,6 @@ share/applications/bmp-play-2.0.desktop
%%DATADIR%%/images/stock/silk-feed_delete.png
%%DATADIR%%/images/stock/silk-feed_disk.png
%%DATADIR%%/images/stock/silk-folder.png
-%%DATADIR%%/images/stock/silk-html.png
%%DATADIR%%/images/stock/silk-new.png
%%DATADIR%%/images/stock/silk-picture.png
%%DATADIR%%/images/stock/silk-plugin.png
@@ -263,17 +194,49 @@ share/applications/bmp-play-2.0.desktop
%%DATADIR%%/images/stock/tag.png
%%DATADIR%%/images/stock/track.png
%%DATADIR%%/images/stock/undo.png
+%%DATADIR%%/images/stock/web.png
%%DATADIR%%/images/stock/xiph.png
-%%DATADIR%%/images/svg/button-background.svg
-%%DATADIR%%/images/svg/button-outline.svg
-%%DATADIR%%/images/throbber.gif
+%%DATADIR%%/images/sources/audiocd.png
+%%DATADIR%%/images/sources/jamendo.png
+%%DATADIR%%/images/sources/lastfm.png
+%%DATADIR%%/images/sources/library.png
+%%DATADIR%%/images/sources/playlist.png
+%%DATADIR%%/images/sources/podcasts.png
+%%DATADIR%%/images/sources/radio.png
+%%DATADIR%%/images/rating/stars_0.png
+%%DATADIR%%/images/rating/stars_1.png
+%%DATADIR%%/images/rating/stars_2.png
+%%DATADIR%%/images/rating/stars_3.png
+%%DATADIR%%/images/rating/stars_4.png
+%%DATADIR%%/images/rating/stars_5.png
+%%DATADIR%%/images/podcast/feed-default.png
+%%DATADIR%%/images/podcast/feed-expired.png
+%%DATADIR%%/images/podcast/updating.png
+%%DATADIR%%/images/main/paused.gif
+%%DATADIR%%/images/lastfm/audioscrobbler.png
+%%DATADIR%%/images/lastfm/header-logo-left.png
+%%DATADIR%%/images/lastfm/header-logo-right.png
+%%DATADIR%%/images/lastfm/header-logo-slice.png
+%%DATADIR%%/images/lastfm/lastfm-album.png
+%%DATADIR%%/images/lastfm/lastfm-artist.png
+%%DATADIR%%/images/lastfm/lastfm-friend.png
+%%DATADIR%%/images/lastfm/lastfm-mainuser.png
+%%DATADIR%%/images/lastfm/lastfm-neighbour.png
+%%DATADIR%%/images/lastfm/lastfm-recommended-radio.png
+%%DATADIR%%/images/lastfm/lastfm-station-small.png
+%%DATADIR%%/images/lastfm/lastfm-station.png
+%%DATADIR%%/images/lastfm/lastfm-tag.png
+%%DATADIR%%/images/lastfm/lastfm-track.png
+%%DATADIR%%/images/lastfm/lastfm-user.png
+%%DATADIR%%/images/cdda/audiocd-big.png
+%%DATADIR%%/images/cdda/audiocd-unplayable.png
share/dbus-1/services/org.beepmediaplayer.sentinel.service
share/dbus-1/services/org.mpris.bmp.service
share/icons/hicolor/48x48/apps/bmpx.png
%%NLS%%share/locale/af/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/cs/LC_MESSAGES/bmpx.mo
+%%NLS%%share/locale/da/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/de/LC_MESSAGES/bmpx.mo
-%%NLS%%share/locale/dk/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/el/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/es/LC_MESSAGES/bmpx.mo
%%NLS%%share/locale/et/LC_MESSAGES/bmpx.mo
@@ -302,13 +265,9 @@ share/icons/hicolor/48x48/apps/bmpx.png
@dirrm %%DATADIR%%/images/stock
@dirrm %%DATADIR%%/images/sources
@dirrm %%DATADIR%%/images/rating
-@dirrm %%DATADIR%%/images/preferences
@dirrm %%DATADIR%%/images/podcast
@dirrm %%DATADIR%%/images/main
-@dirrm %%DATADIR%%/images/library
@dirrm %%DATADIR%%/images/lastfm
-@dirrm %%DATADIR%%/images/hal
-@dirrm %%DATADIR%%/images/collections
@dirrm %%DATADIR%%/images/cdda
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/icons/tray-icons