aboutsummaryrefslogtreecommitdiff
path: root/multimedia/camserv
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-03-04 06:29:01 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-03-04 06:29:01 +0000
commit6ec66a1081be04f426e77ba33e118390e49cd726 (patch)
treeb76c28b8db904816d52c2e7307f054e1942e0307 /multimedia/camserv
parent5a889036fcd2f767993704db7dbf3c5b3968d35a (diff)
downloadports-6ec66a1081be04f426e77ba33e118390e49cd726.tar.gz
ports-6ec66a1081be04f426e77ba33e118390e49cd726.zip
Notes
Diffstat (limited to 'multimedia/camserv')
-rw-r--r--multimedia/camserv/Makefile36
-rw-r--r--multimedia/camserv/distinfo3
-rw-r--r--multimedia/camserv/files/patch-Makefile.in11
-rw-r--r--multimedia/camserv/files/patch-aa178
-rw-r--r--multimedia/camserv/files/patch-camserv.cfg78
-rw-r--r--multimedia/camserv/files/patch-configure11
-rw-r--r--multimedia/camserv/pkg-descr2
-rw-r--r--multimedia/camserv/pkg-plist58
8 files changed, 149 insertions, 228 deletions
diff --git a/multimedia/camserv/Makefile b/multimedia/camserv/Makefile
index 9a358b4b3838..06cb5c64d9c5 100644
--- a/multimedia/camserv/Makefile
+++ b/multimedia/camserv/Makefile
@@ -6,40 +6,30 @@
#
PORTNAME= camserv
-PORTVERSION= 0.42
+PORTVERSION= 0.5.0
+PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= http://cserv.sourceforge.net/old/
MAINTAINER= chein@freebsd.org
COMMENT= Camserv is a free program to do streaming video via the web
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
-
-# Things that should get fixed
-#
-# imlib2 still needs to be ported
-# http://www.us.rasterman.com/files/imlib2-0.0.5.tar.gz
-# imlib2:${PORTSDIR}/graphics/imlib2
-#
-# gtk12 has broken includes ...
-# should look something like this :
-# include <gtk12/gdk/gdkprivate.h>
-# instead of <gdk/gdkprivate.h>
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ Imlib2.2:${PORTSDIR}/graphics/imlib2 \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+USE_X_LIB= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Broken pkg-plist"
-.endif
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include \
+ -I${X11BASE}/include/gtk12 -I${X11BASE}/include/gdk-pixbuf-1.0 \
+ -I${LOCALBASE}/include/glib12" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-install:
-
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/camserv
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/camserv
- ${INSTALL_DATA} ${WRKSRC}/javascript.txt ${PREFIX}/share/doc/camserv
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/javascript.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/camserv/distinfo b/multimedia/camserv/distinfo
index 9990e43986d1..3ab455837a9e 100644
--- a/multimedia/camserv/distinfo
+++ b/multimedia/camserv/distinfo
@@ -1 +1,2 @@
-MD5 (camserv-0.42.tar.gz) = 6afb506499e75d14ef0ba5b4ada305a9
+MD5 (camserv-0.5.0.tar.gz) = d578b54a011e8a4067573afc926ea033
+SIZE (camserv-0.5.0.tar.gz) = 462974
diff --git a/multimedia/camserv/files/patch-Makefile.in b/multimedia/camserv/files/patch-Makefile.in
new file mode 100644
index 000000000000..68f5f89251d5
--- /dev/null
+++ b/multimedia/camserv/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- camserv/Makefile.in.orig Sat Feb 7 00:23:59 2004
++++ camserv/Makefile.in Sat Feb 7 00:24:04 2004
+@@ -85,7 +85,7 @@
+ datadir = @datadir@/camserv
+
+ CPPFLAGS = -DDATDIR=\"${datadir}\"
+-LDFLAGS = -export-dynamic
++LDFLAGS = -export-dynamic @LDFLAGS@
+
+ bin_PROGRAMS = camserv
+ camserv_LDADD = $(LIBLTDL) $(top_srcdir)/common/libcommon.a
diff --git a/multimedia/camserv/files/patch-aa b/multimedia/camserv/files/patch-aa
deleted file mode 100644
index b0c28cf0ad1e..000000000000
--- a/multimedia/camserv/files/patch-aa
+++ /dev/null
@@ -1,178 +0,0 @@
-*** camserv.cfg.orig Sun Feb 13 18:07:06 2000
---- camserv.cfg Sat Aug 19 02:51:13 2000
-***************
-*** 1,45 ****
- # video_basic: The 'basic' color-changing video module.
- [video_basic]
- path /usr/local/lib/libvideo_basic.so
-
-- # video_v4l_bttv: Example of a common BTTV module for video4linux.
-- # port 0 == TV, port 1 = Composite 1, port 2 = Composite 2
-- # frequency == is the channel frequency for the TV
-- # autobright == 0 turns off autobrightness adjusting, otherwise it adjusts
-- # the brightness of the picture every 'autobright' frames.
-- # brightmean == The mean pixel value that is the 'goal' of the autobright.
-- # (0->255)
-- # brightx1->y2 == (x1,y1) top left coords, and (x2,y2) bottom right coords
-- # of a rectangle of which to take the average pixel value.
-- # this is then used in calculating the mean to adjust the
-- # brightness of the image.
-- # mode == the video norm to use: 0 == PAL, 1 == NTSC, 2 == SECAM, 3 == AUTO
-- # color,hue,contrast,brightness,whiteness = 0->60000, representing
-- # the value of each component.
--
-- [video_v4l_bttv]
-- path /usr/local/lib/libvideo_v4l.so
-- device_path /dev/video0
-- port 0
-- mode 3
-- frequency 74.43
-- color 30000
-- hue 30000
-- contrast 30000
-- brightness 30000
-- whiteness 30000
-- autobright 1
-- brightmean 128
-- brightx1 0
-- brighty1 320
-- brightx2 0
-- brighty2 240
--
- # FreeBSD BTTV driver:
- # port 0 = Video
- # 1 = Tuner
- # Channel Sets:
- # nabscst 1
- # cableirc 2
- # cablehrc 3
- # weurope 4
---- 1,14 ----
- # video_basic: The 'basic' color-changing video module.
- [video_basic]
- path /usr/local/lib/libvideo_basic.so
-
- # FreeBSD BTTV driver:
- # port 0 = Video
- # 1 = Tuner
-+ # 2 = S-Video
-+ #
- # Channel Sets:
- # nabscst 1
- # cableirc 2
- # cablehrc 3
- # weurope 4
-***************
-*** 47,78 ****
- # jpncable 6
- # xussr 7
- # australia 8
-
- [video_fbsd_bttv]
-! path /usr/local/lib/libvideo_fbsd_bttv.so.0.0
- port 1
- width 320
- height 240
- autobright 100
- #brightness 0
- #chroma 180
- #contrast 1000
-! channelset 2
-! channel 60
-!
-! [video_v4l_qcam]
-! path /usr/local/lib/libvideo_v4l.so
-! device_path /dev/video1
-! port 0
-! color 30000
-! hue 30000
-! contrast 30000
-! brightness 30000
-! whiteness 30000
-! autobright 0
-!
-
- [jpg_filter]
- path /usr/local/lib/libjpg_filter.so
- quality 30
-
---- 16,35 ----
- # jpncable 6
- # xussr 7
- # australia 8
-
- [video_fbsd_bttv]
-! path /usr/local/lib/libvideo_fbsd_bttv.so
- port 1
- width 320
- height 240
- autobright 100
- #brightness 0
- #chroma 180
- #contrast 1000
-! channelset 1
-! channel 3
-
- [jpg_filter]
- path /usr/local/lib/libjpg_filter.so
- quality 30
-
-***************
-*** 147,157 ****
- # [video] - This section is devoted to all things dealing with the pictures
- # taken by the input video module. These are general things which
- # should be used by all video modules.
-
- [video]
-! video_section video_v4l_bttv
- width 320
- height 240
- maxfps 0
- memhack 1
-
---- 104,114 ----
- # [video] - This section is devoted to all things dealing with the pictures
- # taken by the input video module. These are general things which
- # should be used by all video modules.
-
- [video]
-! video_section video_fbsd_bttv
- width 320
- height 240
- maxfps 0
- memhack 1
-
-*** configure.orig Sun Feb 13 18:33:16 2000
---- configure Sat Aug 19 02:48:27 2000
-***************
-*** 2181,2193 ****
- echo "$ac_t""no" 1>&6
- fi
-
- echo $ac_n "checking for gdk_pixbuf""... $ac_c" 1>&6
- echo "configure:2186: checking for gdk_pixbuf" >&5
-! GDK_PIXBUF_CFLAGS=`$gnomeconfig gdk_pixbuf --cflags`
-! GDK_PIXBUF_LDFLAGS=`$gnomeconfig gdk_pixbuf --libs`
-!
-
- if test "_$GDK_PIXBUF_CFLAGS" != _; then
- HAVE_GDK_PIXBUF_TRUE=
- HAVE_GDK_PIXBUF_FALSE='#'
- else
---- 2181,2196 ----
- echo "$ac_t""no" 1>&6
- fi
-
- echo $ac_n "checking for gdk_pixbuf""... $ac_c" 1>&6
- echo "configure:2186: checking for gdk_pixbuf" >&5
-! echo "gdk_pixbuf seems to be broken in FreeBSD"
-! echo "not configuring GDK Pixbuf filter in this build"
-! # GDK_PIXBUF_CFLAGS=`$gnomeconfig gdk_pixbuf --cflags`
-! # GDK_PIXBUF_LDFLAGS=`$gnomeconfig gdk_pixbuf --libs`
-! GDK_PIXBUF_CFLAGS=
-! GDK_PIXBUF_LDFLAGS=
-
- if test "_$GDK_PIXBUF_CFLAGS" != _; then
- HAVE_GDK_PIXBUF_TRUE=
- HAVE_GDK_PIXBUF_FALSE='#'
- else
diff --git a/multimedia/camserv/files/patch-camserv.cfg b/multimedia/camserv/files/patch-camserv.cfg
new file mode 100644
index 000000000000..c2bb422a4ab6
--- /dev/null
+++ b/multimedia/camserv/files/patch-camserv.cfg
@@ -0,0 +1,78 @@
+--- camserv.cfg.in.orig Fri Mar 8 02:33:16 2002
++++ camserv.cfg.in Sat Feb 7 00:40:42 2004
+@@ -2,42 +2,10 @@
+ [video_basic]
+ path CAMSERV_MODDIR/libvideo_basic.so
+
+-# video_v4l_bttv: Example of a common BTTV module for video4linux.
+-# port 0 == TV, port 1 = Composite 1, port 2 = Composite 2
+-# frequency == is the channel frequency for the TV
+-# autobright == 0 turns off autobrightness adjusting, otherwise it adjusts
+-# the brightness of the picture every 'autobright' frames.
+-# brightmean == The mean pixel value that is the 'goal' of the autobright.
+-# (0->255)
+-# brightx1->y2 == (x1,y1) top left coords, and (x2,y2) bottom right coords
+-# of a rectangle of which to take the average pixel value.
+-# this is then used in calculating the mean to adjust the
+-# brightness of the image.
+-# mode == the video norm to use: 0 == PAL, 1 == NTSC, 2 == SECAM, 3 == AUTO
+-# color,hue,contrast,brightness,whiteness = 0->60000, representing
+-# the value of each component.
+-
+-[video_v4l_bttv]
+-path CAMSERV_MODDIR/libvideo_v4l.so
+-device_path /dev/video0
+-port 0
+-mode 3
+-#frequency 74.43
+-color 30000
+-hue 30000
+-contrast 30000
+-brightness 30000
+-whiteness 30000
+-autobright 1
+-brightmean 128
+-brightx1 0
+-brighty1 320
+-brightx2 0
+-brighty2 240
+-
+ # FreeBSD BTTV driver:
+ # port 0 = Video
+ # 1 = Tuner
++# 2 = S-Video
+ # Channel Sets:
+ # nabscst 1
+ # cableirc 2
+@@ -49,7 +17,7 @@
+ # australia 8
+
+ [video_fbsd_bttv]
+-path CAMSERV_MODDIR/libvideo_fbsd_bttv.so.0.0
++path CAMSERV_MODDIR/libvideo_fbsd_bttv.so
+ port 1
+ width 320
+ height 240
+@@ -57,20 +25,8 @@
+ #brightness 0
+ #chroma 180
+ #contrast 1000
+-channelset 2
+-channel 60
+-
+-[video_v4l_qcam]
+-path CAMSERV_MODDIR/libvideo_v4l.so
+-device_path /dev/video1
+-port 0
+-color 30000
+-hue 30000
+-contrast 30000
+-brightness 30000
+-whiteness 30000
+-autobright 0
+-
++channelset 1
++channel 3
+
+ [jpg_filter]
+ path CAMSERV_MODDIR/libjpg_filter.so
diff --git a/multimedia/camserv/files/patch-configure b/multimedia/camserv/files/patch-configure
new file mode 100644
index 000000000000..54650f9b201c
--- /dev/null
+++ b/multimedia/camserv/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Feb 7 00:01:51 2004
++++ configure Sat Feb 7 00:17:32 2004
+@@ -5465,7 +5465,7 @@
+ if test "$GDKPIXBUF_CONFIG"x != "x"; then
+ GDKPIXBUF_VERSION=`$GDKPIXBUF_CONFIG --version`
+ case "$GDKPIXBUF_VERSION" in
+- 0.11.*) have_gdkpixbuf=yes
++ 0.22.*) have_gdkpixbuf=yes
+ GDKPIXBUF_CFLAGS=`$GDKPIXBUF_CONFIG --cflags`
+ GDKPIXBUF_LIBS=`$GDKPIXBUF_CONFIG --libs`
+ ac_safe=`echo "gdk-pixbuf/gdk-pixbuf.h" | sed 'y%./+-%__p_%'`
diff --git a/multimedia/camserv/pkg-descr b/multimedia/camserv/pkg-descr
index 01660759a946..19f32395e0bf 100644
--- a/multimedia/camserv/pkg-descr
+++ b/multimedia/camserv/pkg-descr
@@ -4,7 +4,7 @@ However, Internet Explorer under Windows cannot apparently handle
the multi-part JPEGs, and therefore a special javascript page must be setup.
One is included in the distribution as an example.
-Currently, the only supported BSD device is the bttv driver.
+Currently, the only supported BSD device is the bktr driver.
Both tunable modes and camera inputs are supported.
WWW: http://cserv.sourceforge.net/
diff --git a/multimedia/camserv/pkg-plist b/multimedia/camserv/pkg-plist
index 0e0a33d23cfb..31806dd00440 100644
--- a/multimedia/camserv/pkg-plist
+++ b/multimedia/camserv/pkg-plist
@@ -1,27 +1,35 @@
bin/camserv
-bin/ccamcmd
bin/relay
-lib/libjpg_filter.a
-lib/libjpg_filter.la
-lib/libjpg_filter.so
-lib/libjpg_filter.so.0
-lib/librand_filter.a
-lib/librand_filter.la
-lib/librand_filter.so
-lib/librand_filter.so.0
-lib/libtext_filter.a
-lib/libtext_filter.la
-lib/libtext_filter.so
-lib/libtext_filter.so.0
-lib/libvideo_basic.a
-lib/libvideo_basic.la
-lib/libvideo_basic.so
-lib/libvideo_basic.so.0
-lib/libvideo_fbsd_bttv.a
-lib/libvideo_fbsd_bttv.la
-lib/libvideo_fbsd_bttv.so
-lib/libvideo_fbsd_bttv.so.0
-share/camserv.cfg
-share/doc/camserv/README
-share/doc/camserv/javascript.txt
-@dirrm share/doc/camserv
+lib/camserv/libgdk_pixbuf_filter.a
+lib/camserv/libgdk_pixbuf_filter.la
+lib/camserv/libgdk_pixbuf_filter.so
+lib/camserv/libgdk_pixbuf_filter.so.0
+lib/camserv/libimlib2_filter.a
+lib/camserv/libimlib2_filter.la
+lib/camserv/libimlib2_filter.so
+lib/camserv/libimlib2_filter.so.0
+lib/camserv/libjpg_filter.a
+lib/camserv/libjpg_filter.la
+lib/camserv/libjpg_filter.so
+lib/camserv/libjpg_filter.so.0
+lib/camserv/librand_filter.a
+lib/camserv/librand_filter.la
+lib/camserv/librand_filter.so
+lib/camserv/librand_filter.so.0
+lib/camserv/libtext_filter.a
+lib/camserv/libtext_filter.la
+lib/camserv/libtext_filter.so
+lib/camserv/libtext_filter.so.0
+lib/camserv/libvideo_basic.a
+lib/camserv/libvideo_basic.la
+lib/camserv/libvideo_basic.so
+lib/camserv/libvideo_basic.so.0
+lib/camserv/libvideo_fbsd_bttv.a
+lib/camserv/libvideo_fbsd_bttv.la
+lib/camserv/libvideo_fbsd_bttv.so
+lib/camserv/libvideo_fbsd_bttv.so.0
+share/camserv/camserv.cfg
+share/camserv/defpage.html
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/javascript.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%