aboutsummaryrefslogtreecommitdiff
path: root/multimedia/cclive
diff options
context:
space:
mode:
authorJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-28 18:41:34 +0000
committerJulien Laffaye <jlaffaye@FreeBSD.org>2011-06-28 18:41:34 +0000
commit9658320ce060fbe1a4b17499434eca05ba03aead (patch)
tree7a82932edc739865a21ffe2892b9dd1d35edc8c3 /multimedia/cclive
parent05b6fb06aa402f51fff83b3a8747b5b920dd10d4 (diff)
downloadports-9658320ce060fbe1a4b17499434eca05ba03aead.tar.gz
ports-9658320ce060fbe1a4b17499434eca05ba03aead.zip
Notes
Diffstat (limited to 'multimedia/cclive')
-rw-r--r--multimedia/cclive/Makefile9
-rw-r--r--multimedia/cclive/distinfo4
-rw-r--r--multimedia/cclive/files/patch-quvi81
3 files changed, 3 insertions, 91 deletions
diff --git a/multimedia/cclive/Makefile b/multimedia/cclive/Makefile
index b5e7850cf371..e30d94337ed5 100644
--- a/multimedia/cclive/Makefile
+++ b/multimedia/cclive/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cclive
-PORTVERSION= 0.7.3.1
-PORTREVISION= 2
+PORTVERSION= 0.7.4.1
CATEGORIES= multimedia net
MASTER_SITES= SF/${PORTNAME}/0.7 \
GOOGLE_CODE
@@ -25,13 +24,7 @@ PLIST_FILES= bin/cclive
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-MANCOMPRESSED= yes
-USE_CMAKE= yes
-USE_GCC= 4.2+
LICENSE= GPLv3
-post-patch:
- @${REINPLACE_CMD} -e '/install / s|share/||' ${WRKSRC}/man1/CMakeLists.txt
-
.include <bsd.port.mk>
diff --git a/multimedia/cclive/distinfo b/multimedia/cclive/distinfo
index a36cb59833d8..24f51a522977 100644
--- a/multimedia/cclive/distinfo
+++ b/multimedia/cclive/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cclive-0.7.3.1.tar.gz) = 5e0b2daa5b12fb3561fb293ebebebfe0c41960fd9ea2b64e5e2c64d34d63ee52
-SIZE (cclive-0.7.3.1.tar.gz) = 65182
+SHA256 (cclive-0.7.4.1.tar.gz) = d12ab2d08ecd1d130b63c597b25830c87a3d2291b038de8ab83a3438514d8b4a
+SIZE (cclive-0.7.4.1.tar.gz) = 422426
diff --git a/multimedia/cclive/files/patch-quvi b/multimedia/cclive/files/patch-quvi
deleted file mode 100644
index 2bb7169e7d77..000000000000
--- a/multimedia/cclive/files/patch-quvi
+++ /dev/null
@@ -1,81 +0,0 @@
---- include/quvicpp/quvicpp.h.orig 2011-03-15 18:17:23.000000000 +0800
-+++ include/quvicpp/quvicpp.h 2011-06-25 07:00:00.000000000 +0800
-@@ -60,12 +60,10 @@
- void verify (const bool);
- void shortened (const bool);
- void statusfunc (quvi_callback_status);
-- void writefunc (quvi_callback_write);
- private:
- void _swap (const options&);
- private:
- quvi_callback_status _statusfunc;
-- quvi_callback_write _writefunc;
- std::string _format;
- bool _verify;
- bool _shortened;
---- src/quvicpp/link.cpp.orig 2011-03-15 18:17:23.000000000 +0800
-+++ src/quvicpp/link.cpp 2011-06-25 07:00:00.000000000 +0800
-@@ -36,7 +36,7 @@
- dst = tmp; \
- } while (0)
- _wrap(QUVIPROP_VIDEOURL, _url, char*);
-- _wrap(QUVIPROP_VIDEOFILECONTENTTYPE, _contentType, char*);
-+ _wrap(QUVIPROP_MEDIACONTENTTYPE, _contentType, char*);
- _wrap(QUVIPROP_VIDEOFILESUFFIX, _suffix, char*);
- _wrap(QUVIPROP_VIDEOFILELENGTH, _length, double);
- #undef _wrap
---- src/quvicpp/options.cpp.orig 2011-03-15 18:17:23.000000000 +0800
-+++ src/quvicpp/options.cpp 2011-06-25 07:00:00.000000000 +0800
-@@ -25,7 +25,6 @@
-
- options::options ()
- : _statusfunc(NULL),
-- _writefunc(NULL),
- _format("default"),
- _verify(true),
- _shortened(true)
-@@ -35,7 +34,6 @@
-
- options::options (const options& opts)
- : _statusfunc(NULL),
-- _writefunc(NULL),
- _format("default"),
- _verify(true),
- _shortened(true)
-@@ -58,7 +56,6 @@
- options::~options ()
- {
- _statusfunc = NULL;
-- _writefunc = NULL;
- }
-
- // Swap.
-@@ -70,7 +67,6 @@
- _verify = qo._verify;
- _shortened = qo._shortened;
- _statusfunc = qo._statusfunc;
-- _writefunc = qo._writefunc;
- }
-
- // Set.
-@@ -91,10 +87,6 @@
- {
- _statusfunc = cb;
- }
--void options::writefunc (quvi_callback_write cb)
--{
-- _writefunc = cb;
--}
-
- } // End namespace.
-
---- src/quvicpp/query.cpp.orig 2011-03-15 18:17:23.000000000 +0800
-+++ src/quvicpp/query.cpp 2011-06-25 07:00:00.000000000 +0800
-@@ -100,7 +100,6 @@
- quvi_setopt(_quvi, QUVIOPT_FORMAT, opts._format.c_str());
-
- quvi_setopt(_quvi, QUVIOPT_STATUSFUNCTION, opts._statusfunc);
-- quvi_setopt(_quvi, QUVIOPT_WRITEFUNCTION, opts._writefunc);
- #ifdef _0
- quvi_setopt(_quvi, QUVIOPT_NOVERIFY, opts._verify ? 1L:0L);
- #endif