aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clive/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-02-07 22:53:47 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-02-07 22:53:47 +0000
commit5024f8840ba3dbed5c39c5b84ce52962529b925d (patch)
tree1475f1823efc0b0cae3f5e03b27a3b4e5fd137e5 /multimedia/clive/Makefile
parent83965ebbccc11e32f097698a83cf37277778aeea (diff)
downloadports-5024f8840ba3dbed5c39c5b84ce52962529b925d.tar.gz
ports-5024f8840ba3dbed5c39c5b84ce52962529b925d.zip
Notes
Diffstat (limited to 'multimedia/clive/Makefile')
-rw-r--r--multimedia/clive/Makefile88
1 files changed, 29 insertions, 59 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index 38a4a06add9b..b369b42451cb 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,86 +6,56 @@
#
PORTNAME= clive
-PORTVERSION= 1.0.2
-#PORTREVISION= 0
-#PORTEPOCH= 0
+PORTVERSION= 2.1.5
+PORTREVISION= 0
CATEGORIES= multimedia
-MASTER_SITES= http://download.gna.org/clive/1.0.x/ \
+MASTER_SITES= GOOGLE_CODE \
SF
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Video extraction utility for YouTube, GoogleVideo, and others
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber
+RUN_DEPENDS= p5-BerkeleyDB>=0.36:${PORTSDIR}/databases/p5-BerkeleyDB \
+ p5-Config-Tiny>=2.12:${PORTSDIR}/devel/p5-Config-Tiny \
+ p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-WWW-Curl>=4.05:${PORTSDIR}/www/p5-WWW-Curl \
+ p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple
-# deskutils/ljclive (same executable/manpage/distfile name)
-CONFLICTS= clive-[0-9]*
+# deskutils/ljclive, multimedia/clive1 (same executable/manpage/distfile name)
+CONFLICTS= *clive-[0-1]*
-GNU_CONFIGURE= yes
+NO_BUILD= yes
+
+OPTIONS= PASTE "Paste URLs from clipboard" off \
+ CLIVEPASS "Enable login passwords" off \
+ SHOW "Show cache entries" off
USE_BZIP2= yes
-# not compatible with 3.0
-USE_PYTHON= 2.4-2.6
+USE_PERL5= 2.5.8+
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
.if !defined(NO_INSTALL_MANPAGES)
-MAN1= ${PORTNAME}.1 ${PORTNAME}-passwd.1
-.else
-CONFIGURE_ARGS= --with-doc=no
+MAN1= ${PORTNAME}.1
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1/
.endif
-OPTIONS= FEEDPARSER "Enable feed parsing" off \
- FFMPEG "Install ffmpeg for re-encoding" off \
- MPLAYER "Install mplayer as video player" off \
- NEWT "Install devel/newt (support for a simple GUI)" off \
- PYCRYPTO "Install pycrypto to encrypt login password" off \
- SQLITE3 "Install sqlite3 for caching visited URLs" off \
- VLC "Install vlc as video player" off \
- XCLIP "Install xclip (read URLs from clipboard)" off \
- XINE "Install xine as video player" off
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-
.include <bsd.port.pre.mk>
-.if defined(WITH_FEEDPARSER)
-RUN_DEPENDS+= ${PKGNAMEPREFIX}feedparser>=4.1_2:${PORTSDIR}/textproc/py-feedparser
-.endif
-
-.if defined(WITH_FFMPEG)
-RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
-.endif
-
-.if defined(WITH_MPLAYER)
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
-.endif
-
-.if defined(WITH_NEWT)
-RUN_DEPENDS+= newt${PYTHON_PKGNAMESUFFIX}>=0.51.0_4:${PORTSDIR}/devel/newt
-.endif
-
-.if defined(WITH_PYCRYPTO)
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.0.1_1:${PORTSDIR}/security/py-pycrypto
-.endif
-
-.if defined(WITH_SQLITE3)
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.5.2_1:${PORTSDIR}/databases/py-sqlite3
-.endif
-
-.if defined(WITH_VLC)
-RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
+.if defined(WITH_PASTE)
+RUN_DEPENDS+= p5-Clipboard>=0.09:${PORTSDIR}/x11/p5-Clipboard
.endif
-.if defined(WITH_XCLIP)
-RUN_DEPENDS+= xclip:${PORTSDIR}/x11/xclip
+.if defined(WITH_SHOW)
+RUN_DEPENDS+= p5-IO-Pager-0.06:${PORTSDIR}/devel/p5-IO-Pager
.endif
-.if defined(WITH_XINE)
-RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
+.if defined(WITH_CLIVEPASS)
+RUN_DEPENDS+= p5-Expect>=1.21:${PORTSDIR}/lang/p5-Expect
.endif
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|g' \
- ${WRKSRC}/src/scripts/clive ${WRKSRC}/src/scripts/clive-passwd
-
.include <bsd.port.post.mk>