aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clive/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-22 15:50:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-22 15:50:56 +0000
commit83fd488d3f9689c6066d13eac9aba1ae016bbf61 (patch)
tree4035e95e0c585623df92071511b58074f93fdc53 /multimedia/clive/Makefile
parentaa84707771a55bbd1ce14edeff653c701a3a68f2 (diff)
Notes
Diffstat (limited to 'multimedia/clive/Makefile')
-rw-r--r--multimedia/clive/Makefile36
1 files changed, 15 insertions, 21 deletions
diff --git a/multimedia/clive/Makefile b/multimedia/clive/Makefile
index 05bb489b3661..99bb9b94fe3a 100644
--- a/multimedia/clive/Makefile
+++ b/multimedia/clive/Makefile
@@ -6,44 +6,38 @@
#
PORTNAME= clive
-PORTVERSION= 2.2.26
+PORTVERSION= 2.3.2
CATEGORIES= multimedia
-MASTER_SITES= SF/${PORTNAME}/2.2
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:R}
MAINTAINER= geekounet@poildetroll.net
COMMENT= Command line video extraction tool for YouTube and others
LICENSE= GPLv3
-RUN_DEPENDS= p5-HTML-Parser>=3.59:${PORTSDIR}/www/p5-HTML-Parser \
- p5-WWW-Curl>=4.05:${PORTSDIR}/www/p5-WWW-Curl \
- p5-Class-Singleton>=1.4:${PORTSDIR}/devel/p5-Class-Singleton \
- p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
- p5-Config-Tiny>=2.12:${PORTSDIR}/devel/p5-Config-Tiny \
- p5-URI>=1.39:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
+ p5-JSON-XS>=2.30:${PORTSDIR}/converters/p5-JSON-XS
+RUN_DEPENDS= p5-Getopt-ArgvFile>=1.11:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
+ p5-JSON-XS>=2.30:${PORTSDIR}/converters/p5-JSON-XS \
+ quvi>=0.2.16.1:${PORTSDIR}/multimedia/quvi
+
+TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
# deskutils/ljclive, multimedia/clive1 (same executable/manpage/distfile name)
CONFLICTS= clive-[0-1]* ljclive-[0-9]*
-OPTIONS= CACHE "With video page cache" off \
- SIGWINCH "With resizing progressbar" on
+PERL_CONFIGURE= yes
MAN1= clive.1
-
-PERL_CONFIGURE= yes
+PLIST_FILES= bin/clive \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/clive/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/clive
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.if defined(WITH_CACHE)
-RUN_DEPENDS+= p5-BerkeleyDB>=0.36:${PORTSDIR}/databases/p5-BerkeleyDB
-.endif
-
-.if defined(WITH_SIGWINCH)
-RUN_DEPENDS+= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS+= p5-version>=0.77:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS+= p5-version>=0.77:${PORTSDIR}/devel/p5-version
.endif
.include <bsd.port.post.mk>