aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clive1/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-12-21 21:13:50 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-12-21 21:13:50 +0000
commit24992dc130ccb00b748cc87e962b2c0b3a5a7873 (patch)
tree07ed3545411dbf50d8f7a7238dddcaca3261de42 /multimedia/clive1/Makefile
parent00e62ff3dc91ea95babc7baddf54a1453c008515 (diff)
downloadports-24992dc130ccb00b748cc87e962b2c0b3a5a7873.tar.gz
ports-24992dc130ccb00b748cc87e962b2c0b3a5a7873.zip
Notes
Diffstat (limited to 'multimedia/clive1/Makefile')
-rw-r--r--multimedia/clive1/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/multimedia/clive1/Makefile b/multimedia/clive1/Makefile
index af9e626de26f..38a4a06add9b 100644
--- a/multimedia/clive1/Makefile
+++ b/multimedia/clive1/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clive
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.2
#PORTREVISION= 0
#PORTEPOCH= 0
CATEGORIES= multimedia
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= nivit@FreeBSD.org
-COMMENT= Video extraction utility for YouTube and Google Video
+COMMENT= Video extraction utility for YouTube, GoogleVideo, and others
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urlgrabber>=3.1.0_1:${PORTSDIR}/www/py-urlgrabber
@@ -26,7 +26,8 @@ CONFLICTS= clive-[0-9]*
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_PYTHON= yes
+# not compatible with 3.0
+USE_PYTHON= 2.4-2.6
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1 ${PORTNAME}-passwd.1
@@ -34,17 +35,23 @@ MAN1= ${PORTNAME}.1 ${PORTNAME}-passwd.1
CONFIGURE_ARGS= --with-doc=no
.endif
-OPTIONS= FFMPEG "Install ffmpeg for re-encoding" off \
+OPTIONS= FEEDPARSER "Enable feed parsing" off \
+ FFMPEG "Install ffmpeg for re-encoding" off \
MPLAYER "Install mplayer as video player" off \
NEWT "Install devel/newt (support for a simple GUI)" off \
PYCRYPTO "Install pycrypto to encrypt login password" off \
SQLITE3 "Install sqlite3 for caching visited URLs" off \
VLC "Install vlc as video player" off \
- XCLIP "Install xclip (read URLs from clipboard)" off
+ XCLIP "Install xclip (read URLs from clipboard)" off \
+ XINE "Install xine as video player" off
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
.include <bsd.port.pre.mk>
+.if defined(WITH_FEEDPARSER)
+RUN_DEPENDS+= ${PKGNAMEPREFIX}feedparser>=4.1_2:${PORTSDIR}/textproc/py-feedparser
+.endif
+
.if defined(WITH_FFMPEG)
RUN_DEPENDS+= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
.endif
@@ -73,4 +80,12 @@ RUN_DEPENDS+= vlc:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS+= xclip:${PORTSDIR}/x11/xclip
.endif
+.if defined(WITH_XINE)
+RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|g' \
+ ${WRKSRC}/src/scripts/clive ${WRKSRC}/src/scripts/clive-passwd
+
.include <bsd.port.post.mk>