aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clutter-gst/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-26 22:05:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-26 22:05:01 +0000
commit558f6d419774e57aa42baf58fa855c61cba2a9b5 (patch)
tree76eb2e3f78217423b6a761e39fb87cd7690eb42e /multimedia/clutter-gst/Makefile
parent1dc127965c67903e79a10874a9460ab9f5cb29db (diff)
downloadports-558f6d419774e57aa42baf58fa855c61cba2a9b5.tar.gz
ports-558f6d419774e57aa42baf58fa855c61cba2a9b5.zip
Notes
Diffstat (limited to 'multimedia/clutter-gst/Makefile')
-rw-r--r--multimedia/clutter-gst/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/multimedia/clutter-gst/Makefile b/multimedia/clutter-gst/Makefile
new file mode 100644
index 000000000000..278b1b836977
--- /dev/null
+++ b/multimedia/clutter-gst/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: clutter-gst
+# Date created: 2008-12-25
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clutter-gst
+PORTVERSION= 0.8.0
+CATEGORIES= multimedia
+MASTER_SITES= http://www.clutter-project.org/sources/${PORTNAME}/0.8/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Clutter GStreamer integration
+
+LIB_DEPENDS= clutter-glx-0.8:${PORTSDIR}/graphics/clutter
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack ltverhack gnomeprefix
+USE_GSTREAMER= yes
+USE_XORG= xp x11
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>