aboutsummaryrefslogtreecommitdiff
path: root/multimedia/clutter-gst3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-08-05 19:13:24 +0000
commitd129587b5d568b0ff5300386f1e1b706c349f38e (patch)
treee398c7b6ea5203fd3953999e6dd9d6c83c9ec931 /multimedia/clutter-gst3
parentc13de12f75988e599e389d9c77ed92db8d927185 (diff)
Notes
Diffstat (limited to 'multimedia/clutter-gst3')
-rw-r--r--multimedia/clutter-gst3/Makefile33
-rw-r--r--multimedia/clutter-gst3/distinfo2
-rw-r--r--multimedia/clutter-gst3/pkg-descr16
-rw-r--r--multimedia/clutter-gst3/pkg-plist49
4 files changed, 100 insertions, 0 deletions
diff --git a/multimedia/clutter-gst3/Makefile b/multimedia/clutter-gst3/Makefile
new file mode 100644
index 000000000000..786d3eee30c8
--- /dev/null
+++ b/multimedia/clutter-gst3/Makefile
@@ -0,0 +1,33 @@
+# Created by: Martin Wilke <miwi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= clutter-gst
+PORTVERSION= 3.0.8
+PORTREVISION= 1
+CATEGORIES= multimedia
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Clutter GStreamer integration
+
+LIB_DEPENDS= libclutter-1.0.so:${PORTSDIR}/graphics/clutter
+
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME= gnomeprefix introspection:build
+GNU_CONFIGURE= yes
+USE_GL= gl
+USE_GSTREAMER1= yes
+USE_XORG= xp x11
+USE_LDCONFIG= yes
+MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+INSTALL_TARGET= install-strip
+
+# The clutter-gst gstreamer plugin is not parrallel installable with
+# the 2.0 version. Don't install it (see @comment in plist) until
+# all users can be ported (upstream task) to the 3.0 version.
+
+.include <bsd.port.mk>
diff --git a/multimedia/clutter-gst3/distinfo b/multimedia/clutter-gst3/distinfo
new file mode 100644
index 000000000000..b74af1e54a7c
--- /dev/null
+++ b/multimedia/clutter-gst3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clutter-gst-3.0.8.tar.xz) = 582e85b88482e16f7ec719363e38fadf84fab4d4baaa21e5227a454b824f135c
+SIZE (clutter-gst-3.0.8.tar.xz) = 390628
diff --git a/multimedia/clutter-gst3/pkg-descr b/multimedia/clutter-gst3/pkg-descr
new file mode 100644
index 000000000000..369054818768
--- /dev/null
+++ b/multimedia/clutter-gst3/pkg-descr
@@ -0,0 +1,16 @@
+Clutter-GStreamer (clutter-gst) is an integration library for using GStreamer
+with Clutter.
+
+Clutter is an open source software library for creating fast, visually
+rich and animated graphical user interfaces. It uses OpenGL for drawing
+primitives and has multiple backends, allowing its usage on different
+platforms.
+
+GStreamer is a streaming media framework, based on graphs of filters
+which operate on media data. Applications using this library can do
+anything from real-time sound processing to playing videos, and just
+about anything else media-related. Its plugin-based architecture means
+that new data types or processing capabilities can be added simply by
+installing new plug-ins.
+
+WWW: http://clutter-project.org/
diff --git a/multimedia/clutter-gst3/pkg-plist b/multimedia/clutter-gst3/pkg-plist
new file mode 100644
index 000000000000..212174c22a59
--- /dev/null
+++ b/multimedia/clutter-gst3/pkg-plist
@@ -0,0 +1,49 @@
+include/clutter-gst-3.0/clutter-gst/clutter-gst-aspectratio.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-camera-device.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-camera-manager.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-camera.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-content.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-crop.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-enum-types.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-playback.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-player.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-types.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-util.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-version.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst-video-sink.h
+include/clutter-gst-3.0/clutter-gst/clutter-gst.h
+lib/girepository-1.0/ClutterGst-3.0.typelib
+@comment See Makefile for comments on this.
+@comment lib/gstreamer-1.0/libgstclutter-3.0.so
+lib/libclutter-gst-3.0.so
+lib/libclutter-gst-3.0.so.0
+lib/libclutter-gst-3.0.so.0.8.0
+libdata/pkgconfig/clutter-gst-3.0.pc
+%%DOCSDIR%%-3.0/ClutterGstAspectratio.html
+%%DOCSDIR%%-3.0/ClutterGstCamera.html
+%%DOCSDIR%%-3.0/ClutterGstCameraDevice.html
+%%DOCSDIR%%-3.0/ClutterGstContent.html
+%%DOCSDIR%%-3.0/ClutterGstCrop.html
+%%DOCSDIR%%-3.0/ClutterGstPlayback.html
+%%DOCSDIR%%-3.0/ClutterGstPlayer.html
+%%DOCSDIR%%-3.0/ch01.html
+%%DOCSDIR%%-3.0/ch02.html
+%%DOCSDIR%%-3.0/ch03.html
+%%DOCSDIR%%-3.0/ch04.html
+%%DOCSDIR%%-3.0/ch05.html
+%%DOCSDIR%%-3.0/clutter-gst-3.0.devhelp2
+%%DOCSDIR%%-3.0/clutter-gst-Utilities.html
+%%DOCSDIR%%-3.0/clutter-gst-Versioning-Macros.html
+%%DOCSDIR%%-3.0/clutter-gst-Video-Sink.html
+%%DOCSDIR%%-3.0/home.png
+%%DOCSDIR%%-3.0/index.html
+%%DOCSDIR%%-3.0/index.sgml
+%%DOCSDIR%%-3.0/left-insensitive.png
+%%DOCSDIR%%-3.0/left.png
+%%DOCSDIR%%-3.0/license.html
+%%DOCSDIR%%-3.0/right-insensitive.png
+%%DOCSDIR%%-3.0/right.png
+%%DOCSDIR%%-3.0/style.css
+%%DOCSDIR%%-3.0/up-insensitive.png
+%%DOCSDIR%%-3.0/up.png
+share/gir-1.0/ClutterGst-3.0.gir