aboutsummaryrefslogtreecommitdiff
path: root/multimedia/deforaos-player/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 13:14:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-19 13:14:50 +0000
commit11730101f07f1dad994722977cc3e1aaf470bd7f (patch)
treecb5a6ccf40438e9d44bd4982faa45e0285c6d52f /multimedia/deforaos-player/Makefile
parentde6fd882fcfd391f57af70403145d3dd7ff25048 (diff)
downloadports-11730101f07f1dad994722977cc3e1aaf470bd7f.tar.gz
ports-11730101f07f1dad994722977cc3e1aaf470bd7f.zip
Notes
Diffstat (limited to 'multimedia/deforaos-player/Makefile')
-rw-r--r--multimedia/deforaos-player/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/multimedia/deforaos-player/Makefile b/multimedia/deforaos-player/Makefile
new file mode 100644
index 000000000000..00aff3377a98
--- /dev/null
+++ b/multimedia/deforaos-player/Makefile
@@ -0,0 +1,24 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= player
+PORTVERSION= 0.1.4
+CATEGORIES= multimedia
+MASTER_SITES= http://www.defora.org/os/download/download/3708/
+DISTNAME= Player-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS desktop media player
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
+ Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+
+USE_GNOME= gtk20 desktopfileutils
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>