aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvd-slideshow
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-19 21:52:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-19 21:52:12 +0000
commit2429e5d4cdedadf17e14a9e41b53c93342c97732 (patch)
tree9a356c3c3eaa70f7d5ddcea2f5309cb3a99d8e24 /multimedia/dvd-slideshow
parent10e471b0d26241bbc28e144446bb416f85eececc (diff)
Notes
Diffstat (limited to 'multimedia/dvd-slideshow')
-rw-r--r--multimedia/dvd-slideshow/Makefile89
-rw-r--r--multimedia/dvd-slideshow/distinfo2
-rw-r--r--multimedia/dvd-slideshow/pkg-descr4
3 files changed, 95 insertions, 0 deletions
diff --git a/multimedia/dvd-slideshow/Makefile b/multimedia/dvd-slideshow/Makefile
new file mode 100644
index 000000000000..b3e3ee95b24c
--- /dev/null
+++ b/multimedia/dvd-slideshow/Makefile
@@ -0,0 +1,89 @@
+# New ports collection makefile for: dvd-slideshow
+# Date created: 2005-02-16
+# Whom: Phil Oleson <oz@nixil.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvd-slideshow
+PORTVERSION= 0.6.0
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= oz@nixil.net
+COMMENT= Script that creates a slideshow-style DVD with some simple menus
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ identify:${PORTSDIR}/graphics/ImageMagick \
+ sox:${PORTSDIR}/audio/sox \
+ dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ ppmtoyuv:${PORTSDIR}/graphics/netpbm \
+ mkisofs:${PORTSDIR}/sysutils/cdrtools
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+OPTIONS= DVDRWTOOLS "Needed to record/burn DVD" off \
+ LAME "Optional support for audio" off \
+ VORBISTOOLS "Optional audio support" off
+
+PLIST_FILES= bin/dvd-slideshow \
+ bin/dvd-menu \
+ bin/gallery2slideshow \
+ bin/jigl2slideshow
+
+MAN1= dvd-slideshow.1 \
+ dvd-menu.1 \
+ gallery2slideshow.1 \
+ jigl2slideshow.1
+
+PORTDOCS= README.html examples.html changelog.html \
+ gallery2slideshow.html dir2slideshow.html \
+ jigl2slideshow.html dvd-encode.html \
+ test_with_background.html dvd-menu.html \
+ test_with_background.txt dvd-slideshow.html \
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/growisofs)
+WITH_DVDRWTOOLS=yes
+.endif
+.if exists(${LOCALBASE}/bin/lame)
+WITH_LAME=yes
+.endif
+.if exists(${LOCALBASE}/bin/oggdec)
+WITH_VORBISTOOLS=yes
+.endif
+
+.if defined(WITH_DVDRWTOOLS)
+RUN_DEPENDS+= growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
+.endif
+.if defined(WITH_LAME)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+.if defined(WITH_VORBISTOOLS)
+RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+pre-patch:
+.for FILE in dvd-slideshow dvd-menu gallery2slideshow jigl2slideshow
+ @${REINPLACE_CMD} -e 's|!/bin/bash|!${PREFIX}/bin/bash|g' ${WRKSRC}/${FILE}
+.endfor
+
+do-install:
+.for FILE in dvd-slideshow dvd-menu gallery2slideshow jigl2slideshow
+ ${INSTALL_SCRIPT} ${WRKSRC}/${FILE} ${PREFIX}/bin
+.endfor
+.for FILE in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/${FILE} ${PREFIX}/man/man1
+.endfor
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/dvd-slideshow/distinfo b/multimedia/dvd-slideshow/distinfo
new file mode 100644
index 000000000000..a856ef7d251b
--- /dev/null
+++ b/multimedia/dvd-slideshow/distinfo
@@ -0,0 +1,2 @@
+MD5 (dvd-slideshow_0.6.0.tar.gz) = e06335611f3108a6caba807633696127
+SIZE (dvd-slideshow_0.6.0.tar.gz) = 57939
diff --git a/multimedia/dvd-slideshow/pkg-descr b/multimedia/dvd-slideshow/pkg-descr
new file mode 100644
index 000000000000..c7f2406f9a94
--- /dev/null
+++ b/multimedia/dvd-slideshow/pkg-descr
@@ -0,0 +1,4 @@
+Script that creates a slideshow-style dvd with some simple menus
+
+Author: Scott Dylewski <scott @ dylewski . com>
+WWW: http://dvd-slideshow.sourceforge.net/