aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvd-slideshow
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-05-30 11:52:44 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-05-30 11:52:44 +0000
commite4e7e370b03765307aacf61370f3ad4b38777228 (patch)
tree1160ef2a3c5a67dde913fd8889f5e9d07a023684 /multimedia/dvd-slideshow
parentb4814eb202d33bb32632fb37671935e68915aebf (diff)
downloadports-e4e7e370b03765307aacf61370f3ad4b38777228.tar.gz
ports-e4e7e370b03765307aacf61370f3ad4b38777228.zip
Notes
Diffstat (limited to 'multimedia/dvd-slideshow')
-rw-r--r--multimedia/dvd-slideshow/Makefile10
-rw-r--r--multimedia/dvd-slideshow/distinfo8
-rw-r--r--multimedia/dvd-slideshow/files/patch-dvd-slideshow14
-rw-r--r--multimedia/dvd-slideshow/pkg-descr3
-rw-r--r--multimedia/dvd-slideshow/pkg-plist16
5 files changed, 22 insertions, 29 deletions
diff --git a/multimedia/dvd-slideshow/Makefile b/multimedia/dvd-slideshow/Makefile
index 808482a9e522..df1de918a593 100644
--- a/multimedia/dvd-slideshow/Makefile
+++ b/multimedia/dvd-slideshow/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= dvd-slideshow
-PORTVERSION= 0.8.2
-PORTREVISION= 5
+PORTVERSION= 0.8.4
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}-2:main \
SF/${PORTNAME}/${PORTNAME}-themes/${THEMEVERSION}-1:themes
DISTFILES= ${PORTNAME}-${PORTVERSION}-2${EXTRACT_SUFX}:main
-THEMEVERSION= 0.8.0
+THEMEVERSION= 0.8.4
MAINTAINER= oz@nixil.net
COMMENT= Script that creates a slideshow-style DVD with some simple menus
@@ -57,11 +56,6 @@ PLIST_SUB+= NOTHEMES=""
.else
PLIST_SUB+= NOTHEMES="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS}
-PLIST_SUB+= NOPORTDOCS="@comment "
-.else
-PLIST_SUB+= NOPORTDOCS=""
-.endif
post-patch:
.for FILE in dvd-slideshow dvd-menu dir2slideshow gallery1-to-slideshow jigl2slideshow
diff --git a/multimedia/dvd-slideshow/distinfo b/multimedia/dvd-slideshow/distinfo
index 0f85b5da66c7..9ae838cdf7a8 100644
--- a/multimedia/dvd-slideshow/distinfo
+++ b/multimedia/dvd-slideshow/distinfo
@@ -1,4 +1,4 @@
-SHA256 (dvd-slideshow-0.8.2-2.tar.gz) = 00ad7d8cced0f72dc8febf80f1cf7d843f8c390aa412ca46ca22ed9521ae0005
-SIZE (dvd-slideshow-0.8.2-2.tar.gz) = 155338
-SHA256 (dvd-slideshow-themes-0.8.0-1.tar.gz) = 56c13c272eb6e850b98f4182acd3c5e90ba378a6ec7fc37e4c47af70b6e25cb5
-SIZE (dvd-slideshow-themes-0.8.0-1.tar.gz) = 1224977
+SHA256 (dvd-slideshow-0.8.4-2.tar.gz) = 0587cbe4b39b415aec232ada3213b4352c3b9eecec82a64594f1deb8b14a809d
+SIZE (dvd-slideshow-0.8.4-2.tar.gz) = 162905
+SHA256 (dvd-slideshow-themes-0.8.4-1.tar.gz) = 3a929836c9a4afbb3b134718ea548d0f562f48c52d0026ff7bc1b99bebc4d5a1
+SIZE (dvd-slideshow-themes-0.8.4-1.tar.gz) = 1225865
diff --git a/multimedia/dvd-slideshow/files/patch-dvd-slideshow b/multimedia/dvd-slideshow/files/patch-dvd-slideshow
index 8be3a0a6a36d..38f0a98471d2 100644
--- a/multimedia/dvd-slideshow/files/patch-dvd-slideshow
+++ b/multimedia/dvd-slideshow/files/patch-dvd-slideshow
@@ -1,6 +1,6 @@
---- dvd-slideshow.orig 2008-12-05 07:48:58.000000000 +0000
-+++ dvd-slideshow 2009-04-13 11:10:55.000000000 +0000
-@@ -3845,7 +3845,7 @@
+--- dvd-slideshow.orig 2011-08-22 11:48:52.000000000 -0600
++++ dvd-slideshow 2013-05-28 15:26:51.000000000 -0600
+@@ -3996,7 +3996,7 @@ do
mkdir -p "$outdir/$newname"_pics
fi
if [ "$copy" -eq 1 ] ; then
@@ -9,10 +9,10 @@
fi
moviefiles=$(( $moviefiles + 1 ))
elif [ "${filetype[$i]}" == 'ogg' ] || [ "${filetype[$i]}" == 'mp3' ] || [ "${filetype[$i]}" == 'wav' ] || [ "${image[$i]}" == 'silence' ] || [ "${filetype[$i]}" == 'm4a' ] || [ "${filetype[$i]}" == 'aac' ] ; then
-@@ -7136,9 +7136,9 @@
- mv "$tmpdir/video1.flv" "$outdir"/"$slideshow_name".flv
- myecho "[dvd-slideshow] Generating video thumbnail..."
- ffmpeg -y -i "$outdir"/"$slideshow_name".flv -f mjpeg -t 0.001 "$outdir"/"$slideshow_name".jpg >> "$ffmpeg_out" 2>&1
+@@ -7407,9 +7407,9 @@ if [ "$output_format" == 'flv' ] ; then
+ fi
+ # myecho "[dvd-slideshow] Generating video thumbnail..."
+ # ffmpeg -threads "$cores" -y -i "$outdir"/"$slideshow_name".flv -f mjpeg -t 0.001 "$outdir"/"$slideshow_name".jpg >> "$ffmpeg_out" 2>&1
- if [ -f "/usr/bin/flvtool2" ] ; then
+ if [ -f "/usr/local/bin/flvtool2" ] ; then
myecho "[dvd-slideshow] Running flvtool2 -U $slideshow_name".flv
diff --git a/multimedia/dvd-slideshow/pkg-descr b/multimedia/dvd-slideshow/pkg-descr
index c7f2406f9a94..bffa0c30155d 100644
--- a/multimedia/dvd-slideshow/pkg-descr
+++ b/multimedia/dvd-slideshow/pkg-descr
@@ -1,4 +1,3 @@
Script that creates a slideshow-style dvd with some simple menus
-Author: Scott Dylewski <scott @ dylewski . com>
-WWW: http://dvd-slideshow.sourceforge.net/
+WWW: http://dvd-slideshow.sourceforge.net/
diff --git a/multimedia/dvd-slideshow/pkg-plist b/multimedia/dvd-slideshow/pkg-plist
index d71d50c02a12..5ac1f436e52b 100644
--- a/multimedia/dvd-slideshow/pkg-plist
+++ b/multimedia/dvd-slideshow/pkg-plist
@@ -3,13 +3,13 @@ bin/dvd-menu
bin/dir2slideshow
bin/gallery1-to-slideshow
bin/jigl2slideshow
-%%NOPORTDOCS%%%%DOCSDIR%%/changelog.html
-%%NOPORTDOCS%%%%DOCSDIR%%/gallery1-to-slideshow.html
-%%NOPORTDOCS%%%%DOCSDIR%%/dir2slideshow.html
-%%NOPORTDOCS%%%%DOCSDIR%%/jigl2slideshow.html
-%%NOPORTDOCS%%%%DOCSDIR%%/dvd-menu.html
-%%NOPORTDOCS%%%%DOCSDIR%%/dvd-slideshow.html
-%%NOPORTDOCS%%%%DOCSDIR%%/dvd-slideshowrc
+%%PORTDOCS%%%%DOCSDIR%%/changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/gallery1-to-slideshow.html
+%%PORTDOCS%%%%DOCSDIR%%/dir2slideshow.html
+%%PORTDOCS%%%%DOCSDIR%%/jigl2slideshow.html
+%%PORTDOCS%%%%DOCSDIR%%/dvd-menu.html
+%%PORTDOCS%%%%DOCSDIR%%/dvd-slideshow.html
+%%PORTDOCS%%%%DOCSDIR%%/dvd-slideshowrc
%%NOTHEMES%%%%DATADIR%%/themes/themes.readme.txt
%%NOTHEMES%%%%DATADIR%%/themes/babyblue/thumbnail.jpg
%%NOTHEMES%%%%DATADIR%%/themes/babyblue/bip.ttf
@@ -66,4 +66,4 @@ bin/jigl2slideshow
%%NOTHEMES%%@dirrmtry %%DATADIR%%/themes
%%NOTHEMES%%@dirrmtry %%DATADIR%%
%%NOTHEMES%%@dirrmtry share/apps
-%%NOPORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%