aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2007-05-25 14:46:51 +0000
committerPierre Beyssac <pb@FreeBSD.org>2007-05-25 14:46:51 +0000
commit9e7be81fc9cf316bdab4e1bd6eec93e01a652d6f (patch)
tree4265fcca4dd02bf4b7b5f65c18faae90f54846a8 /multimedia/dvdauthor
parentfc414c3662568d07f4aacfeb8b35397f86e86e74 (diff)
downloadports-9e7be81fc9cf316bdab4e1bd6eec93e01a652d6f.tar.gz
ports-9e7be81fc9cf316bdab4e1bd6eec93e01a652d6f.zip
Notes
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile6
-rw-r--r--multimedia/dvdauthor/distinfo6
-rw-r--r--multimedia/dvdauthor/files/patch-src__dvdunauthor.c28
3 files changed, 34 insertions, 6 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 6220d1b3191a..7825cdac73df 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.11
-PORTREVISION= 2
+PORTVERSION= 0.6.14
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,7 +22,8 @@ USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-MAN1= dvdauthor.1 spumux.1
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
+MAN1= dvdauthor.1 dvddirdel.1 dvdunauthor.1 mpeg2desc.1 spumux.1 spuunmux.1
.include <bsd.port.pre.mk>
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index c0467f0c3a51..e12fa5890c95 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,3 +1,3 @@
-MD5 (dvdauthor-0.6.11.tar.gz) = d2c45879e4cfb95d410bf603af891e07
-SHA256 (dvdauthor-0.6.11.tar.gz) = 253415ec75fe6dc5a9bc8da1f7291ba5ab42906729c2381fb42eae1dff46c575
-SIZE (dvdauthor-0.6.11.tar.gz) = 288452
+MD5 (dvdauthor-0.6.14.tar.gz) = bd646b47950c4091ffd781d43fd2c5e9
+SHA256 (dvdauthor-0.6.14.tar.gz) = dd1b1512f3ed64938d40541b1f5aff6682898782469992d8caa81e2587a48ef4
+SIZE (dvdauthor-0.6.14.tar.gz) = 319371
diff --git a/multimedia/dvdauthor/files/patch-src__dvdunauthor.c b/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
new file mode 100644
index 000000000000..a7c481d9f3a2
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
@@ -0,0 +1,28 @@
+--- src/dvdunauthor.c.orig Thu Jun 1 06:03:24 2006
++++ src/dvdunauthor.c Sat May 5 20:59:53 2007
+@@ -818,6 +818,7 @@
+ cell_adr_t *cells;
+ int numcells,i,j,totalsect,numsect;
+ clock_t start,now,clkpsec;
++ struct tms tp;
+
+ cptr=titlef?ifo->vts_c_adt:ifo->menu_c_adt;
+ if( cptr ) {
+@@ -836,7 +837,7 @@
+ for( i=0; i<numcells; i++ )
+ totalsect += cells[i].last_sector - cells[i].start_sector + 1;
+ clkpsec=sysconf(_SC_CLK_TCK);
+- start=times(NULL);
++ start=times(&tp);
+
+ for( i=0; i<numcells; i++ ) {
+ int h,b,plen;
+@@ -874,7 +875,7 @@
+ for( b=cells[i].start_sector; b<=cells[i].last_sector; b+=BIGBLOCKSECT ) {
+ int rl=cells[i].last_sector+1-b;
+ if( rl > BIGBLOCKSECT ) rl = BIGBLOCKSECT;
+- now=times(NULL);
++ now=times(&tp);
+ if( now-start>3*clkpsec && numsect>0 ) {
+ int rmn=(totalsect-numsect)*(now-start)/(numsect*clkpsec);
+ fprintf(stderr,"STAT: [%d] VOB %d, Cell %d (%d%%, %d:%02d remain)\r",i,cells[i].vob_id,cells[i].cell_id,(numsect*100+totalsect/2)/totalsect,rmn/60,rmn%60);