aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /multimedia/dvdauthor
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile4
-rw-r--r--multimedia/dvdauthor/files/patch-spuunmux.c19
2 files changed, 21 insertions, 2 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 7172b1005dd7..53fe3cf5c095 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvdauthor
PORTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -46,7 +46,7 @@ CFLAGS+= -DICONV_CONV=yes
.if defined(WITH_IMAGEMAGICK)
LIB_DEPENDS+= MagickWand.5:${PORTSDIR}/graphics/ImageMagick
.else
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.endif
pre-everything::
diff --git a/multimedia/dvdauthor/files/patch-spuunmux.c b/multimedia/dvdauthor/files/patch-spuunmux.c
new file mode 100644
index 000000000000..0ef3496b4962
--- /dev/null
+++ b/multimedia/dvdauthor/files/patch-spuunmux.c
@@ -0,0 +1,19 @@
+--- src/spuunmux.c.orig 2010-05-10 09:27:55.000000000 +0200
++++ src/spuunmux.c 2012-04-27 10:44:31.000000000 +0200
+@@ -39,6 +39,7 @@
+ #include <netinet/in.h>
+
+ #include <png.h>
++#include <zlib.h>
+
+ #include "rgb.h"
+ #include "common.h"
+@@ -610,7 +611,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
+ return -1;
+ } /*if*/
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);