aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2004-04-08 21:47:39 +0000
committerPierre Beyssac <pb@FreeBSD.org>2004-04-08 21:47:39 +0000
commit622c54ad9772421959efe658aff1b53bd5cbdcc3 (patch)
treeebf8cf956baf337f7fa6552d212e29f4c87ee9fc /multimedia/dvdauthor
parent1a8aa9bab8d6dd3d5f54276ca7d78a2c00ce1b27 (diff)
downloadports-622c54ad9772421959efe658aff1b53bd5cbdcc3.tar.gz
ports-622c54ad9772421959efe658aff1b53bd5cbdcc3.zip
Notes
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile56
-rw-r--r--multimedia/dvdauthor/distinfo4
-rw-r--r--multimedia/dvdauthor/files/patch-dvdauthor.c11
-rw-r--r--multimedia/dvdauthor/pkg-plist24
4 files changed, 65 insertions, 30 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 20a9111f7d03..2272bd9a6288 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.9
-PORTREVISION= 1
+PORTVERSION= 0.6.10
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,15 +16,62 @@ COMMENT= Makes a DVD file structure from one or more MPEG2 streams
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
LIB_DEPENDS= dvdread.3:${PORTSDIR}/multimedia/libdvdread \
- png.5:${PORTSDIR}/graphics/png \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
MAN1= dvdauthor.1 spumux.1
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libfreetype.so.9)
+WITH_FREETYPE= yes
+.endif
+.if exists(${LOCALBASE}/lib/libfridibi.so.0)
+WITH_FRIBIDI= yes
+.endif
+.if exists(${LOCALBASE}/lib/libiconv.so)
+WITH_ICONV= yes
+.endif
+.if exists(${LOCALBASE}/lib/libMagick.so.6)
+WITH_IMAGEMAGICK= yes
+.endif
+
+.if defined(WITH_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+.endif
+.if defined(WITH_FRIBIDI)
+LIB_DEPENDS+= libfribidi.0:${PORTSDIR}/converters/fribidi
+.endif
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+.endif
+.if defined(WITH_IMAGEMAGICK)
+LIB_DEPENDS+= Magick.6:${PORTSDIR}/graphics/ImageMagick
+.else
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.endif
+
+pre-everything::
+.if !defined(WITH_FREETYPE)
+ @${ECHO_MSG} "You can enable Freetype support by defining WITH_FREETYPE."
+ @${ECHO_MSG}
+.endif
+.if !defined(WITH_FRIBIDI)
+ @${ECHO_MSG} "You can enable FriBidi support by defining WITH_FRIBIDI."
+ @${ECHO_MSG}
+.endif
+.if !defined(WITH_ICONV)
+ @${ECHO_MSG} "You can enable Iconv support by defining WITH_ICONV."
+ @${ECHO_MSG}
+.endif
+.if !defined(WITH_IMAGEMAGICK)
+ @${ECHO_MSG} "You can enable ImageMagick support by defining WITH_IMAGEMAGICK."
+ @${ECHO_MSG}
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/dvdauthor
@@ -38,4 +84,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index f05e8b2ed2d7..ef555fc7adc7 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,2 +1,2 @@
-MD5 (dvdauthor-0.6.9.tar.gz) = f01c7d62faf67a14695022349e2bb78d
-SIZE (dvdauthor-0.6.9.tar.gz) = 235974
+MD5 (dvdauthor-0.6.10.tar.gz) = e98243cd2a12bd723680dd49536f7318
+SIZE (dvdauthor-0.6.10.tar.gz) = 240010
diff --git a/multimedia/dvdauthor/files/patch-dvdauthor.c b/multimedia/dvdauthor/files/patch-dvdauthor.c
deleted file mode 100644
index bdd616336660..000000000000
--- a/multimedia/dvdauthor/files/patch-dvdauthor.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dvdauthor.c.orig Fri Jan 16 20:55:42 2004
-+++ src/dvdauthor.c Tue Jan 20 17:59:45 2004
-@@ -340,7 +340,7 @@
- if( ch>=va->numaudiotracks )
- va->numaudiotracks=ch+1;
-
-- audiodesc_set_audio_attr(&va->ad[ch],&va->adwarn[ch],attr,s);
-+ return audiodesc_set_audio_attr(&va->ad[ch],&va->adwarn[ch],attr,s);
- }
-
- static int vobgroup_set_subpic_attr(struct vobgroup *va,int attr,char *s,int ch)
diff --git a/multimedia/dvdauthor/pkg-plist b/multimedia/dvdauthor/pkg-plist
index 91ce57bf7aed..710625e75995 100644
--- a/multimedia/dvdauthor/pkg-plist
+++ b/multimedia/dvdauthor/pkg-plist
@@ -4,15 +4,15 @@ bin/dvdunauthor
bin/mpeg2desc
bin/spumux
bin/spuunmux
-%%PORTDOCS%%share/doc/dvdauthor/README
-%%PORTDOCS%%share/doc/dvdauthor/README.FreeBSD
-%%PORTDOCS%%share/doc/dvdauthor/dvdauthor.html
-%%PORTDOCS%%share/doc/dvdauthor/ex-title.html
-%%PORTDOCS%%share/doc/dvdauthor/examples.html
-%%PORTDOCS%%share/doc/dvdauthor/index.html
-%%PORTDOCS%%share/doc/dvdauthor/languages.html
-%%PORTDOCS%%share/doc/dvdauthor/lib.txt
-%%PORTDOCS%%share/doc/dvdauthor/manpages.html
-%%PORTDOCS%%share/doc/dvdauthor/menu.txt
-%%PORTDOCS%%share/doc/dvdauthor/spumux.html
-%%PORTDOCS%%@dirrm share/doc/dvdauthor
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
+%%PORTDOCS%%%%DOCSDIR%%/dvdauthor.html
+%%PORTDOCS%%%%DOCSDIR%%/ex-title.html
+%%PORTDOCS%%%%DOCSDIR%%/examples.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/languages.html
+%%PORTDOCS%%%%DOCSDIR%%/lib.txt
+%%PORTDOCS%%%%DOCSDIR%%/manpages.html
+%%PORTDOCS%%%%DOCSDIR%%/menu.txt
+%%PORTDOCS%%%%DOCSDIR%%/spumux.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%