aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2011-09-16 18:40:28 +0000
committerJuergen Lock <nox@FreeBSD.org>2011-09-16 18:40:28 +0000
commitc6d565ac9f772ee688ed3c947326a319f917c030 (patch)
tree091e5ed49807d5336e8ef7ba35f06f4190f2a2ea /multimedia/dvdauthor
parent940345aeafc7ff0998652bdd2d01f0eede5f6e8c (diff)
downloadports-c6d565ac9f772ee688ed3c947326a319f917c030.tar.gz
ports-c6d565ac9f772ee688ed3c947326a319f917c030.zip
Notes
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile16
-rw-r--r--multimedia/dvdauthor/distinfo4
-rw-r--r--multimedia/dvdauthor/files/patch-src__dvdunauthor.c28
-rw-r--r--multimedia/dvdauthor/files/patch-src__subgen-image.c11
4 files changed, 7 insertions, 52 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index 934c694436af..687c2c071c75 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.18
-PORTREVISION= 2
+PORTVERSION= 0.7.0
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -16,11 +15,13 @@ COMMENT= Makes a DVD file structure from one or more MPEG2 streams
LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread \
fribidi.3:${PORTSDIR}/converters/fribidi \
- xml2.5:${PORTSDIR}/textproc/libxml2
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/dvdauthor
MAN1= dvdauthor.1 dvddirdel.1 dvdunauthor.1 mpeg2desc.1 spumux.1 spuunmux.1
@@ -37,12 +38,9 @@ WITH_ICONV= yes
WITH_IMAGEMAGICK= yes
.endif
-.if defined(WITH_FREETYPE)
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
-.endif
.if defined(WITH_ICONV)
USE_ICONV= yes
-CONFIGURE_ENV+= CFLAGS="-DICONV_CONV=yes"
+CFLAGS+= "-DICONV_CONV=yes"
.endif
.if defined(WITH_IMAGEMAGICK)
LIB_DEPENDS+= MagickWand.4:${PORTSDIR}/graphics/ImageMagick
@@ -51,10 +49,6 @@ LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
.endif
pre-everything::
-.if !defined(WITH_FREETYPE)
- @${ECHO_MSG} "You can enable Freetype support by defining WITH_FREETYPE."
- @${ECHO_MSG}
-.endif
.if !defined(WITH_ICONV)
@${ECHO_MSG} "You can enable Iconv support by defining WITH_ICONV."
@${ECHO_MSG}
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index 2ee2bb777bf7..2d3e4dffb603 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dvdauthor-0.6.18.tar.gz) = 0e21c2d9c09f7e347c4c9bd7b691455f524ec2e91bcafc18b84d7b7fb3a9cb26
-SIZE (dvdauthor-0.6.18.tar.gz) = 392809
+SHA256 (dvdauthor-0.7.0.tar.gz) = aea6af7b99eba38ffa9dc5ad1521c2cc652e043cea0e7482e239d2a3fc2f34d0
+SIZE (dvdauthor-0.7.0.tar.gz) = 414191
diff --git a/multimedia/dvdauthor/files/patch-src__dvdunauthor.c b/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
deleted file mode 100644
index 634a109a9ea3..000000000000
--- a/multimedia/dvdauthor/files/patch-src__dvdunauthor.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/dvdunauthor.c.orig 2010-07-24 18:22:12.113194336 +0200
-+++ src/dvdunauthor.c 2010-07-24 18:19:15.409638405 +0200
-@@ -1033,6 +1033,7 @@
- const cell_adr_t *cells;
- int numcells,i,j,totalsect,numsect;
- clock_t start,now,clkpsec;
-+ struct tms tp;
-
- cptr = titlef ? ifo->vts_c_adt : ifo->menu_c_adt;
- if (cptr)
-@@ -1054,7 +1055,7 @@
- for (i = 0; i < numcells; i++)
- totalsect += cells[i].last_sector - cells[i].start_sector + 1;
- clkpsec = sysconf(_SC_CLK_TCK);
-- start = times(NULL);
-+ start = times(&tp);
-
- for (i = 0; i < numcells; i++)
- {
-@@ -1106,7 +1107,7 @@
- int rl = cells[i].last_sector + 1 - b;
- if (rl > BIGBLOCKSECT)
- rl = BIGBLOCKSECT;
-- now = times(NULL);
-+ now = times(&tp);
- if (now-start > 3 * clkpsec && numsect > 0)
- {
- const int rmn = (totalsect - numsect) * (now - start) / (numsect * clkpsec);
diff --git a/multimedia/dvdauthor/files/patch-src__subgen-image.c b/multimedia/dvdauthor/files/patch-src__subgen-image.c
deleted file mode 100644
index 3108b2be0a6b..000000000000
--- a/multimedia/dvdauthor/files/patch-src__subgen-image.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/subgen-image.c.orig 2007-01-12 19:40:42.000000000 -0600
-+++ src/subgen-image.c 2010-07-15 19:56:30.000000000 -0600
-@@ -203,7 +203,7 @@
- png_struct *ps;
- png_info *pi;
- png_byte **rowp;
-- unsigned long width,height;
-+ png_uint_32 width,height;
- int bit_depth,color_type,channels,x,y;
-
- fp=fopen(s->fname,"rb");