aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthorwizard/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-06 12:18:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-06 12:18:10 +0000
commitbe0a85132202af5035c7e51623348aa22ffa9aa3 (patch)
tree8f7e3c3c76490cf174b3b3bac48afddcd3f15dfa /multimedia/dvdauthorwizard/Makefile
parent1a7ae785a97cae8fd14f7a08c80b98598b17f8a3 (diff)
downloadports-be0a85132202af5035c7e51623348aa22ffa9aa3.tar.gz
ports-be0a85132202af5035c7e51623348aa22ffa9aa3.zip
Notes
Diffstat (limited to 'multimedia/dvdauthorwizard/Makefile')
-rw-r--r--multimedia/dvdauthorwizard/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/multimedia/dvdauthorwizard/Makefile b/multimedia/dvdauthorwizard/Makefile
new file mode 100644
index 000000000000..c939de389de5
--- /dev/null
+++ b/multimedia/dvdauthorwizard/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dvdauthorwizard
+# Date created: 30 May 2007
+# Whom: liu_yinghong@yahoo.com.cn
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvdauthorwizard
+PORTVERSION= 1.4.6
+CATEGORIES= multimedia kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= DVDAuthorWizard-${PORTVERSION}
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= The tool for creating a DVD with fully animated menu from MPEG-2 files
+
+NO_BUILD= yes
+USE_BZIP2= yes
+REINPLACE_ARGS= -i ""
+
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ png2yuv:${PORTSDIR}/multimedia/mjpegtools \
+ sox:${PORTSDIR}/audio/sox \
+ transcode:${PORTSDIR}/multimedia/transcode \
+ kdialog:${PORTSDIR}/x11/kdebase3
+
+do-patch:
+ @${REINPLACE_CMD} 's|/bin/bash|/bin/sh|' ${WRKSRC}/inst.sh
+ @${REINPLACE_CMD} 's|/bin/bash|/usr/local/bin/bash|' \
+ ${WRKSRC}/bin/DVDAuthorWizard-Builder.sh
+
+do-install:
+ @cd ${WRKSRC} && ${SH} inst.sh ${WRKSRC} ${LOCALBASE}
+
+.include <bsd.port.mk>