aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdrip
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-21 10:42:16 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-21 10:42:16 +0000
commitc4f8e57e9c7fa121fcbd1725e7a2f8381373b269 (patch)
tree13ba1fca2fd6ec656bdc96c20a1443abf4074c8a /multimedia/dvdrip
parenta8bb79b1f3b4e0b6f78f1324690b37399943ffd1 (diff)
downloadports-c4f8e57e9c7fa121fcbd1725e7a2f8381373b269.tar.gz
ports-c4f8e57e9c7fa121fcbd1725e7a2f8381373b269.zip
Notes
Diffstat (limited to 'multimedia/dvdrip')
-rw-r--r--multimedia/dvdrip/Makefile14
-rw-r--r--multimedia/dvdrip/distinfo4
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm4
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Config.pm64
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::BurnTab.pm39
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TitleTab.pm49
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TranscodeTab.pm2
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Project.pm38
-rw-r--r--multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm6
-rw-r--r--multimedia/dvdrip/pkg-message2
-rw-r--r--multimedia/dvdrip/pkg-plist19
11 files changed, 100 insertions, 141 deletions
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index 7d0911f97a69..8d6ac69b2856 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= dvdrip
-PORTREVISION= 2
-PORTVERSION= 0.50.18
+PORTVERSION= 0.52.6
CATEGORIES= multimedia
MASTER_SITES= http://www.exit1.org/dvdrip/dist/
DISTNAME= Video-DVDRip-${PORTVERSION}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= This is dvd::rip, a Perl Gtk+ based dvd-ripper
.if !defined(WITHOUT_CLUSTER)
@@ -31,18 +30,21 @@ RUN_DEPENDS+= cdrdao:${PORTSDIR}/sysutils/cdrdao \
vcdimager:${PORTSDIR}/multimedia/vcdimager \
${BUILD_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk \
- ${SITE_PERL}/${PERL_ARCH}/Gtk/Gdk/Pixbuf.pm:${PORTSDIR}/x11-toolkits/p5-GdkPixbuf
+ ${SITE_PERL}/${PERL_ARCH}/Gtk/Gdk/Pixbuf.pm:${PORTSDIR}/x11-toolkits/p5-GdkPixbuf \
+ ${SITE_PERL}/Locale/Messages.pm:${PORTSDIR}/devel/p5-Locale-libintl
PERL_CONFIGURE= yes
USE_PERL5= yes
MAN1= dvdrip.1 dr_splitpipe.1 dr_progress.1
-
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Video::DVDRip.3 Video::DVDRip::CPAN::Scanf.3
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= "Broken dependencies"
+.endif
+
pre-everything::
.if !defined(WITHOUT_CLUSTER)
@${ECHO_MSG}
diff --git a/multimedia/dvdrip/distinfo b/multimedia/dvdrip/distinfo
index cee4eef2cb1f..4cb57228be9f 100644
--- a/multimedia/dvdrip/distinfo
+++ b/multimedia/dvdrip/distinfo
@@ -1,2 +1,2 @@
-MD5 (Video-DVDRip-0.50.18.tar.gz) = bb2a3f48354958bc7d1c6a06263e66c8
-SIZE (Video-DVDRip-0.50.18.tar.gz) = 233184
+MD5 (Video-DVDRip-0.52.6.tar.gz) = 83f972e5053e61ea18b2f9ea40e88a43
+SIZE (Video-DVDRip-0.52.6.tar.gz) = 522611
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm
index 17292ec05a88..25e9239e2955 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Cluster::Title.pm
@@ -1,6 +1,6 @@
--- lib/Video/DVDRip/Cluster/Title.pm.orig Sat Apr 10 11:18:03 2004
+++ lib/Video/DVDRip/Cluster/Title.pm Sun Jan 9 17:41:11 2005
-@@ -276,10 +276,10 @@
+@@ -277,10 +277,10 @@
} else {
$command .=
"dr_exec avimerge".
@@ -22,7 +22,7 @@
-
+ "${nice}dr_exec avimerge -o $audio_video_psu_file";
$command .= " -p $audio_psu_file " if not $self->is_ogg;
-+ $command .= " -i $avi_chunks_dir/*";
++ $command .= " -i $avi_chunks_dir/*";
$command .= " && rm $avi_chunks_dir/*"
if $self->with_cleanup;
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Config.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Config.pm
index a4bedda7078d..0764f05f72d3 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Config.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Config.pm
@@ -1,42 +1,41 @@
---- lib/Video/DVDRip/Config.pm.orig Sun Jun 1 18:01:40 2003
-+++ lib/Video/DVDRip/Config.pm Sun Jun 1 18:07:08 2003
-@@ -51,14 +51,9 @@
- value => 4.2,
- },
+--- lib/Video/DVDRip/Config.pm.orig Sun Aug 14 17:34:52 2005
++++ lib/Video/DVDRip/Config.pm Sun Aug 14 17:39:55 2005
+@@ -57,7 +57,7 @@
dvd_device => {
-- label => "DVD device",
-- type => 'file',
+ label => __"DVD device",
+ type => 'file',
- value => "/dev/dvd",
-- },
-- dvd_mount_point => {
- label => "DVD mount point",
-- type => 'dir',
-+ type => 'file',
- value => "/cdrom",
++ value => "/dev/cd0",
},
+ dvd_mount_point => {
+ label => __"DVD mount point",
+@@ -67,12 +67,12 @@
writer_device => {
- label => "Writer device file",
-@@ -58,7 +58,7 @@
- writer_device => {
- label => "Writer device file",
+ label => __"Writer device file",
type => 'file',
- value => "/dev/cdrom",
-+ value => "/dev/cd0c",
++ value => "/dev/cd0",
},
eject_command => {
- label => "Eject Command",
-@@ -91,7 +86,7 @@
+ label => __"Eject Command",
+ type => 'string',
+- value => "eject",
++ value => "cdcontrol",
+ },
+ play_dvd_command => {
+ label => __"DVD player command",
+@@ -95,7 +95,7 @@
play_stdin_command => {
- label => "STDIN player command",
+ label => __"STDIN player command",
type => 'string',
- value => 'xine stdin://mpeg2 -g -pq -a %a',
+ value => 'mplayer -aid %(%a+128) -',
presets => [
'mplayer -aid %(%a+128) -',
'xine stdin://mpeg2 -g -pq -a %a',
-@@ -147,11 +147,10 @@
+@@ -151,11 +151,10 @@
default_video_codec => {
- label => "Default video codec",
+ label => __"Default video codec",
type => 'string',
- value => 'divx4',
+ value => 'xvid4',
@@ -48,32 +47,23 @@
"ffmpeg","fame","af6"
],
},
-@@ -181,7 +176,7 @@
+@@ -198,7 +197,7 @@
burn_cdrecord_cmd => {
- label => "cdrecord command",
+ label => __"cdrecord command",
type => 'string',
- value => '/usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORD',
+ value => 'cdrecord',
presets => [
'/usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORD',
'cdrecord',
-@@ -235,7 +230,7 @@
-
- my @CONFIG_ORDER = (
- "Filesystem" => [qw(
-- dvd_device dvd_mount_point
-+ dvd_device
- base_project_dir dvdrip_files_dir
- ogg_file_ext
- )],
-@@ -617,8 +617,8 @@
+@@ -791,8 +790,8 @@
sub test_play_file_command { _executable (@_) }
sub test_play_stdin_command { _executable (@_) }
sub test_rar_command { _executable (@_) }
-sub test_dvd_device { _writable (@_) }
-sub test_writer_device { _writable (@_) }
-+sub test_dvd_device { _exists (@_) }
-+sub test_writer_device { _exists (@_) }
++sub test_dvd_device { _exists (@_) }
++sub test_writer_device { _exists (@_) }
sub test_dvd_mount_point { _exists (@_) }
sub test_base_project_dir { _writable (@_) }
sub test_dvdrip_files_dir { _writable (@_) }
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::BurnTab.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::BurnTab.pm
index 64e0354ed40b..2b3b88b6e2cb 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::BurnTab.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::BurnTab.pm
@@ -1,21 +1,20 @@
---- lib/Video/DVDRip/GUI/Project/BurnTab.pm.orig Sun Feb 22 12:33:01 2004
-+++ lib/Video/DVDRip/GUI/Project/BurnTab.pm Sun Feb 22 12:33:22 2004
-@@ -550,18 +550,6 @@
- $button_box->show;
- $frame_vbox->pack_start ($button_box, 0, 1, 0);
+--- lib/Video/DVDRip/GUI/Project/BurnTab.pm.orig Sun Aug 14 17:42:57 2005
++++ lib/Video/DVDRip/GUI/Project/BurnTab.pm Sun Aug 14 17:44:50 2005
+@@ -839,7 +839,7 @@
+ sub eject_media {
+ my $self = shift;
+
+- my $command = $self->config('eject_command') . " " . $self->config('writer_device');
++ my $command = $self->config('eject_command') . " -f " . $self->config('writer_device') . " eject";
+
+ system ("$command &");
+
+@@ -849,7 +849,7 @@
+ sub insert_media {
+ my $self = shift;
+
+- my $command = $self->config('eject_command') . " -t " . $self->config('writer_device');
++ my $command = $self->config('eject_command') . " -f " . $self->config('writer_device') . " close";
+
+ system ("$command &");
-- # Eject Button
-- $button = Gtk::Button->new_with_label (" Open burner tray ");
-- $button->show;
-- $button->signal_connect ("clicked", sub { $self->eject_media } );
-- $button_box->pack_start ($button, 0, 1, 0);
--
-- # Insert Button
-- $button = Gtk::Button->new_with_label (" Close burner tray ");
-- $button->show;
-- $button->signal_connect ("clicked", sub { $self->insert_media } );
-- $button_box->pack_start ($button, 0, 1, 0);
--
- # Blank CD-RW button
- $button = Gtk::Button->new_with_label (" Blank CD-RW ");
- $button->show;
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TitleTab.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TitleTab.pm
index 03b96d89ac60..2179e34fb4db 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TitleTab.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TitleTab.pm
@@ -1,33 +1,20 @@
---- lib/Video/DVDRip/GUI/Project/TitleTab.pm.orig Fri Jun 20 03:15:39 2003
-+++ lib/Video/DVDRip/GUI/Project/TitleTab.pm Fri Jun 20 03:16:55 2003
-@@ -60,30 +60,6 @@
- $hbox->pack_start ( $button, 0, 1, 0);
- # $hbox->pack_start ( $label, 0, 1, 0);
+--- lib/Video/DVDRip/GUI/Project/TitleTab.pm.orig Sun Aug 14 17:46:36 2005
++++ lib/Video/DVDRip/GUI/Project/TitleTab.pm Sun Aug 14 17:46:53 2005
+@@ -965,7 +965,7 @@
+ sub eject_dvd {
+ my $self = shift;
-- # Eject Button
-- $button = Gtk::Button->new_with_label (
-- " Open DVD tray"
-- );
-- $button->show;
-- $button->signal_connect ("clicked",
-- sub { $self->eject_dvd }
-- );
-- $hbox->pack_start ($button, 0, 1, 0);
--
-- $self->rip_title_widgets->{eject_dvd_button} = $button;
--
-- # Insert Button
-- $button = Gtk::Button->new_with_label (
-- " Close DVD tray "
-- );
-- $button->show;
-- $button->signal_connect ("clicked",
-- sub { $self->insert_dvd }
-- );
-- $hbox->pack_start ($button, 0, 1, 0);
--
-- $self->rip_title_widgets->{insert_dvd_button} = $button;
--
- $frame->add ($hbox);
- $vbox->pack_start ( $frame, 0, 1, 0);
+- my $command = $self->config('eject_command') . " " . $self->config('dvd_device');
++ my $command = $self->config('eject_command') . " -f " . $self->config('dvd_device') . " eject";
+ system ("$command &");
+
+@@ -975,7 +975,7 @@
+ sub insert_dvd {
+ my $self = shift;
+
+- my $command = $self->config('eject_command') . " -t " . $self->config('dvd_device');
++ my $command = $self->config('eject_command') . " -f " . $self->config('dvd_device') . " close";
+
+ system ("$command &");
+
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TranscodeTab.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TranscodeTab.pm
index 032ab99a329a..973906e3c836 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TranscodeTab.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::GUI::Project::TranscodeTab.pm
@@ -1,6 +1,6 @@
--- lib/Video/DVDRip/GUI/Project/TranscodeTab.pm.orig Mon Jun 2 15:41:16 2003
+++ lib/Video/DVDRip/GUI/Project/TranscodeTab.pm Mon Jun 2 16:04:28 2003
-@@ -1269,14 +1269,14 @@
+@@ -1348,14 +1348,14 @@
if ( $self->version ("transcode") < 609 ) {
$widgets->{tc_video_codec_combo}
->set_popdown_strings(
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Project.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Project.pm
deleted file mode 100644
index c67de0c78bdb..000000000000
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Project.pm
+++ /dev/null
@@ -1,38 +0,0 @@
---- lib/Video/DVDRip/Project.pm.orig Fri Jan 3 15:22:00 2003
-+++ lib/Video/DVDRip/Project.pm Fri Jan 3 15:24:34 2003
-@@ -272,7 +272,7 @@
- my $dir;
-
- if ( $mode eq 'rip' or $mode eq 'dvd' ) {
-- $dir = $self->config('dvd_mount_point');
-+ $dir = $self->config('dvd_device');
-
- } elsif ( $mode eq 'dvd_image' ) {
- $dir = $self->dvd_image_dir;
-@@ -445,7 +445,7 @@
-
- return 1 if $self->rip_mode eq 'dvd_image';
-
-- my $dvd_mount_point = $self->config('dvd_mount_point');
-+ my $dvd_mount_point = $self->config('dvd_device');
-
- return 1 if -d "$dvd_mount_point/video_ts";
- return 1 if -d "$dvd_mount_point/VIDEO_TS";
-@@ -457,7 +457,7 @@
-
- return 1 if $self->rip_mode eq 'dvd_image';
-
-- my $dvd_mount_point = $self->config('dvd_mount_point');
-+ my $dvd_mount_point = $self->config('dvd_device');
-
- $self->log ("Mounting DVD at $dvd_mount_point");
-
-@@ -476,7 +476,7 @@
-
- return 1 if $self->rip_mode eq 'dvd_image';
-
-- my $dvd_mount_point = $self->config('dvd_mount_point');
-+ my $dvd_mount_point = $self->config('dvd_device');
-
- my $mount = qx[ umount $dvd_mount_point 2>&1 ];
-
diff --git a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm
index b225ecdf31b2..be8f553defff 100644
--- a/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm
+++ b/multimedia/dvdrip/files/patch-lib::Video::DVDRip::Title.pm
@@ -1,6 +1,6 @@
--- lib/Video/DVDRip/Title.pm.orig Wed Dec 29 20:15:48 2004
+++ lib/Video/DVDRip/Title.pm Wed Dec 29 20:16:44 2004
-@@ -2152,10 +2152,10 @@
+@@ -2205,10 +2205,10 @@
$command .=
"dr_exec avimerge".
@@ -13,7 +13,7 @@
" mv $avi_file.merged $avi_file &&".
" rm $audio_file &&".
" echo DVDRIP_SUCCESS";
-@@ -2540,7 +2540,7 @@
+@@ -2595,7 +2595,7 @@
my $target_file = $self->preview_filename( type => $type );
my $catch = $self->system (
@@ -22,7 +22,7 @@
);
my ($width, $height);
($width, $height) = ( $catch =~ /(\d+)x(\d+)/ );
-@@ -2598,7 +2598,7 @@
+@@ -2653,7 +2653,7 @@
}
my $catch = $self->system (
diff --git a/multimedia/dvdrip/pkg-message b/multimedia/dvdrip/pkg-message
index e72d64347307..15b05db8fdf5 100644
--- a/multimedia/dvdrip/pkg-message
+++ b/multimedia/dvdrip/pkg-message
@@ -3,7 +3,7 @@
In order to have automated ripping work right, enable usermount (sysctl
vfs.usermount=1), add a mountpoint for your dvd-drive to your home directory
(mkdir /home/foo/cdrom) and add a corresponding entry to /etc/fstab
-(/dev/cd0c /usr/home/foo/cdrom cd9660 ro,noauto 0 0) and
+(/dev/cd0 /usr/home/foo/cdrom cd9660 ro,noauto 0 0) and
specify this mountpoint in dvd::rip's preferences.
################################################################################
diff --git a/multimedia/dvdrip/pkg-plist b/multimedia/dvdrip/pkg-plist
index dabfd5edce55..3ef440842b22 100644
--- a/multimedia/dvdrip/pkg-plist
+++ b/multimedia/dvdrip/pkg-plist
@@ -94,6 +94,12 @@ bin/dvdrip-master
%%SITE_PERL%%/Video/DVDRip/TranscodeRC.pm
%%SITE_PERL%%/Video/DVDRip/icon.xpm
%%SITE_PERL%%/Video/DVDRip/splash.png
+%%SITE_PERL%%/LocaleData/cs/LC_MESSAGES/video.dvdrip.mo
+%%SITE_PERL%%/LocaleData/de/LC_MESSAGES/video.dvdrip.mo
+%%SITE_PERL%%/LocaleData/es/LC_MESSAGES/video.dvdrip.mo
+%%SITE_PERL%%/LocaleData/fr/LC_MESSAGES/video.dvdrip.mo
+%%SITE_PERL%%/LocaleData/it/LC_MESSAGES/video.dvdrip.mo
+%%SITE_PERL%%/LocaleData/sr/LC_MESSAGES/video.dvdrip.mo
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Video/DVDRip/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Video/DVDRip
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Video 2>/dev/null || true
@@ -108,3 +114,16 @@ bin/dvdrip-master
@dirrm %%SITE_PERL%%/Video/DVDRip/CPAN
@dirrm %%SITE_PERL%%/Video/DVDRip
@unexec rmdir %D/%%SITE_PERL%%/Video 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/cs/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/de/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/es/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/fr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/it/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/sr/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/cs 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/de 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/es 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/fr 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/it 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData/sr 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/LocaleData 2>/dev/null || true