aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdrip
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-20 09:01:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-20 09:01:00 +0000
commit2f77f3b19623f536c0780ab8bbcae38c228e3c6b (patch)
treebc7cfd98f46c33ea5cf63d09775d77f706fc55ea /multimedia/dvdrip
parentf39fa1046fb26fda3bb6e81a4100a34028fa25af (diff)
downloadports-2f77f3b19623f536c0780ab8bbcae38c228e3c6b.tar.gz
ports-2f77f3b19623f536c0780ab8bbcae38c228e3c6b.zip
Notes
Diffstat (limited to 'multimedia/dvdrip')
-rw-r--r--multimedia/dvdrip/Makefile29
-rw-r--r--multimedia/dvdrip/pkg-descr2
2 files changed, 17 insertions, 14 deletions
diff --git a/multimedia/dvdrip/Makefile b/multimedia/dvdrip/Makefile
index ba9af32d9f5b..f57f4aeb4af3 100644
--- a/multimedia/dvdrip/Makefile
+++ b/multimedia/dvdrip/Makefile
@@ -11,6 +11,9 @@ MASTER_SITE_SUBDIR= CPAN:JRED
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl Gtk+ based dvd-ripper
+LICENSE= ART10 GPLv1 # (ART10 or GPLv1) and CC-BY-SA-2.5
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
p5-AnyEvent>=0:devel/p5-AnyEvent \
p5-Event-ExecFlow>=0:devel/p5-Event-ExecFlow \
@@ -32,23 +35,23 @@ RUN_DEPENDS= p5-Gtk2>=0:x11-toolkits/p5-Gtk2 \
${LOCALBASE}/sbin/fping:net/fping \
cdrecord:sysutils/cdrtools
-OPTIONS_DEFINE= VORBIS SUBTITLE RAR
+USES= gettext perl5 shebangfix
+SHEBANG_FILES= bin/dvdrip*
+USE_PERL5= configure patch
+CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
+
+MAKE_JOBS_UNSAFE= yes
+
+OPTIONS_DEFINE= VORBIS SUBTITLE RAR
OPTIONS_DEFAULT= VORBIS SUBTITLE
-RAR_DESC= Support RAR-compressed vobsub subtitles
-SUBTITLE_DESC= Enable support for getting subtitles
+RAR_DESC= Support RAR-compressed vobsub subtitles
+SUBTITLE_DESC= Enable support for getting subtitles
RAR_RUN_DEPENDS= rar:archivers/rar
SUBTITLE_RUN_DEPENDS= subtitle2pgm:multimedia/subtitleripper
VORBIS_RUN_DEPENDS= oggenc:audio/vorbis-tools \
ogmmerge:multimedia/ogmtools
-CONFIGURE_ENV= SKIP_UNPACK_REQUIRED_MODULES=1
-USES= gettext perl5 shebangfix
-USE_PERL5= configure patch
-SHEBANG_FILES= bin/dvdrip*
-
-MAKE_JOBS_UNSAFE= yes
-
post-patch:
@${PERL} -pi -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#' \
${WRKSRC}/lib/Video/DVDRip/Cluster/Master.pm \
@@ -57,9 +60,9 @@ post-patch:
post-install:
.for f in dvdrip-progress dvdrip-splitpipe
- ${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/${f}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
- ${CHMOD} u-w ${STAGEDIR}${PREFIX}/bin/${f}
+ @${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/${f}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
+ @${CHMOD} u-w ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
.include <bsd.port.mk>
diff --git a/multimedia/dvdrip/pkg-descr b/multimedia/dvdrip/pkg-descr
index c7d3832f77d1..7ee0a7d01d75 100644
--- a/multimedia/dvdrip/pkg-descr
+++ b/multimedia/dvdrip/pkg-descr
@@ -3,4 +3,4 @@ convenient frontend to transcode and makes ripping and encoding
DVDs a breeze. It also features a cluster daemon, which can distribute
encoding jobs over multiple machines.
-WWW: http://www.exit1.org/dvdrip/
+WWW: https://www.exit1.org/dvdrip/