aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdstyler
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-04-26 08:21:30 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-04-26 08:21:30 +0000
commit32fa6fb90db11556f39959e73b1bd80f58641d6d (patch)
treed4893a5da827ba15939f962289daacc5b6c72a19 /multimedia/dvdstyler
parent68a7dff26ad609299fc02c5fb2a3df0a2922e3b5 (diff)
downloadports-32fa6fb90db11556f39959e73b1bd80f58641d6d.tar.gz
ports-32fa6fb90db11556f39959e73b1bd80f58641d6d.zip
Notes
Diffstat (limited to 'multimedia/dvdstyler')
-rw-r--r--multimedia/dvdstyler/Makefile8
-rw-r--r--multimedia/dvdstyler/files/dvdstyler.desktop.in10
-rw-r--r--multimedia/dvdstyler/pkg-plist2
3 files changed, 20 insertions, 0 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index e10c84350a48..b04448c007bb 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -26,6 +26,7 @@ LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm \
RUN_DEPENDS= ${BUILD_DEPENDS}
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
+DVDSTYLER_ICON= ${DATADIR}/rc/dvdstyler.png
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_INC_LIBTOOL_VER=15
@@ -61,6 +62,9 @@ pre-everything::
.endif
post-patch:
+ @${SED} -e 's|%%COMMENT%%|${COMMENT}|; \
+ s|%%DVDSTYLER_ICON%%|${DVDSTYLER_ICON}|' \
+ < ${FILESDIR}/dvdstyler.desktop.in > ${WRKDIR}/dvdstyler.desktop
@${REINPLACE_CMD} -e 's|$$prefix/dvdstyler|${DATADIR}|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|@datadir@/docs/@PACKAGE@|${DOCSDIR}|' \
@@ -72,4 +76,8 @@ post-patch:
${WRKSRC}/configure
.endif
+post-install:
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKDIR}/dvdstyler.desktop ${PREFIX}/share/applications
+
.include <bsd.port.post.mk>
diff --git a/multimedia/dvdstyler/files/dvdstyler.desktop.in b/multimedia/dvdstyler/files/dvdstyler.desktop.in
new file mode 100644
index 000000000000..317d0a407b93
--- /dev/null
+++ b/multimedia/dvdstyler/files/dvdstyler.desktop.in
@@ -0,0 +1,10 @@
+# $FreeBSD$
+[Desktop Entry]
+Encoding=UTF-8
+Name=DVDStyler
+Comment=%%COMMENT%%
+Icon=%%DVDSTYLER_ICON%%
+Exec=dvdstyler
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;
diff --git a/multimedia/dvdstyler/pkg-plist b/multimedia/dvdstyler/pkg-plist
index 347cbb806456..3770fab0b88b 100644
--- a/multimedia/dvdstyler/pkg-plist
+++ b/multimedia/dvdstyler/pkg-plist
@@ -24,6 +24,7 @@ bin/dvdstyler
%%DATADIR%%/rc/plus.png
%%DATADIR%%/rc/run.png
%%DATADIR%%/rc/save.png
+share/applications/dvdstyler.desktop
share/locale/ca/LC_MESSAGES/dvdstyler.mo
share/locale/de/LC_MESSAGES/dvdstyler.mo
share/locale/es/LC_MESSAGES/dvdstyler.mo
@@ -33,6 +34,7 @@ share/locale/it/LC_MESSAGES/dvdstyler.mo
share/locale/pl/LC_MESSAGES/dvdstyler.mo
share/locale/pt/LC_MESSAGES/dvdstyler.mo
share/locale/ru/LC_MESSAGES/dvdstyler.mo
+@unexec rmdir %D/share/applications 2>/dev/null || true
@dirrm %%DATADIR%%/rc
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%/buttons