aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdstyler
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-11-14 17:21:11 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-11-14 17:21:11 +0000
commite27752debf31eb7a5d7bbbf70a2d74cf0be4fef5 (patch)
tree7aef4934791400fe5a02fa42946654681347fcf6 /multimedia/dvdstyler
parent43d1e3907566cfacc1b627467d4e9ab40d2ef013 (diff)
downloadports-e27752debf31eb7a5d7bbbf70a2d74cf0be4fef5.tar.gz
ports-e27752debf31eb7a5d7bbbf70a2d74cf0be4fef5.zip
Notes
Diffstat (limited to 'multimedia/dvdstyler')
-rw-r--r--multimedia/dvdstyler/Makefile7
-rw-r--r--multimedia/dvdstyler/distinfo4
-rw-r--r--multimedia/dvdstyler/files/patch-src::MenuBox.cpp24
-rw-r--r--multimedia/dvdstyler/pkg-plist86
4 files changed, 54 insertions, 67 deletions
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index df19f53f4b97..ef975a719181 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvdstyler
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.3b
PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -33,6 +32,8 @@ USE_GMAKE= yes
CONFIGURE_ARGS= --with-wx-config=wxgtk2-2.4-config
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+PORTDOCS= AUTHORS COPYING INSTALL ChangeLog README
+
.include <bsd.port.pre.mk>
.if defined(WITH_DVD_DEVICE)
@@ -60,7 +61,7 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$$prefix/dvdstyler|${DATADIR}|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|mp2 AUTHORS COPYING INSTALL README ChangeLog|mp2|' \
+ @${REINPLACE_CMD} -e 's|@datadir@/docs/@PACKAGE@|${DOCSDIR}|' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
${WRKSRC}/src/Config.h
diff --git a/multimedia/dvdstyler/distinfo b/multimedia/dvdstyler/distinfo
index c4456d889e6c..de9d68cc46a3 100644
--- a/multimedia/dvdstyler/distinfo
+++ b/multimedia/dvdstyler/distinfo
@@ -1,2 +1,2 @@
-MD5 (DVDStyler-1.1.tar.gz) = 219d138c141eed5a06db1b344ca62d95
-SIZE (DVDStyler-1.1.tar.gz) = 1147550
+MD5 (DVDStyler-1.3b.tar.gz) = d43a44093223663ed3128548e0dd39f6
+SIZE (DVDStyler-1.3b.tar.gz) = 644257
diff --git a/multimedia/dvdstyler/files/patch-src::MenuBox.cpp b/multimedia/dvdstyler/files/patch-src::MenuBox.cpp
index 768dd64f0c2d..e3965ebbc891 100644
--- a/multimedia/dvdstyler/files/patch-src::MenuBox.cpp
+++ b/multimedia/dvdstyler/files/patch-src::MenuBox.cpp
@@ -1,38 +1,38 @@
---- src/MenuBox.cpp.orig Fri Aug 6 19:32:13 2004
-+++ src/MenuBox.cpp Fri Aug 6 19:41:00 2004
-@@ -15,7 +15,7 @@
- #include "MPEG.h"
+--- src/MenuBox.cpp.orig Fri Nov 12 13:27:47 2004
++++ src/MenuBox.cpp Sat Nov 13 20:49:08 2004
+@@ -16,7 +16,7 @@
#include <wxVillaLib/ImageProc.h>
#include <wxVillaLib/utils.h>
+ #include <wxXML/xml.h>
-#include "math.h"
+#include <math.h>
#include <wx/dnd.h>
#include <wx/utils.h>
+ #include <wx/mstream.h>
+@@ -404,11 +404,11 @@
-@@ -374,11 +374,11 @@
-
- void MenuBox::MoveObject(int& x, int& y)
+ bool MenuBox::MoveObject(int& x, int& y)
{
- x = (int) round(x/m_scale);
- y = (int) round(y/m_scale);
+ x = rint(x/m_scale);
+ y = rint(y/m_scale);
- MoveObjectInt(x,y);
+ bool res = MoveObjectInt(x,y);
- x = (int) round(x*m_scale);
- y = (int) round(y*m_scale);
+ x = rint(x*m_scale);
+ y = rint(y*m_scale);
+ return res;
}
- void MenuBox::MoveObjectInt(int& x, int& y)
-@@ -411,8 +411,8 @@
+@@ -444,8 +444,8 @@
- void MenuBox::ResizeObject(int x, int y, TransformType transformType)
+ bool MenuBox::ResizeObject(int x, int y, TransformType transformType)
{
- x = (int) round(x/m_scale);
- y = (int) round(y/m_scale);
+ x = rint(x/m_scale);
+ y = rint(y/m_scale);
- ResizeObjectInt(x, y, transformType);
+ return ResizeObjectInt(x, y, transformType);
}
diff --git a/multimedia/dvdstyler/pkg-plist b/multimedia/dvdstyler/pkg-plist
index 4fbe28f2fe38..f251234b9a76 100644
--- a/multimedia/dvdstyler/pkg-plist
+++ b/multimedia/dvdstyler/pkg-plist
@@ -1,51 +1,37 @@
bin/dvdstyler
-share/dvdstyler/backgrounds/autobahn.jpg
-share/dvdstyler/backgrounds/bi_domrep.jpg
-share/dvdstyler/backgrounds/blue.jpg
-share/dvdstyler/backgrounds/creta.jpg
-share/dvdstyler/backgrounds/darkblue.jpg
-share/dvdstyler/backgrounds/kiel_kanal.jpg
-share/dvdstyler/backgrounds/lightblue.jpg
-share/dvdstyler/backgrounds/swans.jpg
-share/dvdstyler/bin/dvdstyler
-share/dvdstyler/bin/rc/dvdstyler.png
-share/dvdstyler/bin/rc/files.png
-share/dvdstyler/bin/rc/folder1.png
-share/dvdstyler/bin/rc/folder2.png
-share/dvdstyler/bin/rc/logo.png
-share/dvdstyler/bin/rc/logo_big.png
-share/dvdstyler/bin/rc/minus.png
-share/dvdstyler/bin/rc/move.cur
-share/dvdstyler/bin/rc/nesw.cur
-share/dvdstyler/bin/rc/new.png
-share/dvdstyler/bin/rc/nwse.cur
-share/dvdstyler/bin/rc/open.png
-share/dvdstyler/bin/rc/plus.png
-share/dvdstyler/bin/rc/run.png
-share/dvdstyler/bin/rc/save.png
-share/dvdstyler/buttons/simple.xml
-share/dvdstyler/locale/de/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/locale/es/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/locale/fr/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/locale/hu/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/locale/it/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/locale/ru/LC_MESSAGES/dvdstyler.mo
-share/dvdstyler/silence.mp2
-@dirrm share/dvdstyler/locale/ru/LC_MESSAGES
-@dirrm share/dvdstyler/locale/ru
-@dirrm share/dvdstyler/locale/it/LC_MESSAGES
-@dirrm share/dvdstyler/locale/it
-@dirrm share/dvdstyler/locale/hu/LC_MESSAGES
-@dirrm share/dvdstyler/locale/hu
-@dirrm share/dvdstyler/locale/fr/LC_MESSAGES
-@dirrm share/dvdstyler/locale/fr
-@dirrm share/dvdstyler/locale/es/LC_MESSAGES
-@dirrm share/dvdstyler/locale/es
-@dirrm share/dvdstyler/locale/de/LC_MESSAGES
-@dirrm share/dvdstyler/locale/de
-@dirrm share/dvdstyler/locale
-@dirrm share/dvdstyler/buttons
-@dirrm share/dvdstyler/bin/rc
-@dirrm share/dvdstyler/bin
-@dirrm share/dvdstyler/backgrounds
-@dirrm share/dvdstyler
+%%DATADIR%%/backgrounds/autobahn.jpg
+%%DATADIR%%/backgrounds/bi_domrep.jpg
+%%DATADIR%%/backgrounds/blue.jpg
+%%DATADIR%%/backgrounds/creta.jpg
+%%DATADIR%%/backgrounds/darkblue.jpg
+%%DATADIR%%/backgrounds/kiel_kanal.jpg
+%%DATADIR%%/backgrounds/lightblue.jpg
+%%DATADIR%%/backgrounds/swans.jpg
+%%DATADIR%%/buttons/simple.xml
+%%DATADIR%%/data/silence.mp2
+%%DATADIR%%/rc/dvdstyler.png
+%%DATADIR%%/rc/files.png
+%%DATADIR%%/rc/folder1.png
+%%DATADIR%%/rc/folder2.png
+%%DATADIR%%/rc/logo.png
+%%DATADIR%%/rc/logo_big.png
+%%DATADIR%%/rc/minus.png
+%%DATADIR%%/rc/move.cur
+%%DATADIR%%/rc/nesw.cur
+%%DATADIR%%/rc/new.png
+%%DATADIR%%/rc/nwse.cur
+%%DATADIR%%/rc/open.png
+%%DATADIR%%/rc/plus.png
+%%DATADIR%%/rc/run.png
+%%DATADIR%%/rc/save.png
+share/locale/de/LC_MESSAGES/dvdstyler.mo
+share/locale/es/LC_MESSAGES/dvdstyler.mo
+share/locale/fr/LC_MESSAGES/dvdstyler.mo
+share/locale/hu/LC_MESSAGES/dvdstyler.mo
+share/locale/it/LC_MESSAGES/dvdstyler.mo
+share/locale/ru/LC_MESSAGES/dvdstyler.mo
+@dirrm %%DATADIR%%/rc
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/buttons
+@dirrm %%DATADIR%%/backgrounds
+@dirrm %%DATADIR%%