aboutsummaryrefslogtreecommitdiff
path: root/multimedia/emotion
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2012-12-22 20:54:59 +0000
commit2d250bb95eac4419c2b2a81d30d1629c50a4ba4f (patch)
tree9c4bc08591050b7b536082be6db8392c913f8089 /multimedia/emotion
parent3f57bf2285e342135340477d9404790fda157f15 (diff)
downloadports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.tar.gz
ports-2d250bb95eac4419c2b2a81d30d1629c50a4ba4f.zip
Notes
Diffstat (limited to 'multimedia/emotion')
-rw-r--r--multimedia/emotion/Makefile50
-rw-r--r--multimedia/emotion/distinfo4
-rw-r--r--multimedia/emotion/pkg-plist8
3 files changed, 29 insertions, 33 deletions
diff --git a/multimedia/emotion/Makefile b/multimedia/emotion/Makefile
index 242fceadbd7a..bb79080e5249 100644
--- a/multimedia/emotion/Makefile
+++ b/multimedia/emotion/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= emotion
-PORTVERSION= 0.2.0.65643
+PORTVERSION= 1.7.4
PORTEPOCH= 1
CATEGORIES= multimedia enlightenment
-MASTER_SITES= http://download.enlightenment.org/snapshots/2011-11-28/ \
- http://files.roorback.net/e17/base/
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ LOCAL/gblach/e17/
MAINTAINER= gblach@FreeBSD.org
COMMENT= Video playback wrapper library for Enlightenment
@@ -14,33 +14,38 @@ COMMENT= Video playback wrapper library for Enlightenment
LICENSE= BSD
DIST_SUBDIR= e17
-GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_GMAKE= yes
+GNU_CONFIGURE= yes
USE_EFL= ecore edje eet eio embryo evas libtool_hack modarch_hack
USE_EFL_EVAS_LOADERS= png jpeg
USE_GNOME= gnomehack pkgconfig
USE_LDCONFIG= yes
-OPTIONS= GST "Build GStreamer module" on \
- XINE "Build Xine module" off
-
# emotion's vlc plugin needs updating due to libvlc API changes
# details: http://trac.enlightenment.org/e/ticket/601
CONFIGURE_ARGS= --disable-generic-vlc
-.include <bsd.port.pre.mk>
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= GSTREAMER LIBXINE
+OPTIONS_DEFAULT=GSTREAMER
+
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
BROKEN= Does not install on sparc64: coredump
.endif
-.if defined(WITHOUT_XINE) && defined(WITHOUT_GST)
-IGNORE= is useless without playback library. Please run 'make config' and choose one of XINE and GST
+.if ${PORT_OPTIONS:MGSTREAMER}
+USE_GSTREAMER= ffmpeg good
+CONFIGURE_ARGS+=--enable-gstreamer
+PLIST_SUB+= GST=""
+.else
+CONFIGURE_ARGS+=--disable-gstreamer
+PLIST_SUB+= GST="@comment "
.endif
-.if !defined(WITHOUT_XINE)
-LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
+.if ${PORT_OPTIONS:MLIBXINE}
+LIB_DEPENDS+= xine:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+=--enable-xine
PLIST_SUB+= XINE=""
.else
@@ -48,19 +53,10 @@ CONFIGURE_ARGS+=--disable-xine
PLIST_SUB+= XINE="@comment "
.endif
-.if !defined(WITHOUT_GST)
-USE_GSTREAMER= ffmpeg good
-CONFIGURE_ARGS+=--enable-gstreamer
-PLIST_SUB+= GST=""
-.else
-CONFIGURE_ARGS+=--disable-gstreamer
-PLIST_SUB+= GST="@comment "
-.endif
-
-.if !defined(NOPORTEXAMPLES)
-CONFIGURE_ARGS+= --enable-install-examples
+.if ${PORT_OPTIONS:MEXAMPLES}
+CONFIGURE_ARGS+=--enable-install-examples
.else
-CONFIGURE_ARGS+= --disable-install-examples
+CONFIGURE_ARGS+=--disable-install-examples
.endif
post-patch:
@@ -68,8 +64,8 @@ post-patch:
${WRKSRC}/src/examples/Makefile.in
post-install:
-.if defined(NOPORTEXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
@${RMDIR} ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/emotion/distinfo b/multimedia/emotion/distinfo
index 16ea2132e179..1197dc474e70 100644
--- a/multimedia/emotion/distinfo
+++ b/multimedia/emotion/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/emotion-0.2.0.65643.tar.bz2) = 4a149d3c0e3c6617ff949b9d8f691556eeea4622ae4d698d0b6c1893f26c88d7
-SIZE (e17/emotion-0.2.0.65643.tar.bz2) = 477814
+SHA256 (e17/emotion-1.7.4.tar.bz2) = 44fd9061ffa0939a99e238044efefc0077ac0422781ea51be2d94a6735008111
+SIZE (e17/emotion-1.7.4.tar.bz2) = 499639
diff --git a/multimedia/emotion/pkg-plist b/multimedia/emotion/pkg-plist
index 88da5c57086e..3da92f6e78ae 100644
--- a/multimedia/emotion/pkg-plist
+++ b/multimedia/emotion/pkg-plist
@@ -1,12 +1,12 @@
bin/emotion_test
-include/emotion-0/Emotion.h
-include/emotion-0/Emotion_Generic_Plugin.h
+include/emotion-1/Emotion.h
+include/emotion-1/Emotion_Generic_Plugin.h
lib/emotion/em_generic.so
%%GST%%lib/emotion/gstreamer.so
%%XINE%%lib/emotion/xine.so
lib/edje/modules/emotion/%%E17_ARCH%%/module.so
lib/libemotion.so
-lib/libemotion.so.2
+lib/libemotion.so.8
libdata/pkgconfig/emotion.pc
%%DATADIR%%/data/theme.edj
%%DATADIR%%/data/icon.edj
@@ -18,7 +18,7 @@ libdata/pkgconfig/emotion.pc
@dirrm lib/edje/modules/emotion
@dirrmtry lib/edje/modules
@dirrmtry lib/edje
-@dirrm include/emotion-0
+@dirrm include/emotion-1
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
@dirrm lib/emotion