aboutsummaryrefslogtreecommitdiff
path: root/multimedia/emotion
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-26 17:36:30 +0000
commitb9eaf394330b28c95aff1aed37c4e9c7269123a4 (patch)
treec7d813040107a076d3b35f3a2eefbed1462e4ed4 /multimedia/emotion
parent2cce93719ddda5af2198b65d659b27535350e329 (diff)
Notes
Diffstat (limited to 'multimedia/emotion')
-rw-r--r--multimedia/emotion/Makefile30
-rw-r--r--multimedia/emotion/distinfo4
-rw-r--r--multimedia/emotion/pkg-descr2
-rw-r--r--multimedia/emotion/pkg-plist7
4 files changed, 33 insertions, 10 deletions
diff --git a/multimedia/emotion/Makefile b/multimedia/emotion/Makefile
index 45b365648b87..49832c65387f 100644
--- a/multimedia/emotion/Makefile
+++ b/multimedia/emotion/Makefile
@@ -7,31 +7,32 @@
#
PORTNAME= emotion
-PORTVERSION= 0.2.0.56361
-PORTREVISION= 4
+PORTVERSION= 0.2.0.65643
PORTEPOCH= 1
CATEGORIES= multimedia enlightenment
-MASTER_SITES= http://files.roorback.net/e17/2011-01-29/extra/
+MASTER_SITES= http://download.enlightenment.org/snapshots/2011-11-28/ \
+ http://files.roorback.net/e17/base/
MAINTAINER= magik@roorback.net
COMMENT= Video playback wrapper library for Enlightenment
LICENSE= BSD
+
DIST_SUBDIR= e17
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_EFL= ecore edje eet embryo evas libtool_hack modarch_hack
+USE_EFL= ecore edje eet eio embryo evas libtool_hack modarch_hack
USE_EFL_EVAS_LOADERS= png jpeg
USE_GNOME= gnomehack pkgconfig
USE_LDCONFIG= yes
-OPTIONS= XINE "Build Xine module" on \
- GST "Build GStreamer module" on
+OPTIONS= GST "Build GStreamer module" on \
+ XINE "Build Xine module" off
# emotion's vlc plugin needs updating due to libvlc API changes
# details: http://trac.enlightenment.org/e/ticket/601
-CONFIGURE_ARGS= --disable-vlc
+CONFIGURE_ARGS= --disable-generic-vlc
.include <bsd.port.pre.mk>
@@ -57,4 +58,19 @@ CONFIGURE_ARGS+=--disable-gstreamer
PLIST_SUB+= GST="@comment "
.endif
+.if !defined(NOPORTEXAMPLES)
+CONFIGURE_ARGS+= --enable-install-examples
+.else
+CONFIGURE_ARGS+= --disable-install-examples
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|= \$$(datadir)/\$$(PACKAGE)/examples|= $$(datadir)/examples/$$(PACKAGE)|' \
+ ${WRKSRC}/src/examples/Makefile.in
+
+post-install:
+.if defined(NOPORTEXAMPLES)
+ @${RMDIR} ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.post.mk>
diff --git a/multimedia/emotion/distinfo b/multimedia/emotion/distinfo
index 7504bd3e4754..16ea2132e179 100644
--- a/multimedia/emotion/distinfo
+++ b/multimedia/emotion/distinfo
@@ -1,2 +1,2 @@
-SHA256 (e17/emotion-0.2.0.56361.tar.bz2) = b6d7278c3c8837dd0ba3c23b1d33e1b7a14b7a25751eb3dda5a5b2e61e74ca96
-SIZE (e17/emotion-0.2.0.56361.tar.bz2) = 1827445
+SHA256 (e17/emotion-0.2.0.65643.tar.bz2) = 4a149d3c0e3c6617ff949b9d8f691556eeea4622ae4d698d0b6c1893f26c88d7
+SIZE (e17/emotion-0.2.0.65643.tar.bz2) = 477814
diff --git a/multimedia/emotion/pkg-descr b/multimedia/emotion/pkg-descr
index 16e81062c14b..42872b188312 100644
--- a/multimedia/emotion/pkg-descr
+++ b/multimedia/emotion/pkg-descr
@@ -3,4 +3,4 @@ various multimedia engines. It features simplified and generalized
interface and power.
Author: The Rasterman (Carsten Haitzler) <raster@rasterman.com>
-WWW: http://www.enlightenment.org/
+WWW: http://docs.enlightenment.org/auto/emotion/
diff --git a/multimedia/emotion/pkg-plist b/multimedia/emotion/pkg-plist
index e2f8008b39a2..88da5c57086e 100644
--- a/multimedia/emotion/pkg-plist
+++ b/multimedia/emotion/pkg-plist
@@ -1,5 +1,7 @@
bin/emotion_test
include/emotion-0/Emotion.h
+include/emotion-0/Emotion_Generic_Plugin.h
+lib/emotion/em_generic.so
%%GST%%lib/emotion/gstreamer.so
%%XINE%%lib/emotion/xine.so
lib/edje/modules/emotion/%%E17_ARCH%%/module.so
@@ -8,6 +10,10 @@ lib/libemotion.so.2
libdata/pkgconfig/emotion.pc
%%DATADIR%%/data/theme.edj
%%DATADIR%%/data/icon.edj
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/emotion_basic_example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/emotion_generic_example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/emotion_border_example.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/emotion_signals_example.c
@dirrm lib/edje/modules/emotion/%%E17_ARCH%%
@dirrm lib/edje/modules/emotion
@dirrmtry lib/edje/modules
@@ -16,3 +22,4 @@ libdata/pkgconfig/emotion.pc
@dirrm %%DATADIR%%/data
@dirrm %%DATADIR%%
@dirrm lib/emotion
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%