aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-29 03:11:41 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-11-29 03:11:41 +0000
commit4bb41a8ba4f33821c512ea5839c87aa1a0564735 (patch)
treec081998183f96ec443d95cf54219e44a0877a2ef /multimedia/ffmpeg-devel
parenteac252fa111deb110b51e9edf49dba9ebaa74ba6 (diff)
downloadports-4bb41a8ba4f33821c512ea5839c87aa1a0564735.tar.gz
ports-4bb41a8ba4f33821c512ea5839c87aa1a0564735.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg-devel')
-rw-r--r--multimedia/ffmpeg-devel/Makefile51
-rw-r--r--multimedia/ffmpeg-devel/distinfo6
-rw-r--r--multimedia/ffmpeg-devel/files/extra-bktr-patch-libavformat::Makefile11
-rw-r--r--multimedia/ffmpeg-devel/files/grab_bsdbktr.c328
-rw-r--r--multimedia/ffmpeg-devel/files/patch-configure17
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavcodec::Makefile22
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavcodec::bswap.h34
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavcodec::libpostproc::Makefile25
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavcodec::x264.c10
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavformat::Makefile22
-rw-r--r--multimedia/ffmpeg-devel/files/patch-libavutil__bswap.h21
-rw-r--r--multimedia/ffmpeg-devel/pkg-plist9
12 files changed, 118 insertions, 438 deletions
diff --git a/multimedia/ffmpeg-devel/Makefile b/multimedia/ffmpeg-devel/Makefile
index 63fabafe8d4f..db4d5a959625 100644
--- a/multimedia/ffmpeg-devel/Makefile
+++ b/multimedia/ffmpeg-devel/Makefile
@@ -8,7 +8,9 @@
PORTNAME= ffmpeg
DISTVERSION= 0.4.9.cvs.${RELEASE_DATE}
CATEGORIES= multimedia audio ipv6 net
-MASTER_SITES= http://mplayerhq.hu/MPlayer/cvs/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+# http://mplayerhq.hu/MPlayer/cvs/
+MASTER_SITE_SUBDIR= lioux
PKGNAMESUFFIX= -devel
DISTNAME= FFMpeg-${RELEASE_DATE}
@@ -54,7 +56,7 @@ INSTALLS_SHLIB= yes
NO_LATEST_LINK= yes
CONFLICTS= ffmpeg-[0-9]*-*
-RELEASE_DATE= 20050620
+RELEASE_DATE= 2005112800
SHLIB_VERSION= 1
MAN1= ffmpeg.1
@@ -69,11 +71,14 @@ DOC_DOCFILES= TODO faq.html ffmpeg-doc.html \
PORTDOCS= *
## headers
-HEADER_FILES= libavcodec/avcodec.h libavcodec/common.h \
- libavcodec/dsputil.h
+HEADER_FILES= libavcodec/avcodec.h \
+ libavcodec/dsputil.h \
+ libavutil/common.h
#
# libraries
-LIB_FILES= libavcodec/libavcodec.a libavformat/libavformat.a
+LIB_FILES= libavcodec/libavcodec.a \
+ libavformat/libavformat.a \
+ libavutil/libavutil.a
.include <bsd.port.pre.mk>
@@ -100,7 +105,11 @@ WITH_IPV6= yes
.if ${ARCH} != "i386"
WITHOUT_MMX= yes
.else
-EXTRA_PATCHES+= ${FILESDIR}/extra-bktr-patch-libavformat::Makefile
+#EXTRA_PATCHES+= ${FILESDIR}/extra-bktr-patch-libavformat::Makefile
+.endif
+## sse hardware vector support
+.if (defined(MACHINE_CPU) && ${MACHINE_CPU:Msse} == "sse")
+WITH_BUILTIN_VECTOR= yes
.endif
##
@@ -122,8 +131,12 @@ WITH_FAAD=yes
.if exists(${LOCALBASE}/lib/libfreetype.so)
WITH_FREETYPE2=yes
.endif
+## gsm
+.if exists(${LOCALBASE}/lib/libgsm.so)
+WITH_GSM=yes
+.endif
## imlib2
-.if exists(${X11BASE}/lib/libImlib2.so)
+.if exists(${LOCALBASE}/lib/libImlib2.so)
WITH_IMLIB2=yes
.endif
## lame mp3
@@ -184,8 +197,7 @@ CONFIGURE_ARGS+= --enable-a52 \
# libavcodec needs it
FFMPEG_LDFLAGS+= -la52
.else
-CONFIGURE_ARGS+= --enable-a52 \
- --disable-a52bin
+CONFIGURE_ARGS+= --enable-a52
.endif
## dts
.ifdef(WITH_DTS)
@@ -228,6 +240,12 @@ CONFIGURE_ARGS+= --disable-mmx
WITHOUT_BUILTIN_VECTOR= yes
.endif
+## gsm
+.ifdef(WITH_GSM)
+LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+
+CONFIGURE_ARGS+= --enable-libgsm
+.endif
## mp3
.ifdef(WITH_MP3)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
@@ -337,7 +355,7 @@ pre-everything::
@${ECHO_MSG} 'You can disable liba52 support by defining WITHOUT_LIBA52'
@${ECHO_MSG}
.endif
-.ifndef(WITH_BUILTIN_VECTOR)
+.if !defined(WITHOUT_BUILTIN_VECTOR) && !defined(WITH_BUILTIN_VECTOR)
@${ECHO_MSG} 'Define WITH_BUILTIN_VECTOR if your system supports SSE"
@${ECHO_MSG}
.endif
@@ -365,6 +383,10 @@ pre-everything::
@${ECHO_MSG} 'Define WITHOUT_IPV6 to disable IPV6 network support'
@${ECHO_MSG}
.endif
+.ifndef(WITH_GSM)
+ @${ECHO_MSG} 'Define WITH_GSM to enable GSM codec'
+ @${ECHO_MSG}
+.endif
.ifndef(WITHOUT_MMX)
@${ECHO_MSG} 'Define WITHOUT_MMX if your system does not support MMX'
@${ECHO_MSG}
@@ -439,7 +461,7 @@ pre-everything::
post-extract:
.if ${ARCH} == "i386"
# install booktree extension
- @${CP} ${FILESDIR}/grab_bsdbktr.c ${WRKSRC}/libavformat/
+# @${CP} ${FILESDIR}/grab_bsdbktr.c ${WRKSRC}/libavformat/
.endif # ${ARCH} == i386
post-patch:
@@ -464,11 +486,6 @@ post-patch:
.endif
.if ${ARCH} == "i386"
.ifdef(WITH_VIDEO_CAPTURE)
-# we support "v4l" per default through Steve O'Hara-Smith's bktr(4)
-# patch
- @${REINPLACE_CMD} -E \
- -e 's|^(v4l).*$$|\1="yes"|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
# set proper audio device
.ifdef(WITH_AUDIO_DEV)
@${REINPLACE_CMD} -E \
@@ -513,7 +530,7 @@ post-patch:
-e 's|^(imlib2).*$$|\1=yes|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -E \
- -e 's|(-lImlib2)|-L ${X11BASE}/lib \1|' \
+ -e 's|(-lImlib2)|-L ${LOCALBASE}/lib \1|' \
${WRKSRC}/vhook/Makefile
.endif
.if defined(WITH_IPV6) && ${OSVERSION} >= 400014
diff --git a/multimedia/ffmpeg-devel/distinfo b/multimedia/ffmpeg-devel/distinfo
index 2ba92c5d9296..37ef8007af59 100644
--- a/multimedia/ffmpeg-devel/distinfo
+++ b/multimedia/ffmpeg-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (FFMpeg-20050620.tar.bz2) = e7a76b9c56545faaead1705a0902d9da
-SHA256 (FFMpeg-20050620.tar.bz2) = 03f3ae5eb1e8d1b5eba5bc76c83c8b83ed9e00a984048ce757815df942398f73
-SIZE (FFMpeg-20050620.tar.bz2) = 1623626
+MD5 (FFMpeg-2005112800.tar.bz2) = c3c960816c75f640a93662961ba7f15f
+SHA256 (FFMpeg-2005112800.tar.bz2) = 7754ca22c545a8ecf5f9bb47a7fed0cbf918718e415caf40eb12ee84ec1655e9
+SIZE (FFMpeg-2005112800.tar.bz2) = 1694390
diff --git a/multimedia/ffmpeg-devel/files/extra-bktr-patch-libavformat::Makefile b/multimedia/ffmpeg-devel/files/extra-bktr-patch-libavformat::Makefile
deleted file mode 100644
index d5e22abe72d1..000000000000
--- a/multimedia/ffmpeg-devel/files/extra-bktr-patch-libavformat::Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- libavformat/Makefile.orig Mon Jun 6 21:05:05 2005
-+++ libavformat/Makefile Mon Jun 6 21:05:10 2005
-@@ -37,7 +37,7 @@
- OBJS+= framehook.o
-
- ifeq ($(CONFIG_VIDEO4LINUX),yes)
--OBJS+= grab.o
-+OBJS+= grab_bsdbktr.o
- endif
-
- ifeq ($(CONFIG_DV1394),yes)
diff --git a/multimedia/ffmpeg-devel/files/grab_bsdbktr.c b/multimedia/ffmpeg-devel/files/grab_bsdbktr.c
deleted file mode 100644
index 3112fc9a9c94..000000000000
--- a/multimedia/ffmpeg-devel/files/grab_bsdbktr.c
+++ /dev/null
@@ -1,328 +0,0 @@
-/*
- * FreeBSD video grab interface
- * Copyright (c) 2002,2003,2004,2005 Steve O'Hara-Smith
- * based on
- * Linux video grab interface
- * Copyright (c) 2000,2001 Gerard Lantau.
- * and
- * simple_grab.c Copyright (c) 1999 Roger Hardiman
- *
- * GPL virus inherited:
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
- */
-#include "avformat.h"
-#if defined __DragonFly__
-#include <dev/video/meteor/ioctl_meteor.h>
-#include <dev/video/bktr/ioctl_bt848.h>
-#else
-#if __FreeBSD__ >= 502100
-#include <dev/bktr/ioctl_meteor.h>
-#include <dev/bktr/ioctl_bt848.h>
-#else
-#include <machine/ioctl_meteor.h>
-#include <machine/ioctl_bt848.h>
-#endif
-#endif
-#include <unistd.h>
-#include <fcntl.h>
-#include <sys/ioctl.h>
-#include <sys/mman.h>
-#include <sys/time.h>
-#include <signal.h>
-
-typedef struct {
- int fd;
- int tuner_fd;
- int frame_format; /* see VIDEO_PALETTE_xxx */
- int width, height;
- int frame_rate;
- int frame_rate_base;
- int64_t per_frame;
-} VideoData;
-
-const char *video_device = "/dev/bktr0";
-
-#define PAL 1
-#define PALBDGHI 1
-#define NTSC 2
-#define NTSCM 2
-#define SECAM 3
-#define PALN 4
-#define PALM 5
-#define NTSCJ 6
-
-/* PAL is 768 x 576. NTSC is 640 x 480 */
-#define PAL_HEIGHT 576
-#define SECAM_HEIGHT 576
-#define NTSC_HEIGHT 480
-
-#ifndef VIDEO_FORMAT
-#define VIDEO_FORMAT NTSC
-#endif
-
-static int bktr_dev[] = { METEOR_DEV0, METEOR_DEV1, METEOR_DEV2,
- METEOR_DEV3, METEOR_DEV_SVIDEO };
-
-static u_int8_t *video_buf;
-static int nsignals = 0;
-static void catchsignal(int signal)
-{
- nsignals++;
- return;
-}
-
-static int bktr_init (const char *video_device, int width, int height,
- int format, u_int8_t **video_buf, int *video_fd, int *tuner_fd,
- int idev, double frequency)
-{
- struct meteor_geomet geo;
- int h_max;
- long ioctl_frequency;
- char *arg;
- int c;
- struct sigaction act,old;
-
- if (idev < 0 || idev > 4)
- {
- arg = getenv ("BKTR_DEV");
- if (arg)
- idev = atoi (arg);
- if (idev < 0 || idev > 4)
- idev = 0;
- }
-
- if (format < 1 || format > 6)
- {
- arg = getenv ("BKTR_FORMAT");
- if (arg)
- format = atoi (arg);
- if (format < 1 || format > 6)
- format = VIDEO_FORMAT;
- }
-
- if (frequency <= 0)
- {
- arg = getenv ("BKTR_FREQUENCY");
- if (arg)
- frequency = atof (arg);
- if (frequency <= 0)
- frequency = 0.0;
- }
-
- memset(&act,0,sizeof(act));
- sigemptyset(&act.sa_mask);
- act.sa_handler = catchsignal;
- sigaction(SIGUSR1,&act,&old);
-
- *tuner_fd = open ("/dev/tuner0", O_RDONLY);
- if (*tuner_fd < 0) {
- perror("Warning: Tuner not opened continuing");
- }
-
- *video_fd = open (video_device, O_RDONLY);
- if (*video_fd < 0) {
- perror (video_device);
- return -1;
- }
-
- geo.rows = height;
- geo.columns = width;
- geo.frames = 1;
- geo.oformat = METEOR_GEO_YUV_PACKED;
-
- switch (format) {
- case PAL: h_max = PAL_HEIGHT; c = BT848_IFORM_F_PALBDGHI; break;
- case PALN: h_max = PAL_HEIGHT; c = BT848_IFORM_F_PALN; break;
- case PALM: h_max = PAL_HEIGHT; c = BT848_IFORM_F_PALM; break;
- case SECAM: h_max = SECAM_HEIGHT; c = BT848_IFORM_F_SECAM; break;
- case NTSC: h_max = NTSC_HEIGHT; c = BT848_IFORM_F_NTSCM; break;
- case NTSCJ: h_max = NTSC_HEIGHT; c = BT848_IFORM_F_NTSCJ; break;
- default: h_max = PAL_HEIGHT; c = BT848_IFORM_F_PALBDGHI; break;
- }
- if (height <= h_max/2) {
- geo.oformat |= METEOR_GEO_EVEN_ONLY;
- }
-
- if (ioctl(*video_fd, METEORSETGEO, &geo) < 0) {
- perror ("METEORSETGEO");
- return -1;
- }
-
- if (ioctl(*video_fd, BT848SFMT, &c) < 0) {
- perror ("BT848SFMT");
- return -1;
- }
-
- c = bktr_dev[idev];
- if (ioctl(*video_fd, METEORSINPUT, &c) < 0) {
- perror ("METEORSINPUT");
- return -1;
- }
- *video_buf = (u_int8_t *) mmap((void *) 0, width*height*2,
- PROT_READ, MAP_SHARED, *video_fd, (off_t) 0);
- if (*video_buf == MAP_FAILED) {
- perror ("mmap");
- return -1;
- }
- if (frequency != 0.0) {
- ioctl_frequency = (unsigned long)(frequency*16);
- if (*tuner_fd > 0)
- {
- if (ioctl(*tuner_fd, TVTUNER_SETFREQ, &ioctl_frequency)<0)
- perror("TVTUNER_SETFREQ");
- }
- }
- c = METEOR_CAP_CONTINOUS;
- ioctl(*video_fd, METEORCAPTUR, &c);
- c = SIGUSR1;
- ioctl (*video_fd, METEORSSIGNAL, &c);
- return 0;
-}
-
-static void bktr_getframe(u_int64_t per_frame)
-{
- u_int64_t curtime;
- static u_int64_t last_frame_time = 0;
-
- curtime = av_gettime();
- if (!last_frame_time)
- last_frame_time = curtime;
-
- if (!last_frame_time
- || ((last_frame_time + per_frame) > curtime)) {
- if (!usleep (last_frame_time + per_frame + per_frame/2 + per_frame/4 - curtime)) {
- if (!nsignals)
- printf ("\nSLEPT NO signals - %d microseconds late\n",
- (int) (av_gettime() - last_frame_time - per_frame));
- }
- }
- nsignals = 0;
-
- last_frame_time = curtime;
-}
-
-void bf_memcpy (char *dest, char *src, int size)
-{
- while (size -= 2)
- {
- dest[0] = src[1];
- dest[1] = src[0];
- dest += 2;
- src += 2;
- }
-}
-
-/* note: we support only one picture read at a time */
-static int grab_read_packet(AVFormatContext *s1, AVPacket *pkt)
-{
- VideoData *s = s1->priv_data;
- int size, halfsize;
-
- size = s->width * s->height;
- halfsize = size << 1;
-
- if (av_new_packet(pkt, size + size) < 0)
- return -AVERROR_IO;
-
- bktr_getframe (s->per_frame);
- pkt->pts = av_gettime() & ((1LL << 48) - 1);
- bf_memcpy (pkt->data, video_buf, size + size);
-
- return size + size;
-}
-
-static int grab_read_header (AVFormatContext *s1, AVFormatParameters *ap)
-{
- VideoData *s = s1->priv_data;
- AVStream *st;
- int width, height;
- int frame_rate;
- int frame_rate_base;
- int format = -1;
-
- if (!ap || ap->width <= 0 || ap->height <= 0 || ap->time_base.den <= 0)
- return -1;
-
- width = ap->width;
- height = ap->height;
- frame_rate = ap->time_base.den;
- frame_rate_base = ap->time_base.num;
-
- st = av_new_stream(s1, 0);
- if (!st)
- return -ENOMEM;
-
- s->width = width;
- s->height = height;
- s->frame_rate = frame_rate;
- s->frame_rate_base = frame_rate_base;
- s->per_frame = ((int64_t)1000000 * s->frame_rate_base) / s->frame_rate;
-
- st->codec.codec_type = CODEC_TYPE_VIDEO;
- st->codec.pix_fmt = PIX_FMT_YUV422;
- st->codec.codec_id = CODEC_ID_RAWVIDEO;
- st->codec.width = width;
- st->codec.height = height;
- st->codec.time_base.den = frame_rate;
- st->codec.time_base.num = frame_rate_base;
-
- av_set_pts_info(st, 48, 1, 1000000); /* 48 bits pts in use */
-
- if (ap->standard) {
- if (!strcasecmp(ap->standard, "pal"))
- format = PAL;
- if (!strcasecmp(ap->standard, "secam"))
- format = SECAM;
- if (!strcasecmp(ap->standard, "ntsc"))
- format = NTSC;
- }
-
- if (bktr_init (video_device, width, height, format, &video_buf,
- &(s->fd), &(s->tuner_fd), -1, 0.0) < 0)
- return -AVERROR_IO;
- return 0;
-}
-
-static int grab_read_close (AVFormatContext *s1)
-{
- VideoData *s = s1->priv_data;
-
- int c = METEOR_CAP_STOP_CONT;
- ioctl(s->fd, METEORCAPTUR, &c);
- c = METEOR_SIG_MODE_MASK;
- ioctl(s->fd, METEORSSIGNAL, &c);
- close(s->fd);
- close(s->tuner_fd);
- munmap((void *)video_buf, sizeof(video_buf));
- return 0;
-}
-
-AVInputFormat video_grab_device_format = {
- "video4linux",
- "video grab",
- sizeof(VideoData),
- NULL,
- grab_read_header,
- grab_read_packet,
- grab_read_close,
- flags: AVFMT_NOFILE,
-};
-
-int video_grab_init(void)
-{
- av_register_input_format(&video_grab_device_format);
- return 0;
-}
diff --git a/multimedia/ffmpeg-devel/files/patch-configure b/multimedia/ffmpeg-devel/files/patch-configure
index 113a7eb1e736..c81d2f68f1c3 100644
--- a/multimedia/ffmpeg-devel/files/patch-configure
+++ b/multimedia/ffmpeg-devel/files/patch-configure
@@ -1,11 +1,20 @@
---- configure.orig Fri May 13 01:19:02 2005
-+++ configure Fri May 13 01:19:42 2005
-@@ -935,6 +935,8 @@
+--- configure.orig Sat Oct 22 17:17:17 2005
++++ configure Mon Nov 28 23:58:20 2005
+@@ -1019,6 +1019,8 @@
builtin_vector=no
- if $cc -o $TMPO $TMPC 2> /dev/null ; then
+ if $cc -msse -o $TMPO $TMPC 2> /dev/null ; then
builtin_vector=yes
+else
+ builtin_vector=no
fi
# dlopen/dlfcn.h probing
+@@ -1449,7 +1451,7 @@
+ echo "BUILD_SHARED=yes" >> config.mak
+ echo "PIC=-fPIC -DPIC" >> config.mak
+ echo "SPPMAJOR=0" >> config.mak
+- echo "SPPVERSION=0.0.1" >> config.mak
++ echo "SPPVERSION=1" >> config.mak
+ fi
+ echo "EXTRALIBS=$extralibs" >> config.mak
+ version=`grep '#define FFMPEG_VERSION ' "$source_path/libavcodec/avcodec.h" |
diff --git a/multimedia/ffmpeg-devel/files/patch-libavcodec::Makefile b/multimedia/ffmpeg-devel/files/patch-libavcodec::Makefile
index e2d43cc5c7a3..b5dc2d00d965 100644
--- a/multimedia/ffmpeg-devel/files/patch-libavcodec::Makefile
+++ b/multimedia/ffmpeg-devel/files/patch-libavcodec::Makefile
@@ -1,26 +1,24 @@
---- libavcodec/Makefile.orig Sun May 22 20:58:35 2005
-+++ libavcodec/Makefile Thu May 26 13:30:41 2005
-@@ -463,8 +463,7 @@
- install $(INSTALLSTRIP) -m 755 $(SLIB) "$(prefix)"
+--- libavcodec/Makefile.orig Mon Nov 28 22:57:22 2005
++++ libavcodec/Makefile Mon Nov 28 22:58:37 2005
+@@ -488,8 +488,7 @@
+ install $(INSTALLSTRIP) -m 755 $(SLIBNAME) "$(prefix)"
else
install -d $(libdir)
-- install $(INSTALLSTRIP) -m 755 $(SLIB) $(libdir)/libavcodec-$(VERSION).so
-- ln -sf libavcodec-$(VERSION).so $(libdir)/libavcodec.so
-+ ${BSD_INSTALL_DATA} $(SLIB) $(libdir)/libavcodec.so
+- install $(INSTALLSTRIP) -m 755 $(SLIBNAME) $(libdir)/libavcodec-$(VERSION)$(SLIBSUF)
+- ln -sf libavcodec-$(VERSION)$(SLIBSUF) $(libdir)/libavcodec$(SLIBSUF)
++ ${BSD_INSTALL_DATA} $(SLIBNAME) $(libdir)/libavcodec.so
$(LDCONFIG) || true
endif
ifeq ($(CONFIG_PP),yes)
-@@ -479,12 +478,12 @@
+@@ -504,10 +503,10 @@
install-headers:
mkdir -p "$(prefix)/include/ffmpeg"
- install -m 644 $(SRC_PATH)/libavcodec/avcodec.h \
+ ${BSD_INSTALL_DATA} $(SRC_PATH)/libavcodec/avcodec.h \
- $(SRC_PATH)/libavcodec/common.h \
- $(SRC_PATH)/libavcodec/rational.h \
"$(prefix)/include/ffmpeg"
-- install -d $(libdir)/pkgconfig
-- install -m 644 ../libavcodec.pc $(libdir)/pkgconfig
+- install -d "$(libdir)/pkgconfig"
+- install -m 644 ../libavcodec.pc "$(libdir)/pkgconfig"
+ install -d $(prefix)/libdata/pkgconfig
+ ${BSD_INSTALL_DATA} ../libavcodec.pc $(prefix)/libdata/pkgconfig
diff --git a/multimedia/ffmpeg-devel/files/patch-libavcodec::bswap.h b/multimedia/ffmpeg-devel/files/patch-libavcodec::bswap.h
deleted file mode 100644
index 436ec36de958..000000000000
--- a/multimedia/ffmpeg-devel/files/patch-libavcodec::bswap.h
+++ /dev/null
@@ -1,34 +0,0 @@
---- libavcodec/bswap.h.orig Tue May 10 15:54:38 2005
-+++ libavcodec/bswap.h Fri May 13 02:12:48 2005
-@@ -6,8 +6,31 @@
- #ifndef __BSWAP_H__
- #define __BSWAP_H__
-
-+/* to detect __FreeBSD_version */
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #ifdef HAVE_BYTESWAP_H
- #include <byteswap.h>
-+#elif (defined(__FreeBSD__) && __FreeBSD_version >= 500000)
-+#include <sys/endian.h>
-+#define bswap_16(x) bswap16(x)
-+#define bswap_32(x) bswap32(x)
-+#define bswap_64(x) bswap64(x)
-+#elif (defined(__FreeBSD__) && __FreeBSD_version <= 500000)
-+#include <sys/endian.h>
-+#define bswap_16(x) be16toh(x)
-+#define bswap_32(x) be32toh(x)
-+#define bswap_64(x) \
-+ x = ((((x) & 0xff00000000000000) >> 56) | \
-+ (((x) & 0x00ff000000000000) >> 40) | \
-+ (((x) & 0x0000ff0000000000) >> 24) | \
-+ (((x) & 0x000000ff00000000) >> 8) | \
-+ (((x) & 0x00000000ff000000) << 8) | \
-+ (((x) & 0x0000000000ff0000) << 24) | \
-+ (((x) & 0x000000000000ff00) << 40) | \
-+ (((x) & 0x00000000000000ff) << 56))
- #else
-
- #ifdef ARCH_X86_64
diff --git a/multimedia/ffmpeg-devel/files/patch-libavcodec::libpostproc::Makefile b/multimedia/ffmpeg-devel/files/patch-libavcodec::libpostproc::Makefile
index 67c531e3bebc..b374020c899c 100644
--- a/multimedia/ffmpeg-devel/files/patch-libavcodec::libpostproc::Makefile
+++ b/multimedia/ffmpeg-devel/files/patch-libavcodec::libpostproc::Makefile
@@ -1,15 +1,24 @@
---- libavcodec/libpostproc/Makefile.orig Thu May 26 13:50:31 2005
-+++ libavcodec/libpostproc/Makefile Thu May 26 14:00:11 2005
-@@ -56,16 +56,14 @@
- install $(INSTALLSTRIP) -m 755 $(SPPLIB) "$(prefix)"
+--- libavcodec/libpostproc/Makefile.orig Mon Nov 28 22:37:54 2005
++++ libavcodec/libpostproc/Makefile Mon Nov 28 22:47:35 2005
+@@ -20,7 +20,7 @@
+ PPOBJS=postprocess.o
+ SPPOBJS=postprocess_pic.o
+
+-CFLAGS = $(OPTFLAGS) $(MLIB_INC) -I. -I.. $(EXTRA_INC)
++CFLAGS = $(OPTFLAGS) $(MLIB_INC) -I. -I.. $(EXTRA_INC) -I/usr/home/lioux/src/myports/ports/multimedia/ffmpeg-devel/work/FFMpeg-2005112800/libavcodec -I/usr/home/lioux/src/myports/ports/multimedia/ffmpeg-devel/work/FFMpeg-2005112800/libavcodec/i386 -I/usr/home/lioux/src/myports/ports/multimedia/ffmpeg-devel/work/FFMpeg-2005112800/libavformat -I/usr/local/include -I/usr/X11R6/include -I. -I.. -L/usr/local/lib -L/usr/X11R6/lib -O -pipe -pipe -funit-at-a-time -m3dnow -msse -mfpmath=sse,387 -falign-functions -fforce-addr -fforce-mem -foptimize-register-move -foptimize-sibling-calls -fpeel-loops -fprefetch-loop-arrays -freorder-blocks -march=athlon-xp -fno-force-addr -I/usr/local/include/vorbis
+ # -I/usr/X11R6/include/
+
+ .SUFFIXES: .c .o
+@@ -62,16 +62,14 @@
+ install $(INSTALLSTRIP) -m 755 $(SPPLIBNAME) "$(prefix)"
else
install -d $(libdir)
-- install $(INSTALLSTRIP) -m 755 $(SPPLIB) $(libdir)/$(SPPLIB).$(SPPVERSION)
-- ln -sf $(SPPLIB).$(SPPVERSION) $(libdir)/$(SPPLIB)
-- ln -sf $(SPPLIB).$(SPPVERSION) $(libdir)/$(SPPLIB).$(SPPMAJOR)
+- install $(INSTALLSTRIP) -m 755 $(SPPLIBNAME) $(libdir)/$(SPPLIB)
+- ln -sf $(SPPLIB) $(libdir)/$(SPPLIBNAME)
+- ln -sf $(SPPLIB) $(libdir)/$(SPPLIBMAJOR)
- install -d $(libdir)/pkgconfig
- install -m 644 ../../libpostproc.pc $(libdir)/pkgconfig
-+ ${BSD_INSTALL_DATA} $(SPPLIB) $(libdir)/libpostproc.so
++ ${BSD_INSTALL_DATA} $(SPPLIBNAME) $(libdir)/libpostproc.so
+ install -d $(prefix)/libdata/pkgconfig
+ ${BSD_INSTALL_DATA} ../../libpostproc.pc $(prefix)/libdata/pkgconfig
$(LDCONFIG) || true
diff --git a/multimedia/ffmpeg-devel/files/patch-libavcodec::x264.c b/multimedia/ffmpeg-devel/files/patch-libavcodec::x264.c
deleted file mode 100644
index 5c4d4cc6085a..000000000000
--- a/multimedia/ffmpeg-devel/files/patch-libavcodec::x264.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libavcodec/x264.c.orig Sun May 1 16:15:23 2005
-+++ libavcodec/x264.c Sun May 1 16:14:58 2005
-@@ -19,6 +19,7 @@
-
- #include "avcodec.h"
- #include <x264.h>
-+#include <math.h>
-
- typedef struct X264Context {
- x264_param_t params;
diff --git a/multimedia/ffmpeg-devel/files/patch-libavformat::Makefile b/multimedia/ffmpeg-devel/files/patch-libavformat::Makefile
index 74f8e4edd0d6..3d3e577a1fc8 100644
--- a/multimedia/ffmpeg-devel/files/patch-libavformat::Makefile
+++ b/multimedia/ffmpeg-devel/files/patch-libavformat::Makefile
@@ -1,16 +1,16 @@
---- libavformat/Makefile.orig Sun May 22 20:58:36 2005
-+++ libavformat/Makefile Thu May 26 13:30:00 2005
-@@ -109,8 +109,7 @@
- install $(INSTALLSTRIP) -m 755 $(SLIB) "$(prefix)"
+--- libavformat/Makefile.orig Mon Nov 28 22:06:13 2005
++++ libavformat/Makefile Mon Nov 28 22:07:39 2005
+@@ -113,8 +113,7 @@
+ install $(INSTALLSTRIP) -m 755 $(SLIBNAME) "$(prefix)"
else
install -d $(libdir)
-- install $(INSTALLSTRIP) -m 755 $(SLIB) $(libdir)/libavformat-$(VERSION).so
-- ln -sf libavformat-$(VERSION).so $(libdir)/libavformat.so
-+ ${BSD_INSTALL_DATA} $(SLIB) $(libdir)/libavformat.so
+- install $(INSTALLSTRIP) -m 755 $(SLIBNAME) $(libdir)/$(SLIBPREF)avformat-$(VERSION)$(SLIBSUF)
+- ln -sf $(SLIBPREF)avformat-$(VERSION)$(SLIBSUF) $(libdir)/$(SLIBNAME)
++ ${BSD_INSTALL_DATA} $(SLIBNAME) $(libdir)/libavformat.so
$(LDCONFIG) || true
endif
else
-@@ -122,12 +121,12 @@
+@@ -126,12 +125,12 @@
install-headers:
mkdir -p "$(prefix)/include/ffmpeg"
@@ -19,10 +19,10 @@
$(SRC_PATH)/libavformat/rtp.h $(SRC_PATH)/libavformat/rtsp.h \
$(SRC_PATH)/libavformat/rtspcodes.h \
"$(prefix)/include/ffmpeg"
-- install -d $(libdir)/pkgconfig
-- install -m 644 ../libavformat.pc $(libdir)/pkgconfig
+- install -d "$(libdir)/pkgconfig"
+- install -m 644 ../libavformat.pc "$(libdir)/pkgconfig"
+ install -d $(prefix)/libdata/pkgconfig
+ ${BSD_INSTALL_DATA} ../libavformat.pc $(prefix)/libdata/pkgconfig
%.o: %.c
- $(CC) $(CFLAGS) -c -o $@ $<
+ $(CC) $(CFLAGS) $(LIBOBJFLAGS) -c -o $@ $<
diff --git a/multimedia/ffmpeg-devel/files/patch-libavutil__bswap.h b/multimedia/ffmpeg-devel/files/patch-libavutil__bswap.h
new file mode 100644
index 000000000000..7cbce43f6018
--- /dev/null
+++ b/multimedia/ffmpeg-devel/files/patch-libavutil__bswap.h
@@ -0,0 +1,21 @@
+--- libavutil/bswap.h.orig Mon Nov 28 22:16:18 2005
++++ libavutil/bswap.h Mon Nov 28 22:21:22 2005
+@@ -6,8 +6,18 @@
+ #ifndef __BSWAP_H__
+ #define __BSWAP_H__
+
++/* to detect __FreeBSD_version */
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
+ #ifdef HAVE_BYTESWAP_H
+ #include <byteswap.h>
++#elif (defined(__FreeBSD__) && __FreeBSD_version >= 500000)
++# include <sys/endian.h>
++# define bswap_16(x) bswap16(x)
++# define bswap_32(x) bswap32(x)
++# define bswap_64(x) bswap64(x)
+ #else
+
+ #ifdef ARCH_X86_64
diff --git a/multimedia/ffmpeg-devel/pkg-plist b/multimedia/ffmpeg-devel/pkg-plist
index d8e005ceedd6..862289814250 100644
--- a/multimedia/ffmpeg-devel/pkg-plist
+++ b/multimedia/ffmpeg-devel/pkg-plist
@@ -2,8 +2,12 @@ bin/ffmpeg
include/ffmpeg/avcodec.h
include/ffmpeg/avformat.h
include/ffmpeg/avio.h
+include/ffmpeg/avutil.h
include/ffmpeg/common.h
include/ffmpeg/dsputil.h
+include/ffmpeg/integer.h
+include/ffmpeg/intfloat_readwrite.h
+include/ffmpeg/mathematics.h
include/ffmpeg/rational.h
include/ffmpeg/rtp.h
include/ffmpeg/rtsp.h
@@ -14,5 +18,10 @@ lib/libavcodec.so.%%SHLIB_VERSION%%
lib/libavformat.a
lib/libavformat.so
lib/libavformat.so.%%SHLIB_VERSION%%
+lib/libavutil-CVS.so
+lib/libavutil.a
+lib/libavutil.so
+lib/libavutil.so.%%SHLIB_VERSION%%
+lib/pkgconfig/libavutil.pc
libdata/pkgconfig/libavcodec.pc
libdata/pkgconfig/libavformat.pc