aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-04-18 20:41:52 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-04-18 20:41:52 +0000
commitc9778da82f0cbaa662f69c969584bfe80b0cb0e2 (patch)
tree83af079c5439665999b5dfd2acd77642d07b990a /multimedia/ffmpeg/Makefile
parent14b0cf780617b5690c978fe84d730ca82632d063 (diff)
downloadports-c9778da82f0cbaa662f69c969584bfe80b0cb0e2.tar.gz
ports-c9778da82f0cbaa662f69c969584bfe80b0cb0e2.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg/Makefile')
-rw-r--r--multimedia/ffmpeg/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 82da753406f7..75c11157c228 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -40,6 +40,7 @@ OPTIONS= AMR_NB "AMR Narrow Band encoder" off \
SCHROEDINGER "Dirac codec via libschroedinger" on \
SDL "SDL support (build ffplay)" off \
SPEEX "Speex audio decoder" off \
+ SSSE3 "Enable ssse3 support (gcc 4.4+)" off \
THEORA "Theora encoder (implies OGG)" on \
VHOOK "Video hook support" off \
VORBIS "Vorbis encoder via libvorbis (implies OGG)" on \
@@ -111,6 +112,11 @@ PORTDOCS= *
USE_RC_SUBR= ffserver
.endif
+.if defined(WITH_SSSE3)
+USE_GCC= 4.4+
+BUILD_DEPENDS+= as:${PORTSDIR}/devel/binutils
+.endif
+
# sse hardware vector support
.if defined(MACHINE_CPU) && (${MACHINE_CPU:Msse} == "sse" || ${MACHINE_CPU:Mamd64} == "amd64")
WITH_BUILTIN_VECTOR= yes