aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg/files
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-07-29 00:46:08 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-07-29 00:46:08 +0000
commitb07ec5fead8770209b7bfae4baa7c91e15895653 (patch)
treebc9b7c1a414ea381edbe014689a34bdc00346d8f /multimedia/ffmpeg/files
parenta4aef534e1d7544ac8298e943977ce6da97c035b (diff)
downloadports-b07ec5fead8770209b7bfae4baa7c91e15895653.tar.gz
ports-b07ec5fead8770209b7bfae4baa7c91e15895653.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg/files')
-rw-r--r--multimedia/ffmpeg/files/amd64-patch55
-rw-r--r--multimedia/ffmpeg/files/patch-configure34
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_Makefile12
3 files changed, 12 insertions, 89 deletions
diff --git a/multimedia/ffmpeg/files/amd64-patch b/multimedia/ffmpeg/files/amd64-patch
deleted file mode 100644
index db2116a39116..000000000000
--- a/multimedia/ffmpeg/files/amd64-patch
+++ /dev/null
@@ -1,55 +0,0 @@
-$OpenBSD: patch-libavcodec_mpegvideo_c,v 1.1 2007/01/23 09:34:45 robert Exp $
---- libavcodec/mpegvideo.c.orig Sat Dec 23 05:05:36 2006
-+++ libavcodec/mpegvideo.c Tue Jan 2 18:22:01 2007
-@@ -4837,7 +4837,7 @@ static int pre_estimate_motion_thread(AV
- static int estimate_motion_thread(AVCodecContext *c, void *arg){
- MpegEncContext *s= arg;
-
-- ff_check_alignment();
-+ /*ff_check_alignment();*/
-
- s->me.dia_size= s->avctx->dia_size;
- s->first_slice_line=1;
-@@ -4865,7 +4865,7 @@ static int mb_var_thread(AVCodecContext
- MpegEncContext *s= arg;
- int mb_x, mb_y;
-
-- ff_check_alignment();
-+ /*ff_check_alignment();*/
-
- for(mb_y=s->start_mb_y; mb_y < s->end_mb_y; mb_y++) {
- for(mb_x=0; mb_x < s->mb_width; mb_x++) {
-@@ -4914,7 +4914,7 @@ static int encode_thread(AVCodecContext
- PutBitContext pb[2], pb2[2], tex_pb[2];
- //printf("%d->%d\n", s->resync_mb_y, s->end_mb_y);
-
-- ff_check_alignment();
-+ /*ff_check_alignment();*/
-
- for(i=0; i<2; i++){
- init_put_bits(&pb [i], bit_buf [i], MAX_MB_BYTES);
---- libavcodec/dsputil.c.orig Wed Apr 18 09:42:55 2007
-+++ libavcodec/dsputil.c Wed Apr 18 10:16:01 2007
-@@ -3814,6 +3814,7 @@
- for(i=0; i<64; i++) inv_zigzag_direct16[ff_zigzag_direct[i]]= i+1;
- }
-
-+/*
- int ff_check_alignment(void){
- static int did_fail=0;
- DECLARE_ALIGNED_16(int, aligned);
-@@ -3832,12 +3833,12 @@
- }
- return 0;
- }
--
-+*/
- void dsputil_init(DSPContext* c, AVCodecContext *avctx)
- {
- int i;
-
-- ff_check_alignment();
-+ /*ff_check_alignment();*/
-
- #ifdef CONFIG_ENCODERS
- if(avctx->dct_algo==FF_DCT_FASTINT) {
diff --git a/multimedia/ffmpeg/files/patch-configure b/multimedia/ffmpeg/files/patch-configure
index aa9b8f17d1ed..ac71b897fc17 100644
--- a/multimedia/ffmpeg/files/patch-configure
+++ b/multimedia/ffmpeg/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sun May 27 12:31:02 2007
-+++ configure Wed May 30 21:50:21 2007
+--- configure.orig 2007-07-08 13:47:15.000000000 -0400
++++ configure 2007-07-09 12:37:09.000000000 -0400
@@ -210,11 +210,11 @@
# "tr '[a-z]' '[A-Z]'" is a workaround for Solaris tr not grokking "tr a-z A-Z"
@@ -14,7 +14,7 @@
}
set_all(){
-@@ -1020,15 +1020,9 @@
+@@ -992,15 +992,9 @@
enable fast_unaligned
;;
x86_64|amd64)
@@ -32,30 +32,20 @@
;;
# armv4l is a subset of armv[567]*l
arm|armv[4567]*l)
-@@ -1781,14 +1775,14 @@
- # not all compilers support -Os
- test "$optimize" = "small" && check_cflags -Os
-
--if enabled optimize; then
+@@ -1734,12 +1728,6 @@
+ check_cflags -Os # not all compilers support -Os
+ optimize="small"
+ elif enabled optimize; then
- if test -n "`$cc -v 2>&1 | grep xlc`"; then
- add_cflags "-O5"
- add_ldflags "-O5"
- else
- add_cflags "-O3"
- fi
--fi
-+#if enabled optimize; then
-+# if test -n "`$cc -v 2>&1 | grep xlc`"; then
-+# add_cflags "-O5"
-+# add_ldflags "-O5"
-+# else
-+# add_cflags "-O3"
-+# fi
-+#fi
+ fi
# PIC flags for shared library objects where they are needed
- if enabled shared; then
-@@ -1996,15 +1990,15 @@
+@@ -1927,15 +1915,15 @@
if enabled shared; then
echo "BUILD_SHARED=yes" >> config.mak
echo "PIC=-fPIC -DPIC" >> config.mak
@@ -76,7 +66,7 @@
echo "SWSVERSION=$sws_version" >> config.mak
echo "SLIBNAME=${SLIBNAME}" >> config.mak
echo "SLIBNAME_WITH_VERSION=${SLIBNAME_WITH_VERSION}" >> config.mak
-@@ -2039,7 +2033,7 @@
+@@ -1969,7 +1957,7 @@
echo "SRC_PATH=\"$source_path\"" >> config.mak
echo "SRC_PATH_BARE=$source_path" >> config.mak
@@ -85,7 +75,7 @@
# Apparently it's not possible to portably echo a backslash.
if enabled asmalign_pot; then
-@@ -2119,8 +2113,8 @@
+@@ -2047,8 +2035,8 @@
Version: $version
Requires: $requires
Conflicts:
@@ -96,7 +86,7 @@
EOF
}
-@@ -2143,7 +2137,8 @@
+@@ -2071,7 +2059,8 @@
Requires: $requires
Conflicts:
Libs: \${libdir}/${LIBPREF}${shortname}${LIBSUF} $libs
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_Makefile b/multimedia/ffmpeg/files/patch-libavcodec_Makefile
deleted file mode 100644
index e48db852bb7d..000000000000
--- a/multimedia/ffmpeg/files/patch-libavcodec_Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- libavcodec/Makefile.orig Thu May 3 08:50:33 2007
-+++ libavcodec/Makefile Thu May 3 08:50:42 2007
-@@ -293,9 +293,7 @@
-
- OBJS-$(HAVE_XVMC_ACCEL) += xvmcvideo.o
-
--ifneq ($(CONFIG_SWSCALER),yes)
- OBJS += imgresample.o
--endif
-
- # processor-specific code
- ifeq ($(TARGET_MMX),yes)