aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-21 01:32:37 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-03-21 01:32:37 +0000
commit53151e47a7f6934cfd4844e41913c5b92ae014bf (patch)
tree52500ec9a6fa8215466898307570d91a3a933954 /multimedia/ffmpeg
parentdc55fb7e065dfea8a820aa9ec6b188d6e0b079f3 (diff)
downloadports-53151e47a7f6934cfd4844e41913c5b92ae014bf.tar.gz
ports-53151e47a7f6934cfd4844e41913c5b92ae014bf.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg')
-rw-r--r--multimedia/ffmpeg/Makefile20
-rw-r--r--multimedia/ffmpeg/pkg-message17
-rw-r--r--multimedia/ffmpeg/pkg-plist1
3 files changed, 19 insertions, 19 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 63f449f9a3d3..537c67554847 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.4.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia audio net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ffmpeg
@@ -166,6 +166,13 @@ LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
CONFIGURE_ARGS+= --enable-faad
.endif
+## post processing
+.ifndef(WITHOUT_POSTPROCESS)
+CONFIGURE_ARGS+= --enable-shared-pp
+PLIST_FILES+= include/ffmpeg/postproc/postprocess.h
+PLIST_DIRS+= include/ffmpeg/postproc
+.endif
+PLIST_DIRS+= include/ffmpeg
pre-everything::
.ifndef(WITH_FREETYPE2)
@@ -193,6 +200,12 @@ pre-everything::
@${ECHO_MSG} 'by defining WITH_OPTIMIZED_CFLAGS'
@${ECHO_MSG}
.endif
+.ifndef(WITHOUT_POSTPROCESS)
+ @${ECHO_MSG} 'You can disable post process support by defining'
+ @${ECHO_MSG} 'WITHOUT_POSTPROCESS'
+ @${ECHO_MSG} 'Beware that this might break some ports that require it'
+ @${ECHO_MSG}
+.endif
.ifndef(WITHOUT_VHOOK)
@${ECHO_MSG} 'You can disable vhook support by defining WITHOUT_VHOOK'
@${ECHO_MSG}
@@ -289,5 +302,10 @@ post-install:
.for file in ${LIB_FILES}
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib/${file:T}
.endfor
+.ifndef(WITHOUT_POSTPROCESS)
+ @${MKDIR} ${PREFIX}/include/ffmpeg/postproc
+ @${INSTALL_DATA} ${WRKSRC}/libavcodec/libpostproc/postprocess.h \
+ ${PREFIX}/include/ffmpeg/postproc/postprocess.h
+.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/ffmpeg/pkg-message b/multimedia/ffmpeg/pkg-message
deleted file mode 100644
index cb70ec87a6b5..000000000000
--- a/multimedia/ffmpeg/pkg-message
+++ /dev/null
@@ -1,17 +0,0 @@
- ATTENTIONATTENTION:
-
-ffmpeg users have reported that older version 0.4.5 encodes faster
-than later ffmpeg versions. Therefore, it might prove better for
-capturing purposes with Brooktree bktr(4) devices. So, if you want
-the additional speed, you might want to try using the ffmpeg045
-port. The current ffmpeg port should be used for all other purposes
-unless you really need the additional speed.
-
-Do not install both ports at the same time. They install conflicting
-files.
-
-- ffmpeg 0.4.5
-ports/multimedia/ffmpeg045
-
-- ffmpeg current
-ports/multimedia/ffmpeg
diff --git a/multimedia/ffmpeg/pkg-plist b/multimedia/ffmpeg/pkg-plist
index a24e68f4e971..cc48bd0c86d8 100644
--- a/multimedia/ffmpeg/pkg-plist
+++ b/multimedia/ffmpeg/pkg-plist
@@ -32,4 +32,3 @@ lib/libavformat.so.%%SHLIB_VERSION%%
%%PORTDOCS%%share/doc/ffmpeg/ffserver-doc.texi
%%PORTDOCS%%@dirrm share/doc/ffmpeg
%%VHOOK%%@dirrm lib/vhook
-@dirrm include/ffmpeg