aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-03-31 13:58:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-03-31 13:58:18 +0000
commit694ee5533aa3eaba3a430504e5def5b30bbfeaa3 (patch)
treec50ac977c802e6e3298640ee8544eafba6ac93f7 /multimedia/ffmpeg
parent35df691a43f8349e57eb88339a99b856f57ec470 (diff)
downloadports-694ee5533aa3eaba3a430504e5def5b30bbfeaa3.tar.gz
ports-694ee5533aa3eaba3a430504e5def5b30bbfeaa3.zip
Notes
Diffstat (limited to 'multimedia/ffmpeg')
-rw-r--r--multimedia/ffmpeg/Makefile4
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_libx264.c37
2 files changed, 39 insertions, 2 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 312187fc5a42..c80c4f43b377 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ffmpeg
DISTVERSION= 2008-07-27
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ahze
@@ -210,7 +210,7 @@ CONFIGURE_ARGS+= --disable-libvorbis
# x264
.ifndef(WITHOUT_X264)
-LIB_DEPENDS+= x264.50:${PORTSDIR}/multimedia/x264
+LIB_DEPENDS+= x264.65:${PORTSDIR}/multimedia/x264
CONFIGURE_ARGS+= --enable-libx264
.else
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_libx264.c b/multimedia/ffmpeg/files/patch-libavcodec_libx264.c
new file mode 100644
index 000000000000..5c7de00067b5
--- /dev/null
+++ b/multimedia/ffmpeg/files/patch-libavcodec_libx264.c
@@ -0,0 +1,37 @@
+--- ./libavcodec/libx264.c.orig 2008-06-12 23:50:13.000000000 +0200
++++ ./libavcodec/libx264.c 2008-10-13 15:47:05.000000000 +0200
+@@ -124,6 +124,8 @@
+ {
+ X264Context *x4 = avctx->priv_data;
+
++ av_freep(&avctx->extradata);
++
+ if(x4->enc)
+ x264_encoder_close(x4->enc);
+
+@@ -162,7 +164,7 @@
+
+ x4->params.i_bframe = avctx->max_b_frames;
+ x4->params.b_cabac = avctx->coder_type == FF_CODER_TYPE_AC;
+- x4->params.b_bframe_adaptive = avctx->b_frame_strategy;
++ x4->params.i_bframe_adaptive = avctx->b_frame_strategy;
+ x4->params.i_bframe_bias = avctx->bframebias;
+ x4->params.b_bframe_pyramid = avctx->flags2 & CODEC_FLAG2_BPYRAMID;
+ avctx->has_b_frames= avctx->flags2 & CODEC_FLAG2_BPYRAMID ? 2 : !!avctx->max_b_frames;
+@@ -227,8 +229,6 @@
+ x4->params.analyse.i_me_range = avctx->me_range;
+ x4->params.analyse.i_subpel_refine = avctx->me_subpel_quality;
+
+- x4->params.analyse.b_bidir_me = avctx->bidir_refine > 0;
+- x4->params.analyse.b_bframe_rdo = avctx->flags2 & CODEC_FLAG2_BRDO;
+ x4->params.analyse.b_mixed_references =
+ avctx->flags2 & CODEC_FLAG2_MIXED_REFS;
+ x4->params.analyse.b_chroma_me = avctx->me_cmp & FF_CMP_CHROMA;
+@@ -253,7 +253,6 @@
+ x4->params.rc.f_ip_factor = 1/fabs(avctx->i_quant_factor);
+ x4->params.rc.f_pb_factor = avctx->b_quant_factor;
+ x4->params.analyse.i_chroma_qp_offset = avctx->chromaoffset;
+- x4->params.rc.psz_rc_eq = avctx->rc_eq;
+
+ x4->params.analyse.b_psnr = avctx->flags & CODEC_FLAG_PSNR;
+ x4->params.i_log_level = X264_LOG_DEBUG;