aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gavl/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-07-22 08:46:59 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-07-22 08:46:59 +0000
commitf0b1bac694b16aba1e508e72ba7eda2db9001612 (patch)
treefceed1d9c88db9a6b7ae0ef7cb549d1668496812 /multimedia/gavl/Makefile
parent1c43feef109b2f695671632d8c4cf07154937c9b (diff)
downloadports-f0b1bac694b16aba1e508e72ba7eda2db9001612.tar.gz
ports-f0b1bac694b16aba1e508e72ba7eda2db9001612.zip
Notes
Diffstat (limited to 'multimedia/gavl/Makefile')
-rw-r--r--multimedia/gavl/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/multimedia/gavl/Makefile b/multimedia/gavl/Makefile
index e8f7bd573134..6f4ffcf94e4c 100644
--- a/multimedia/gavl/Makefile
+++ b/multimedia/gavl/Makefile
@@ -6,17 +6,13 @@
#
PORTNAME= gavl
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= multimedia
MASTER_SITES= SF/gmerlin/${PORTNAME}/${PORTVERSION}
MAINTAINER= mm@FreeBSD.org
COMMENT= A library for handling uncompressed video and audio data
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- samplerate.1:${PORTSDIR}/audio/libsamplerate
-
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -26,21 +22,30 @@ MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --without-cpuflags --without-doxygen
+CONFIGURE_ARGS= --with-cpuflags=none --without-doxygen
PORTDOCS= README
-OPTIONS= OPTIMIZED_CFLAGS "Additional optimizations" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS PNG
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS PNG
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPNG}
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --disable-libpng
+.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_OPTIMIZED_CFLAGS) && ${ARCH} == i386 && ${OSVERSION} < 700000
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS} && ${ARCH} == i386 && ${OSVERSION} < 700000
# Build fails on FreeBSD-6.3 i386 with optimized cflags with gcc 3.4
USE_GCC= 4.2+
.endif
post-patch:
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e \
's|-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math||g' \
${WRKSRC}/configure