aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gnome-mplayer
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-03-11 19:09:14 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-03-11 19:09:14 +0000
commit7385cf0f70272ee7e3b3fe6c3b10019a39a2d861 (patch)
tree969cbabcc8d44ffcea33c9947385e108ad1f487b /multimedia/gnome-mplayer
parent45a90dd7fa229ca53c9470b44ab3141d1ecd3636 (diff)
downloadports-7385cf0f70272ee7e3b3fe6c3b10019a39a2d861.tar.gz
ports-7385cf0f70272ee7e3b3fe6c3b10019a39a2d861.zip
Notes
Diffstat (limited to 'multimedia/gnome-mplayer')
-rw-r--r--multimedia/gnome-mplayer/Makefile50
-rw-r--r--multimedia/gnome-mplayer/pkg-plist100
2 files changed, 73 insertions, 77 deletions
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index cd825982e740..e14017a55e27 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-mplayer
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia gnome
MASTER_SITES= GOOGLE_CODE
@@ -12,33 +12,36 @@ COMMENT= GNOME frontend for MPlayer
LICENSE= GPLv2
-LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- gmtk:${PORTSDIR}/multimedia/gmtk
+LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libgmtk.so:${PORTSDIR}/multimedia/gmtk
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-OPTIONS_DEFINE= ALSA BRAINZ3 DOCS GIO GPOD GTK3 NAUPLUG NLS NOTIFY PULSEAUDIO
+OPTIONS_DEFINE= ALSA BRAINZ3 DOCS GIO GPOD GTK3 NLS NOTIFY PULSEAUDIO
BRAINZ3_DESC= Add support for libmusicbrainz
GIO_DESC= Use GIO for file I/O
GPOD_DESC= Add support for libgpod
-NAUPLUG_DESC= Enable Nautilus plugin
-USES= gmake pkgconfig pkgconfig
+USES= desktop-file-utils gettext gmake pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20
USE_XORG= x11 xscrnsaver
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LIBS='-lintl'
+CONFIGURE_ARGS= --disable-nautilus
-MAN1= ${PORTNAME}.1
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README \
dbus.txt keyboard_shortcuts.txt plugin-interaction.txt
-NO_STAGE= yes
+GLIB_SCHEMAS= apps.gecko-mediaplayer.preferences.gschema.xml \
+ apps.gnome-mplayer.preferences.enums.xml \
+ apps.gnome-mplayer.preferences.gschema.xml
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= libasound.so:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
CONFIGURE_ARGS+= --with-alsa
.else
@@ -46,8 +49,8 @@ CONFIGURE_ARGS+= --without-alsa
.endif
.if ${PORT_OPTIONS:MBRAINZ3}
-LIB_DEPENDS+= musicbrainz3:${PORTSDIR}/audio/libmusicbrainz3 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libmusicbrainz3.so:${PORTSDIR}/audio/libmusicbrainz3 \
+ libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-libmusicbrainz3
.else
CONFIGURE_ARGS+= --without-libmusicbrainz3
@@ -60,7 +63,7 @@ CONFIGURE_ARGS+= --without-gio
.endif
.if ${PORT_OPTIONS:MGPOD}
-LIB_DEPENDS+= gpod:${PORTSDIR}/audio/libgpod
+LIB_DEPENDS+= libgpod.so:${PORTSDIR}/audio/libgpod
CONFIGURE_ARGS+= --with-libgpod
.else
CONFIGURE_ARGS+= --without-libgpod
@@ -74,27 +77,8 @@ USE_GNOME+= gtk20
CONFIGURE_ARGS+= --disable-gtk3
.endif
-.if ${PORT_OPTIONS:MNAUPLUG}
-USE_GNOME+= nautilus2
-PLIST_SUB+= PLUGIN=""
-CONFIGURE_ARGS+= --enable-nautilus
-.else
-PLIST_SUB+= PLUGIN="@comment "
-CONFIGURE_ARGS+= --enable-nautilus=no
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+= --enable-nls
-PLIST_SUB+= NLS=""
-LDFLAGS+= -lintl
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
CONFIGURE_ARGS+= --with-libnotify
.else
@@ -102,7 +86,7 @@ CONFIGURE_ARGS+= --without-libnotify
.endif
.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+= libpulse.so:${PORTSDIR}/audio/pulseaudio
CONFIGURE_ARGS+= --with-pulseaudio
.else
CONFIGURE_ARGS+= --without-pulseaudio
diff --git a/multimedia/gnome-mplayer/pkg-plist b/multimedia/gnome-mplayer/pkg-plist
index cda2e57315e9..b5b32af6ad12 100644
--- a/multimedia/gnome-mplayer/pkg-plist
+++ b/multimedia/gnome-mplayer/pkg-plist
@@ -1,4 +1,5 @@
bin/gnome-mplayer
+man/man1/gnome-mplayer.1.gz
share/applications/gnome-mplayer.desktop
share/gnome-control-center/default-apps/gnome-mplayer.xml
share/icons/hicolor/16x16/apps/gnome-mplayer.png
@@ -7,51 +8,62 @@ share/icons/hicolor/24x24/apps/gnome-mplayer.png
share/icons/hicolor/32x32/apps/gnome-mplayer.png
share/icons/hicolor/48x48/apps/gnome-mplayer.png
share/icons/hicolor/scalable/apps/gnome-mplayer.svg
-%%NLS%%share/locale/ar/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/da/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/de/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/el/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/es/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/et/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/fo/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/fy/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/he/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/id/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/it/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/kk/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/si/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/th/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/ug/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/zh_HK/LC_MESSAGES/gnome-mplayer.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/gnome-mplayer.mo
-%%PLUGIN%%lib/nautilus/extensions-2.0/libgnome-mplayer-properties-page.so
+share/locale/ar/LC_MESSAGES/gnome-mplayer.mo
+share/locale/bg/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ca/LC_MESSAGES/gnome-mplayer.mo
+share/locale/cs/LC_MESSAGES/gnome-mplayer.mo
+share/locale/da/LC_MESSAGES/gnome-mplayer.mo
+share/locale/de/LC_MESSAGES/gnome-mplayer.mo
+share/locale/el/LC_MESSAGES/gnome-mplayer.mo
+share/locale/en_GB/LC_MESSAGES/gnome-mplayer.mo
+share/locale/es/LC_MESSAGES/gnome-mplayer.mo
+share/locale/et/LC_MESSAGES/gnome-mplayer.mo
+share/locale/eu/LC_MESSAGES/gnome-mplayer.mo
+share/locale/fi/LC_MESSAGES/gnome-mplayer.mo
+share/locale/fo/LC_MESSAGES/gnome-mplayer.mo
+share/locale/fr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/fy/LC_MESSAGES/gnome-mplayer.mo
+share/locale/gl/LC_MESSAGES/gnome-mplayer.mo
+share/locale/he/LC_MESSAGES/gnome-mplayer.mo
+share/locale/hr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/hu/LC_MESSAGES/gnome-mplayer.mo
+share/locale/id/LC_MESSAGES/gnome-mplayer.mo
+share/locale/it/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ja/LC_MESSAGES/gnome-mplayer.mo
+share/locale/kk/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ko/LC_MESSAGES/gnome-mplayer.mo
+share/locale/lt/LC_MESSAGES/gnome-mplayer.mo
+share/locale/nl/LC_MESSAGES/gnome-mplayer.mo
+share/locale/pl/LC_MESSAGES/gnome-mplayer.mo
+share/locale/pt/LC_MESSAGES/gnome-mplayer.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ro/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ru/LC_MESSAGES/gnome-mplayer.mo
+share/locale/si/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sv/LC_MESSAGES/gnome-mplayer.mo
+share/locale/th/LC_MESSAGES/gnome-mplayer.mo
+share/locale/tr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ug/LC_MESSAGES/gnome-mplayer.mo
+share/locale/uk/LC_MESSAGES/gnome-mplayer.mo
+share/locale/vi/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-mplayer.mo
@dirrmtry share/gnome-control-center/default-apps
@dirrmtry share/gnome-control-center
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/fy/LC_MESSAGES
+@dirrmtry share/locale/fy
@dirrmtry share/locale/fo/LC_MESSAGES
@dirrmtry share/locale/fo