aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gnome-mplayer
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-01 14:18:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-01 14:18:06 +0000
commit667b143dbe1d1f4a245ea2b6f069e0d17c932828 (patch)
tree263104aefc81c16d76bcb17857b1c0864754df21 /multimedia/gnome-mplayer
parentc9f49ee956fac4088c327055beaf8ea996c2049a (diff)
downloadports-667b143dbe1d1f4a245ea2b6f069e0d17c932828.tar.gz
ports-667b143dbe1d1f4a245ea2b6f069e0d17c932828.zip
Notes
Diffstat (limited to 'multimedia/gnome-mplayer')
-rw-r--r--multimedia/gnome-mplayer/Makefile80
-rw-r--r--multimedia/gnome-mplayer/distinfo3
-rw-r--r--multimedia/gnome-mplayer/pkg-descr9
-rw-r--r--multimedia/gnome-mplayer/pkg-plist22
4 files changed, 114 insertions, 0 deletions
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
new file mode 100644
index 000000000000..f7e537403c35
--- /dev/null
+++ b/multimedia/gnome-mplayer/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: gnome-mplayer
+# Date created: 21 February 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-mplayer
+PORTVERSION= 0.9.4
+CATEGORIES= multimedia gnome
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GNOME frontend for MPlayer
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+
+OPTIONS= GIO "Use GIO for file I/O" off \
+ GCONF "Use Gconf to store preferences" off \
+ NOTIFY "Send notifications of new media" off \
+ GPOD "Add support for libgpod" off \
+ BRAINZ3 "Add support for libmusicbrainz3" off
+
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_GNOME= glib20 gtk20
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --without-alsa
+
+PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README \
+ dbus.txt keyboard_shortcuts.txt plugin-interaction.txt
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GIO)
+CONFIGURE_ARGS+= --with-gio
+.else
+CONFIGURE_ARGS+= --without-gio
+.endif
+
+.if defined(WITH_GCONF)
+USE_GNOME+= gconf2
+CONFIGURE_ARGS+= --with-gconf
+GCONF_SCHEMAS= ${PORTNAME}.schemas
+.else
+CONFIGURE_ARGS+= --without-gconf --disable-schemas-install
+.endif
+
+.if defined(WITH_NOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
+CONFIGURE_ARGS+= --with-libnotify
+.else
+CONFIGURE_ARGS+= --without-libnotify
+.endif
+
+.if defined(WITH_GPOD)
+LIB_DEPENDS+= gpod.3:${PORTSDIR}/audio/libgpod
+CONFIGURE_ARGS+= --with-libgpod
+.else
+CONFIGURE_ARGS+= --without-libgpod
+.endif
+
+.if defined(WITH_BRAINZ3)
+LIB_DEPENDS+= musicbrainz3.6:${PORTSDIR}/audio/libmusicbrainz3
+CONFIGURE_ARGS+= --with-libmusicbrainz3
+.else
+CONFIGURE_ARGS+= --without-libmusicbrainz3
+.endif
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e \
+ 's/install-desktopDATA install-gnome_mplayerdocDATA/install-desktopDATA/' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/gnome-mplayer/distinfo b/multimedia/gnome-mplayer/distinfo
new file mode 100644
index 000000000000..86c89f86e62a
--- /dev/null
+++ b/multimedia/gnome-mplayer/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome-mplayer-0.9.4.tar.gz) = 42722c0361a43c16fea6261b2b2118e9
+SHA256 (gnome-mplayer-0.9.4.tar.gz) = ed02688b294647aa53b5565be4a04553a08fdc203692fdd074b6182f9e060b75
+SIZE (gnome-mplayer-0.9.4.tar.gz) = 540526
diff --git a/multimedia/gnome-mplayer/pkg-descr b/multimedia/gnome-mplayer/pkg-descr
new file mode 100644
index 000000000000..3a0f764e8d06
--- /dev/null
+++ b/multimedia/gnome-mplayer/pkg-descr
@@ -0,0 +1,9 @@
+GNOME MPlayer is a simple GUI for MPlayer. It is intended to be a nice tight
+player and provide a simple and clean interface to MPlayer. GNOME MPlayer has
+a rich API that is exposed via DBus. Using DBus you can control a single or
+multiple instances of GNOME MPlayer from a single command.
+
+The player can be used to play media on websites
+when used with Gecko Mediaplayer
+
+WWW: http://kdekorte.googlepages.com/gnomemplayer
diff --git a/multimedia/gnome-mplayer/pkg-plist b/multimedia/gnome-mplayer/pkg-plist
new file mode 100644
index 000000000000..2dad7718eb36
--- /dev/null
+++ b/multimedia/gnome-mplayer/pkg-plist
@@ -0,0 +1,22 @@
+bin/gnome-mplayer
+share/applications/gnome-mplayer.desktop
+share/locale/bg/LC_MESSAGES/gnome-mplayer.mo
+share/locale/de/LC_MESSAGES/gnome-mplayer.mo
+share/locale/en/LC_MESSAGES/gnome-mplayer.mo
+share/locale/es/LC_MESSAGES/gnome-mplayer.mo
+share/locale/fr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/it/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ko/LC_MESSAGES/gnome-mplayer.mo
+share/locale/pl/LC_MESSAGES/gnome-mplayer.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ro/LC_MESSAGES/gnome-mplayer.mo
+share/locale/ru/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-mplayer.mo
+share/locale/sv/LC_MESSAGES/gnome-mplayer.mo
+share/locale/tr/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-mplayer.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-mplayer.mo
+share/pixmaps/gnome-mplayer.png
+@dirrmtry share/applications