aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-bad
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
commitd8e1e16e64701b6d51c9402ad779fd5560b8ce51 (patch)
tree266f139932061c245ade2aa3ef5c087c802dc5e3 /multimedia/gstreamer-plugins-bad
parent96ae3a6609c06c520d2aad7f2f89fb23d7b54e8e (diff)
downloadports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.tar.gz
ports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-bad')
-rw-r--r--multimedia/gstreamer-plugins-bad/Makefile41
-rw-r--r--multimedia/gstreamer-plugins-bad/pkg-plist9
2 files changed, 50 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-bad/Makefile b/multimedia/gstreamer-plugins-bad/Makefile
new file mode 100644
index 000000000000..0b18e113a617
--- /dev/null
+++ b/multimedia/gstreamer-plugins-bad/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gstreamer-plugins-bad
+# Date created: 20 Jan 2006
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins-bad/Makefile,v 1.2 2006/02/26 19:23:20 marcus Exp $
+#
+
+PORTREVISION= 1
+CATEGORIES= multimedia
+
+COMMENT= Bad gstreamer-plugins
+
+GST_PLUGIN= bad
+GST_PLUGIN_SUFFIX= -bad
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+
+EXTRACT_ONLY= ${BAD_DISTFILE}
+WRKSRC= ${WRKDIR}/${BAD_DISTNAME}
+
+BAD_GST_DIRS= gst sys
+PLIST_SUB= VERSION="${GST_VERSION}"
+NO_GSTREAMER_COMMON= yes
+PLIST= ${.CURDIR}/pkg-plist
+
+do-build:
+.for dir in ${BAD_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for dir in ${BAD_GST_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.endfor
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer-plugins-bad/pkg-plist b/multimedia/gstreamer-plugins-bad/pkg-plist
new file mode 100644
index 000000000000..965c4c366b7d
--- /dev/null
+++ b/multimedia/gstreamer-plugins-bad/pkg-plist
@@ -0,0 +1,9 @@
+lib/gstreamer-%%VERSION%%/libgstqtdemux.a
+lib/gstreamer-%%VERSION%%/libgstqtdemux.la
+lib/gstreamer-%%VERSION%%/libgstqtdemux.so
+lib/gstreamer-%%VERSION%%/libgstspeed.a
+lib/gstreamer-%%VERSION%%/libgstspeed.la
+lib/gstreamer-%%VERSION%%/libgstspeed.so
+lib/gstreamer-%%VERSION%%/libgsttta.a
+lib/gstreamer-%%VERSION%%/libgsttta.la
+lib/gstreamer-%%VERSION%%/libgsttta.so