aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-buzztard
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-06-25 15:14:07 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-06-25 15:14:07 +0000
commit3a020c1895109999b7eb1c35ac919965a94728eb (patch)
treec91a044c85609ebcd442a8fffb985d9f6c179a80 /multimedia/gstreamer-plugins-buzztard
parent52921233960bec348e56b32a31cc5ffd669424b0 (diff)
downloadports-3a020c1895109999b7eb1c35ac919965a94728eb.tar.gz
ports-3a020c1895109999b7eb1c35ac919965a94728eb.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-buzztard')
-rw-r--r--multimedia/gstreamer-plugins-buzztard/Makefile30
-rw-r--r--multimedia/gstreamer-plugins-buzztard/distinfo3
-rw-r--r--multimedia/gstreamer-plugins-buzztard/pkg-descr3
-rw-r--r--multimedia/gstreamer-plugins-buzztard/pkg-plist55
4 files changed, 91 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-buzztard/Makefile b/multimedia/gstreamer-plugins-buzztard/Makefile
new file mode 100644
index 000000000000..154ed6f2e2bf
--- /dev/null
+++ b/multimedia/gstreamer-plugins-buzztard/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gstreamer-plugins-buzztard
+# Date created: 2007-06-24
+# Whom: Michael Johnson <ahze@buh.ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= buzztard
+PORTVERSION= 0.2.0
+CATEGORIES= multimedia
+MASTER_SITES= SF
+PKGNAMEPREFIX= gstreamer-plugins-
+DISTNAME= gst-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Buzztard gstreamer plugins
+
+LIB_DEPENDS= fluidsynth.2:${PORTSDIR}/audio/fluidsynth
+
+USE_AUTOTOOLS= libtool:15
+USE_GSTREAMER= yes
+USE_GNOME= gnomehack ltverhack
+USE_LDCONFIG= yes
+PLIST_SUB= GST_VERSION="${GST_VERSION}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${datadir}/gtk-doc/html|${DOCSDIR}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-plugins-buzztard/distinfo b/multimedia/gstreamer-plugins-buzztard/distinfo
new file mode 100644
index 000000000000..6cd913bab2b6
--- /dev/null
+++ b/multimedia/gstreamer-plugins-buzztard/distinfo
@@ -0,0 +1,3 @@
+MD5 (gst-buzztard-0.2.0.tar.gz) = 0a7f74602677522cbb78745320e5897e
+SHA256 (gst-buzztard-0.2.0.tar.gz) = 3fd96cc526370c6cb6397e706cb17ddf06519041cdf94712d3582906ea647cb9
+SIZE (gst-buzztard-0.2.0.tar.gz) = 435118
diff --git a/multimedia/gstreamer-plugins-buzztard/pkg-descr b/multimedia/gstreamer-plugins-buzztard/pkg-descr
new file mode 100644
index 000000000000..4faf01bb12b8
--- /dev/null
+++ b/multimedia/gstreamer-plugins-buzztard/pkg-descr
@@ -0,0 +1,3 @@
+Buzztard gstreamer plugins
+
+WWW: http://www.buzztard.org
diff --git a/multimedia/gstreamer-plugins-buzztard/pkg-plist b/multimedia/gstreamer-plugins-buzztard/pkg-plist
new file mode 100644
index 000000000000..bbca32fde0d7
--- /dev/null
+++ b/multimedia/gstreamer-plugins-buzztard/pkg-plist
@@ -0,0 +1,55 @@
+include/gstreamer-0.10/gst/childbin/childbin.h
+include/gstreamer-0.10/gst/envelope/envelope.h
+include/gstreamer-0.10/gst/help/help.h
+include/gstreamer-0.10/gst/note2frequency/note2frequency.h
+include/gstreamer-0.10/gst/preset/preset.h
+include/gstreamer-0.10/gst/propertymeta/propertymeta.h
+include/gstreamer-0.10/gst/tempo/tempo.h
+lib/gstreamer-0.10/libgstaudiodelay.a
+lib/gstreamer-0.10/libgstaudiodelay.la
+lib/gstreamer-0.10/libgstaudiodelay.so
+lib/gstreamer-0.10/libgstfluidsynth.a
+lib/gstreamer-0.10/libgstfluidsynth.la
+lib/gstreamer-0.10/libgstfluidsynth.so
+lib/gstreamer-0.10/libgstfluidsynth.so.0
+lib/gstreamer-0.10/libgstsimsyn.a
+lib/gstreamer-0.10/libgstsimsyn.la
+lib/gstreamer-0.10/libgstsimsyn.so
+lib/libgstbuzztard.a
+lib/libgstbuzztard.la
+lib/libgstbuzztard.so
+lib/libgstbuzztard.so.0
+libdata/pkgconfig/libgstbuzztard.pc
+%%DOCSDIR%%/gst-buzztard/GstAudioDelay.html
+%%DOCSDIR%%/gst-buzztard/GstChildBin.html
+%%DOCSDIR%%/gst-buzztard/GstHelp.html
+%%DOCSDIR%%/gst-buzztard/GstNote2Frequency.html
+%%DOCSDIR%%/gst-buzztard/GstPreset.html
+%%DOCSDIR%%/gst-buzztard/GstPropertyMeta.html
+%%DOCSDIR%%/gst-buzztard/GstSimSyn.html
+%%DOCSDIR%%/gst-buzztard/GstTempo.html
+%%DOCSDIR%%/gst-buzztard/api-index.html
+%%DOCSDIR%%/gst-buzztard/ch01.html
+%%DOCSDIR%%/gst-buzztard/ch02.html
+%%DOCSDIR%%/gst-buzztard/ch03.html
+%%DOCSDIR%%/gst-buzztard/gst-buzztard-GstEnvelope.html
+%%DOCSDIR%%/gst-buzztard/gst-buzztard.devhelp
+%%DOCSDIR%%/gst-buzztard/gst-buzztard.devhelp2
+%%DOCSDIR%%/gst-buzztard/hierarchy.html
+%%DOCSDIR%%/gst-buzztard/home.png
+%%DOCSDIR%%/gst-buzztard/index.html
+%%DOCSDIR%%/gst-buzztard/index.sgml
+%%DOCSDIR%%/gst-buzztard/left.png
+%%DOCSDIR%%/gst-buzztard/pr01.html
+%%DOCSDIR%%/gst-buzztard/right.png
+%%DOCSDIR%%/gst-buzztard/style.css
+%%DOCSDIR%%/gst-buzztard/up.png
+@dirrm %%DOCSDIR%%/gst-buzztard
+@dirrm %%DOCSDIR%%
+@dirrmtry include/gstreamer-0.10/gst/tempo
+@dirrmtry include/gstreamer-0.10/gst/propertymeta
+@dirrmtry include/gstreamer-0.10/gst/preset
+@dirrmtry include/gstreamer-0.10/gst/note2frequency
+@dirrmtry include/gstreamer-0.10/gst/help
+@dirrmtry include/gstreamer-0.10/gst/envelope
+@dirrmtry include/gstreamer-0.10/gst/childbin