aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-core80
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-28 22:16:10 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-28 22:16:10 +0000
commitdaf4cc81e4d055f630943b557402293b79680953 (patch)
tree8478681967016f816092cb7e0ded4578aa26bd4e /multimedia/gstreamer-plugins-core80
parentffcbb5ca66c4bee1c2b113913a1208cd9f034a27 (diff)
downloadports-daf4cc81e4d055f630943b557402293b79680953.tar.gz
ports-daf4cc81e4d055f630943b557402293b79680953.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-core80')
-rw-r--r--multimedia/gstreamer-plugins-core80/Makefile40
-rw-r--r--multimedia/gstreamer-plugins-core80/pkg-descr3
2 files changed, 43 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-core80/Makefile b/multimedia/gstreamer-plugins-core80/Makefile
new file mode 100644
index 000000000000..c02906679221
--- /dev/null
+++ b/multimedia/gstreamer-plugins-core80/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gstreamer-plugins-core
+# Date created: 2004-11-15
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer-plugins-core
+PORTVERSION= 0.8
+PORTREVISION= 1
+CATEGORIES= multimedia audio
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Core set of typical audio and video gstreamer-plugins
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+GST_DIR= lib/gstreamer-${PORTVERSION}
+PLIST_FILES= ${GST_DIR}/.gstreamer-plugins-core.keep
+
+# Audio plugins
+USE_GSTREAMER+= a52dec mad vorbis
+
+# Graphics plugins
+USE_GSTREAMER+= libpng
+
+# Multimedia plugins
+USE_GSTREAMER+= ffmpeg dts dvd xvid
+
+do-install:
+ if [ ! -d ${PREFIX}/${GST_DIR} ]; then \
+ ${MKDIR} ${PREFIX}/${GST_DIR} ; \
+ fi
+ ${TOUCH} -f ${PREFIX}/${GST_DIR}/.gstreamer-plugins-core.keep
+
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-plugins-core80/pkg-descr b/multimedia/gstreamer-plugins-core80/pkg-descr
new file mode 100644
index 000000000000..90895a218dc8
--- /dev/null
+++ b/multimedia/gstreamer-plugins-core80/pkg-descr
@@ -0,0 +1,3 @@
+Meta-port to core "typical" gstreamer-plugins
+
+WWW: http://gstreamer.net