aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-core
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-19 08:34:40 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-19 08:34:40 +0000
commitf9123f019600c1994a24c0dfd334f2c8c5a66d75 (patch)
tree1ee2b48ef9c20641b7115f15ddcc0507ea055bd2 /multimedia/gstreamer-plugins-core
parent18c823ddce962d4d1b0683f67d1b72df5d30b5b2 (diff)
downloadports-f9123f019600c1994a24c0dfd334f2c8c5a66d75.tar.gz
ports-f9123f019600c1994a24c0dfd334f2c8c5a66d75.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-core')
-rw-r--r--multimedia/gstreamer-plugins-core/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/multimedia/gstreamer-plugins-core/Makefile b/multimedia/gstreamer-plugins-core/Makefile
index 84861f3d1f46..2bec73caf983 100644
--- a/multimedia/gstreamer-plugins-core/Makefile
+++ b/multimedia/gstreamer-plugins-core/Makefile
@@ -22,14 +22,22 @@ NO_BUILD= yes
GST_DIR= lib/gstreamer-${PORTVERSION}
PLIST_FILES= ${GST_DIR}/.gstreamer-plugins-core.keep
+WANT_GSTREAMER= yes
+
+.include <bsd.port.pre.mk>
+
# Audio plugins
-USE_GSTREAMER+= mad vorbis
+USE_GSTREAMER+= mad vorbis
# Graphics plugins
USE_GSTREAMER+= libpng
# Multimedia plugins
-USE_GSTREAMER+= ffmpeg xvid
+USE_GSTREAMER+= ffmpeg
+
+.if ${OSVERSION} > 500035 || defined(WITH_XVID)
+USE_GSTREAMER+= xvid
+.endif
.if !defined(WITHOUT_DVD)
# Audio plugins
@@ -43,6 +51,10 @@ pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} " Disable DVD plugins by defining WITHOUT_DVD"
@${ECHO_MSG} ""
+.if ${OSVERSION} < 500035 && !defined(WITH_XVID)
+ @${ECHO_MSG} " Enable XVID plugins by defining WITH_XVID"
+ @${ECHO_MSG} ""
+.endif
do-install:
if [ ! -d ${PREFIX}/${GST_DIR} ]; then \
@@ -50,4 +62,4 @@ do-install:
fi
${TOUCH} -f ${PREFIX}/${GST_DIR}/.gstreamer-plugins-core.keep
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>