aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-gnonlin/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-06-02 15:44:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-06-02 15:44:53 +0000
commit902986329d8578b883ec30719761956e5473025b (patch)
treeacba84c0d777d519e479c864d9b6293087dd1441 /multimedia/gstreamer-plugins-gnonlin/Makefile
parent1eab858ef36a9213c400ff41c0e7f824a4f808cc (diff)
downloadports-902986329d8578b883ec30719761956e5473025b.tar.gz
ports-902986329d8578b883ec30719761956e5473025b.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-gnonlin/Makefile')
-rw-r--r--multimedia/gstreamer-plugins-gnonlin/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-gnonlin/Makefile b/multimedia/gstreamer-plugins-gnonlin/Makefile
new file mode 100644
index 000000000000..b3509e8c18c5
--- /dev/null
+++ b/multimedia/gstreamer-plugins-gnonlin/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnonlin
+# Date created: 2 June 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnonlin
+PORTVERSION= 0.2.2
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= GStreamer extension library for non-linear editing
+
+LIB_DEPENDS= gstreamer-0.8.5:${PORTSDIR}/multimedia/gstreamer
+
+CONFLICTS= pitivi-0.1.1*
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnometarget
+USE_LIBTOOL_VER= 15
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= gnonlin-config.1
+
+.include <bsd.port.mk>