aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-ugly/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
commitd8e1e16e64701b6d51c9402ad779fd5560b8ce51 (patch)
tree266f139932061c245ade2aa3ef5c087c802dc5e3 /multimedia/gstreamer-plugins-ugly/Makefile
parent96ae3a6609c06c520d2aad7f2f89fb23d7b54e8e (diff)
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins-ugly/Makefile')
-rw-r--r--multimedia/gstreamer-plugins-ugly/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/multimedia/gstreamer-plugins-ugly/Makefile b/multimedia/gstreamer-plugins-ugly/Makefile
new file mode 100644
index 000000000000..f165480d1ffd
--- /dev/null
+++ b/multimedia/gstreamer-plugins-ugly/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: gstreamer-plugins-ugly
+# Date created: 20 Jan 2006
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/multimedia/gstreamer-plugins-ugly/Makefile,v 1.3 2006/04/16 08:42:06 marcus Exp $
+#
+
+PORTREVISION= 2
+CATEGORIES= multimedia
+
+COMMENT= Ugly gstreamer-plugins
+
+GST_PLUGIN= ugly
+GST_PLUGIN_SUFFIX= -ugly
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
+
+EXTRACT_ONLY= ${UGLY_DISTFILE}
+WRKSRC= ${WRKDIR}/${UGLY_DISTNAME}
+
+UGLY_GST_DIRS= gst
+PLIST_SUB= VERSION="${GST_VERSION}"
+NO_GSTREAMER_COMMON= yes
+PLIST= ${.CURDIR}/pkg-plist
+
+do-build:
+.for dir in ${UGLY_GST_DIRS}
+ @(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for dir in ${UGLY_GST_DIRS}
+ @(cd ${INSTALL_WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.endfor
+
+.include "${MASTERDIR}/Makefile"