aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins/Makefile.common
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-09-06 21:10:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-09-06 21:10:50 +0000
commit5b545e24438890b69da5b8d33dc4e205688cbf33 (patch)
treefa7f43588b1ae9866009ecff3e30c1d6a57cccc8 /multimedia/gstreamer-plugins/Makefile.common
parent2d9698d0345d0c95d4f23e7158d4c2d2305b6c4f (diff)
downloadports-5b545e24438890b69da5b8d33dc4e205688cbf33.tar.gz
ports-5b545e24438890b69da5b8d33dc4e205688cbf33.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common25
1 files changed, 23 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 08bf8dffc439..4e3ce689d327 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -14,7 +14,7 @@ BASE_GST_ALL_PLUGINS= \
# bad
BAD_GST_ALL_PLUGINS+= \
alsaspdif \
- amrwbenc \
+ amrwb \
apexsink \
assrender \
bz2 \
@@ -118,7 +118,6 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-examples \
--disable-1394 \
--disable-acm \
- --disable-amrnb \
--disable-alsa \
--disable-dvb \
--disable-http \
@@ -163,6 +162,22 @@ gst_aalib_LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
gst_aalib_PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so \
${GST_LIB_DIR}/libgstaasink.la
+# amrnb
+gst_amrnb_LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
+gst_amrnb_PLIST_FILES= ${GST_LIB_DIR}/libgstamrnb.la \
+ ${GST_LIB_DIR}/libgstamrnb.so \
+ share/gstreamer-${VERSION}/presets/GstAmrnbEnc.prs
+gst_amrnb_PLIST_DIRS= share/gstreamer-${VERSION}/presets \
+ share/gstreamer-${VERSION}
+gst_amrnb_DIST= ugly
+
+# amrwbdec
+gst_amrwbdec_LIB_DEPENDS+= opencore-amrwb.0:${PORTSDIR}/audio/opencore-amr
+gst_amrwbdec_CONFIGURE_ARGS+= --enable-amrwb
+gst_amrwbdec_PLIST_FILES= ${GST_LIB_DIR}/libgstamrwbdec.la \
+ ${GST_LIB_DIR}/libgstamrwbdec.so
+gst_amrwbdec_DIST= ugly
+
# annodex
gst_annodex_LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
gst_annodex_PLIST_FILES= ${GST_LIB_DIR}/libgstannodex.la \
@@ -452,6 +467,12 @@ gst_theora_PLIST_FILES= ${GST_LIB_DIR}/libgsttheora.la \
${GST_LIB_DIR}/libgsttheora.so
gst_theora_DIST= base
+# twolame
+gst_twolame_LIB_DEPENDS+= twolame.0:${PORTSDIR}/audio/twolame
+gst_twolame_PLIST_FILES= ${GST_LIB_DIR}/libgsttwolame.la \
+ ${GST_LIB_DIR}/libgsttwolame.so
+gst_twolame_DIST= ugly
+
# gst_v4l2
gst_gst_v4l2_LIB_DEPENDS+= v4l2.0:${PORTSDIR}/multimedia/libv4l
.if ${OSVERSION} >= 800000