aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins/Makefile.common
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-03-14 22:52:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-03-14 22:52:34 +0000
commitc33f8ccc1b1b387c727cc531b72303f7ef6e08fa (patch)
tree264b41f1f1a771d0014606f1b6be6e84402a4ae2 /multimedia/gstreamer-plugins/Makefile.common
parenta582e114eb7db5cf2ee35ea2d20bccab0a575835 (diff)
downloadports-c33f8ccc1b1b387c727cc531b72303f7ef6e08fa.tar.gz
ports-c33f8ccc1b1b387c727cc531b72303f7ef6e08fa.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common19
1 files changed, 12 insertions, 7 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 45b6a752435b..d5ffb4f06463 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -2,21 +2,24 @@ GST_ALL_PLUGINS= \
a52dec \
aalib \
aalibtest \
- alsa \
+ amrnb \
arts \
artstest \
artsc \
audiofile \
+ audioresample \
cairo \
cdaudio \
cdparanoia \
dirac \
+ directfb \
divx \
dts \
dvdnav \
dvdread \
dxr3 \
esd \
+ esdtest \
faac \
faad \
flac \
@@ -49,6 +52,7 @@ GST_ALL_PLUGINS= \
musicbrainz \
nas \
ogg \
+ oggtest \
opengl \
pango \
polyp \
@@ -56,8 +60,10 @@ GST_ALL_PLUGINS= \
qcam \
raw1394 \
sdl \
+ sdltest \
shout \
shout2 \
+ shout2test \
sidplay \
smoothwave \
sndfile \
@@ -69,6 +75,7 @@ GST_ALL_PLUGINS= \
vcd \
vorbis \
xine \
+ vorbistest \
xvid
# Disable all plugins by default\
@@ -77,6 +84,7 @@ CONFIGURE_ARGS+= --disable-${d}
.endfor
CONFIGURE_ARGS+=--disable-tests \
+ --disable-examples \
--disable-alsa \
--disable-http \
--enable-cdrom \
@@ -86,8 +94,9 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-osx_audio \
--disable-osx_video \
--enable-static \
- --enable-gst_v4l \
- --enable-gst_v4l2 \
+ --disable-sunaudio \
+ --disable-gst_v4l \
+ --disable-gst_v4l2 \
--enable-x \
--enable-xshm \
--enable-xvideo
@@ -430,10 +439,6 @@ do-build:
${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
.endfor
-post-build:
- @${ECHO_CMD} ${PREFIX}/bin/gst-register-${GST_VERSION} \
- --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml
-
do-install:
.for dir in ${GST_PLUGIN_DIR}
@cd ${WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \