aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins/Makefile.common
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-06-09 20:24:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-06-09 20:24:03 +0000
commitf2e4c41d65915c469732c209445ae2845f850d44 (patch)
tree494ddbc8e65d75fb12c8a5474727ea1febbf128f /multimedia/gstreamer-plugins/Makefile.common
parent03b02cf7ce9dc08d8d271ce61a3055756e2fa7e4 (diff)
downloadports-f2e4c41d65915c469732c209445ae2845f850d44.tar.gz
ports-f2e4c41d65915c469732c209445ae2845f850d44.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile.common')
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common23
1 files changed, 15 insertions, 8 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index 8c01dfee3ff6..d1a447ee245c 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -1,5 +1,5 @@
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins/Makefile.common,v 1.40 2006/04/23 21:40:21 marcus Exp $
+# $MCom: ports/multimedia/gstreamer-plugins/Makefile.common,v 1.47 2006/06/08 20:53:40 ahze Exp $
# base
BASE_GST_ALL_PLUGINS= \
alsa \
@@ -106,7 +106,7 @@ CONFIGURE_ARGS+=--disable-spc
PLIST_SUB+= SPC="@comment "
#.endif
-.if ${GST_PLUGIN}!="base" && !defined(NO_GSTREAMER_COMMON)
+.if !defined(NO_GSTREAMER_COMMON)
GST_PLUGIN_SUFFIX?= -${GST_PLUGIN}
COMMENT= Gstreamer ${GST_PLUGIN} plugin
@@ -128,9 +128,6 @@ PLIST_FILES?= ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.a \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.la
-# hack around WRKSRC stuff near the top... fix me
-DIST?= good
-
# a52dec
.if ${GST_PLUGIN}=="a52dec"
LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
@@ -393,24 +390,34 @@ DIST= bad
LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
DIST= bad
.endif
+.endif # NO_GSTREAMER_COMMON
.if ${DIST}=="base"
EXTRACT_ONLY=${BASE_DISTFILE}
WRKSRC=${WRKDIR}/${BASE_DISTNAME}
+PORTVERSION= ${BASE_PORTVERSION}
+DISTFILES+= ${BASE_DISTFILE}:base
.elif ${DIST}=="bad"
EXTRACT_ONLY=${BAD_DISTFILE}
WRKSRC=${WRKDIR}/${BAD_DISTNAME}
+PORTVERSION= ${BAD_PORTVERSION}
+DISTFILES+= ${BAD_DISTFILE}:bad
.elif ${DIST}=="ugly"
EXTRACT_ONLY=${UGLY_DISTFILE}
WRKSRC=${WRKDIR}/${UGLY_DISTNAME}
+PORTVERSION= ${UGLY_PORTVERSION}
+DISTFILES+= ${UGLY_DISTFILE}:ugly
+.elif ${DIST}=="makesum"
+DISTFILES+= ${BASE_DISTFILE}:base ${BAD_DISTFILE}:bad \
+ ${UGLY_DISTFILE}:ugly ${GOOD_DISTFILE}:good
.else
EXTRACT_ONLY=${GOOD_DISTFILE}
WRKSRC=${WRKDIR}/${GOOD_DISTNAME}
+PORTVERSION= ${GOOD_PORTVERSION}
+DISTFILES+= ${GOOD_DISTFILE}:good
.endif
-BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
-RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:${PORTSDIR}/multimedia/gstreamer-plugins
-
+.if !defined(NO_GSTREAMER_COMMON)
.if !target(do-build)
do-build:
.for dir in ${GST_PREBUILD_DIR} ${GST_PLUGIN_DIR} ${GST_POSTBUILD_DIR}