aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-17 07:03:20 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-17 07:03:20 +0000
commit8cc150076ac2e8f997a7d4821a48971c4546a607 (patch)
tree438ae3e2653583552b9d75887627854df85600d9 /multimedia/gstreamer-plugins/Makefile
parent12c6f69fa59480a83616fab9303f4151fd894836 (diff)
downloadports-8cc150076ac2e8f997a7d4821a48971c4546a607.tar.gz
ports-8cc150076ac2e8f997a7d4821a48971c4546a607.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins/Makefile')
-rw-r--r--multimedia/gstreamer-plugins/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 98cc56bbf3fe..5262f64c4e7f 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -137,6 +137,11 @@ post-patch:
.if ${GST_PLUGIN}!="base"
@${REINPLACE_CMD} -E -e 's|ac_config_files=\"*\"|ac_config_files="$$ac_config_files Makefile ${GST_PLUGIN_MAKEFILES}" #|' \
${WRKSRC}/configure
+.else
+.for f in ${GST_ALL_PLUGINS}
+ @${REINPLACE_CMD} -e 's|ext/${f}/Makefile||g' \
+ ${WRKSRC}/configure
+.endfor
.endif
post-build:
@@ -153,7 +158,7 @@ post-install:
. endfor
.endif
# register plugins
- -@${X11BASE}/bin/gst-register-${GST_VERSION} \
- --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
+ -@${X11BASE}/bin/gst-register-${VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${VERSION}/registry.xml 2>/dev/null
.include <bsd.port.post.mk>