aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2004-11-30 22:48:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2004-11-30 22:48:34 +0000
commita5d29142c4b701b930b61e36974f73edab2afbf3 (patch)
treef77368e1998747d7a47911f9a0a3a52c5a3e58c1 /multimedia/gstreamer-plugins
parent72c25115af5405f4f9153b85c2534f3ba4a6a935 (diff)
downloadports-a5d29142c4b701b930b61e36974f73edab2afbf3.tar.gz
ports-a5d29142c4b701b930b61e36974f73edab2afbf3.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile44
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist2
2 files changed, 44 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 70d1d45882ad..b96772f431eb 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -56,8 +56,6 @@ CONFIGURE_ARGS+=\
--disable-tarkin \
--disable-lcs \
--disable-shout2 \
- --disable-libvisual \
- --disable-musepack \
--disable-dirac \
--disable-librfb
@@ -139,6 +137,10 @@ post-patch:
${WRKSRC}/sys/vcd/vcdsrc.c \
${WRKSRC}/sys/vcd/vcdsrc.h
+# tell configure where the musepack includes live
+ @${REINPLACE_CMD} -e 's|/usr/include/musepack|${LOCALBASE}/include/musepack|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
# hermes is required for gstreamer-player to work
@@ -316,6 +318,11 @@ WITH_LIBSNDFILE=yes
WITH_LIBTHEORA=yes
.endif
+# libvisual
+.if exists(${LOCALBASE}/lib/libvisual.a)
+WITH_LIBVISUAL=yes
+.endif
+
# mad
.if exists(${LOCALBASE}/lib/libmad.a)
WITH_MAD=yes
@@ -326,6 +333,11 @@ WITH_MAD=yes
WITH_MJPEGTOOLS=yes
.endif
+# musepack
+.if exists(${LOCALBASE}/lib/libmusepack.a)
+WITH_MUSEPACK=yes
+.endif
+
# nas
.if exists(${X11BASE}/lib/libaudio.a)
WITH_NAS=YES
@@ -736,6 +748,16 @@ LIB_DEPENDS+= theora.0:${PORTSDIR}/graphics/libtheora
PLIST_SUB+= LIBTHEORA=""
.endif
+# libvisual
+.ifndef(WITH_LIBVISUAL)
+CONFIGURE_ARGS+= --disable-libvisual
+PLIST_SUB+= LIBVISUAL="@comment "
+.else
+LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
+
+PLIST_SUB+= LIBVISUAL=""
+.endif
+
# mad
.ifndef(WITH_MAD)
CONFIGURE_ARGS+= --disable-mad
@@ -762,6 +784,16 @@ CONFIGURE_ENV+= HAVE_CXX=yes
PLIST_SUB+= MJPEGTOOLS=""
.endif
+# musepack
+.ifndef(WITH_MUSEPACK)
+CONFIGURE_ARGS+= --disable-musepack
+PLIST_SUB+= MUSEPACK="@comment "
+.else
+LIB_DEPENDS+= musepack.1:${PORTSDIR}/audio/musepack
+
+PLIST_SUB+= MUSEPACK=""
+.endif
+
# nas
.ifndef(WITH_NAS)
CONFIGURE_ARGS+= --disable-nas
@@ -1072,6 +1104,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_LIBTHEORA to enable libtheora Video plugin'
.endif
+.ifndef(WITH_LIBVISUAL)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_LIBVISUAL to enable libvisual Video plugin'
+.endif
.ifndef(WITH_MAD)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MAD to enable mad Audio plugin'
@@ -1080,6 +1116,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_MNG to enable libmng plugin'
.endif
+.ifndef(WITH_MUSEPACK)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_MUSEPACK to enable musepack Audio plugin'
+.endif
.ifndef(WITH_NAS)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_NAS to enable nas Audio plugin'
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 3278513fa2e4..9b9e9c58dd08 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -89,6 +89,7 @@ lib/gstreamer-%%VERSION%%/libgstinterleave.so
%%LAME%%lib/gstreamer-%%VERSION%%/libgstlame.so
lib/gstreamer-%%VERSION%%/libgstlevel.so
%%LIBFAME%%lib/gstreamer-%%VERSION%%/libgstlibfame.so
+%%LIBVISUAL%%lib/gstreamer-%%VERSION%%/libgstlibvisual.so
%%LIBMAD%%lib/gstreamer-%%VERSION%%/libgstmad.so
lib/gstreamer-%%VERSION%%/libgstmatroska.so
lib/gstreamer-%%VERSION%%/libgstmedian.so
@@ -109,6 +110,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegstream.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
lib/gstreamer-%%VERSION%%/libgstmultifilesink.so
lib/gstreamer-%%VERSION%%/libgstmultipart.so
+%%MUSEPACK%%lib/gstreamer-%%VERSION%%/libgstmusepack.so
%%NAS%%lib/gstreamer-%%VERSION%%/libgstnassink.so
lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
%%OGG%%lib/gstreamer-%%VERSION%%/libgstogg.so