aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-06-22 18:33:20 +0000
commit6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e (patch)
treebdb6dbf3e5d4ada04784a3327eb91e0145530524 /multimedia/gstreamer-plugins
parentb8355694f11dec2ab058a135acfc1a0f3c8967c0 (diff)
downloadports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.tar.gz
ports-6e5719ca80bba1b1c1a97fa29ba2147a5c1ba81e.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile5
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common4
2 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index cd8675ced941..a2e4794d63b6 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -57,7 +57,8 @@ CFLAGS+= -I${LOCALBASE}/include
DEFAULT_AUDIOSINK?= osssink
DEFAULT_AUDIOSRC?= osssrc
-.include <bsd.port.pre.mk>
+# Include bsd.port.options.mk and not bsd.port.pre.mk to be able to use USES
+.include <bsd.port.options.mk>
.if ${ARCH}=="i386"
PLIST_SUB+= I386=""
@@ -166,4 +167,4 @@ USE_GCC= any
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index e78c4c48189a..078617f6733d 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -343,7 +343,7 @@ gst_jack_PLIST_FILES= ${GST_LIB_DIR}/libgstjack.la \
gst_jack_DIST= good
# jpeg
-gst_jpeg_LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+gst_jpeg_USES= jpeg
gst_jpeg_PLIST_FILES= ${GST_LIB_DIR}/libgstjpeg.la \
${GST_LIB_DIR}/libgstjpeg.so
@@ -613,6 +613,7 @@ DIST= ${gst_${GST_PLUGIN}_DIST}
gst_${GST_PLUGIN}_BUILD_DEPENDS?=
gst_${GST_PLUGIN}_LIB_DEPENDS?=
gst_${GST_PLUGIN}_RUN_DEPENDS?=
+gst_${GST_PLUGIN}_USES?=
gst_${GST_PLUGIN}_PLIST_FILES?=${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.a \
${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.la
@@ -631,6 +632,7 @@ gst_${GST_PLUGIN}_USE_GSTREAMER?=
BUILD_DEPENDS+= ${gst_${GST_PLUGIN}_BUILD_DEPENDS}
LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
+USES+= ${gst_${GST_PLUGIN}_USES}
PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
PLIST_DIRS= ${gst_${GST_PLUGIN}_PLIST_DIRS}
PLIST_DIRSTRY= ${gst_${GST_PLUGIN}_PLIST_DIRSTRY}