aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 02:46:49 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-03 02:46:49 +0000
commit5dc9b7f571c5ff107f23c55359449e1320f5bc23 (patch)
tree5a017d01eb1fdb09f452ca186cf116b89ff21ba0 /multimedia/gstreamer-plugins
parent54a93712b5de4af20902c4225ea8294420e21eee (diff)
downloadports-5dc9b7f571c5ff107f23c55359449e1320f5bc23.tar.gz
ports-5dc9b7f571c5ff107f23c55359449e1320f5bc23.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 2e0b1d950ef9..b11bb2c3d377 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -41,7 +41,8 @@ INSTALLS_SHLIB= yes
PLIST_SUB= LOCALBASE="${LOCALBASE}"
# for esound detection
-WANT_ESOUND= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
MAN1= gst-launch-ext.1 gst-visualise.1
@@ -138,7 +139,8 @@ WITH_AVIFILE=yes
# esound
.if exists(${LOCALBASE}/lib/libesd.a)
-WITH_ESOUND=yes
+USE_GNOME+= esound
+PKGNAMESUFFIX= -esound
.endif
# flac
@@ -263,12 +265,13 @@ PLIST_SUB+= AVIFILE=""
.endif
# esound
-.if !(defined(HAVE_ESOUND) || defined(WITH_ESOUND))
+.if !(${HAVE_GNOME:Mesound}!="" || defined(WITH_ESOUND))
CONFIGURE_ARGS+= --disable-esd \
--disable-esdtest
PLIST_SUB+= ESOUND="@comment "
.else
-USE_ESOUND= yes
+USE_GNOME+= esound
+PKGNAMESUFFIX= -esound
CONFIGURE_ARGS+= --with-esd-prefix=${LOCALBASE} \
--with-esd-exec-prefix=${LOCALBASE}
PLIST_SUB+= ESOUND=""
@@ -465,7 +468,7 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_AVIFILE to enable avifile Video plugin'
.endif
-.if !(defined(HAVE_ESOUND) || defined(WITH_ESOUND))
+.if !(${HAVE_GNOME:Mesound}!="" || defined(WITH_ESOUND))
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
.endif