aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /multimedia/gstreamer-plugins
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'multimedia/gstreamer-plugins')
-rw-r--r--multimedia/gstreamer-plugins/Makefile64
-rw-r--r--multimedia/gstreamer-plugins/Makefile.common354
-rw-r--r--multimedia/gstreamer-plugins/distinfo18
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist12
4 files changed, 210 insertions, 238 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 17e1666ba640..b3ab71d2f356 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -3,13 +3,13 @@
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins/Makefile,v 1.86 2006/06/09 18:13:48 ahze Exp $
+# $MCom: ports/multimedia/gstreamer-plugins/Makefile,v 1.100 2006/09/14 21:02:22 ahze Exp $
#
PORTNAME= gstreamer
PORTVERSION?= ${BASE_PORTVERSION}
PORTREVISION?= 0
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES?= multimedia audio
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
http://gstreamer.freedesktop.org/src/gst-plugins-bad/:bad \
@@ -24,20 +24,21 @@ PKGNAMESUFFIX= -plugins${GST_PLUGIN_SUFFIX}
MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
+BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
popt.0:${PORTSDIR}/devel/popt \
oil-0.3.1:${PORTSDIR}/devel/liboil
-BASE_PORTVERSION= 0.10.9
+BASE_PORTVERSION= 0.10.10
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
BAD_PORTVERSION= 0.10.3
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
-GOOD_PORTVERSION= 0.10.3
+GOOD_PORTVERSION= 0.10.4
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
-UGLY_PORTVERSION= 0.10.3
+UGLY_PORTVERSION= 0.10.4
UGLY_DISTNAME= gst-plugins-ugly-${UGLY_PORTVERSION}
UGLY_DISTFILE= ${UGLY_DISTNAME}${EXTRACT_SUFX}
DIST?= good
@@ -46,7 +47,6 @@ SHLIB_VERSION= 1
USE_GETTEXT= yes
VERSION= ${GST_VERSION}
WANT_GSTREAMER= yes
-USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME+= gnomehack gnometarget pkgconfig ltverhack
@@ -67,9 +67,9 @@ IGNORE= many plugins don't build or even work on 4.x
.endif
.if ${GST_PLUGIN} == "base"
-DIST= base
+gst_base_DIST= base
NO_GSTREAMER_COMMON= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= gst-visualise-0.10.1
PLIST_SUB+= VERSION="${VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}"
@@ -79,6 +79,34 @@ USE_GSTREAMER= yes
.include "${MASTERDIR}/Makefile.common"
+.if ${DIST}=="base"
+EXTRACT_ONLY=${BASE_DISTFILE}
+WRKSRC=${WRKDIR}/${BASE_DISTNAME}
+PORTVERSION= ${BASE_PORTVERSION}
+DISTFILES+= ${BASE_DISTFILE}:base
+PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins/files
+.elif ${DIST}=="bad"
+EXTRACT_ONLY=${BAD_DISTFILE}
+WRKSRC=${WRKDIR}/${BAD_DISTNAME}
+PORTVERSION= ${BAD_PORTVERSION}
+DISTFILES+= ${BAD_DISTFILE}:bad
+PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-bad/files
+.elif ${DIST}=="ugly"
+EXTRACT_ONLY=${UGLY_DISTFILE}
+WRKSRC=${WRKDIR}/${UGLY_DISTNAME}
+PORTVERSION= ${UGLY_PORTVERSION}
+DISTFILES+= ${UGLY_DISTFILE}:ugly
+PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-ugly/files
+.elif ${DIST}=="makesum"
+DISTFILES+= ${BASE_DISTFILE}:base ${BAD_DISTFILE}:bad \
+ ${UGLY_DISTFILE}:ugly ${GOOD_DISTFILE}:good
+.else
+EXTRACT_ONLY=${GOOD_DISTFILE}
+WRKSRC=${WRKDIR}/${GOOD_DISTNAME}
+PORTVERSION= ${GOOD_PORTVERSION}
+DISTFILES+= ${GOOD_DISTFILE}:good
+.endif
+
# cdrom default device
.ifdef(WITH_CDROM_DEVICE)
DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
@@ -102,23 +130,23 @@ DEFAULT_DVD_DEVICE=/dev/acd0
.endif
post-patch:
+ @${FIND} ${WRKSRC}/ext -name Makefile.in | \
+ ${XARGS} -n 10 ${REINPLACE_CMD} -e \
+ 's|$$(top_builddir)/gst-libs/gst/tag/libgsttag-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgsttag-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-$$(GST_MAJORMINOR).la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|; \
s|stdint\.h|inttypes.h|; \
s|%%VERSION%%|${VERSION}|'
- @${FIND} ${WRKSRC}/ext -name Makefile.in | \
- ${XARGS} -n 10 ${REINPLACE_CMD} -e \
- 's|$$(top_builddir)/gst-libs/gst/tag/libgsttag-$$(GST_MAJORMINOR).la|${X11BASE}/lib/libgsttag-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-$$(GST_MAJORMINOR).la|${X11BASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-$$(GST_MAJORMINOR).la|${X11BASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-$$(GST_MAJORMINOR).la|${X11BASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${FIND} ${WRKSRC}/ext -name Makefile.in | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
- 's|$$(top_builddir)/gst-libs/gst/tag/libgsttag-@GST_MAJORMINOR@.la|${X11BASE}/lib/libgsttag-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-@GST_MAJORMINOR@.la|${X11BASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-@GST_MAJORMINOR@.la|${X11BASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
- s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-@GST_MAJORMINOR@.la|${X11BASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
+ 's|$$(top_builddir)/gst-libs/gst/tag/libgsttag-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgsttag-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/audio/libgstaudio-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstaudio-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/riff/libgstriff-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstriff-@GST_MAJORMINOR@.la|; \
+ s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${REINPLACE_CMD} -e 's|DEFAULT_AUDIOSINK="alsasink"|DEFAULT_AUDIOSINK="${DEFAULT_AUDIOSINK}"|; \
s|DEFAULT_AUDIOSRC="alsasrc"|DEFAULT_AUDIOSRC="${DEFAULT_AUDIOSRC}"|' \
${WRKSRC}/configure
diff --git a/multimedia/gstreamer-plugins/Makefile.common b/multimedia/gstreamer-plugins/Makefile.common
index d2973c0739f8..0e8d97052438 100644
--- a/multimedia/gstreamer-plugins/Makefile.common
+++ b/multimedia/gstreamer-plugins/Makefile.common
@@ -1,5 +1,5 @@
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins/Makefile.common,v 1.47 2006/06/08 20:53:40 ahze Exp $
+# $MCom: ports/multimedia/gstreamer-plugins/Makefile.common,v 1.63 2006/09/29 23:22:28 ahze Exp $
# base
BASE_GST_ALL_PLUGINS= \
alsa \
@@ -89,339 +89,271 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-tarkin \
--enable-static \
--disable-sunaudio \
- --disable-gst_v4l \
- --disable-gst_v4l2 \
--disable-xine \
--enable-x \
--enable-xshm \
--enable-xvideo
-# spc is broken a the moment
-#.if (${ARCH} == "i386")
-#BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
-#CONFIGURE_ARGS+=--enable-spc
-#PLIST_SUB+= SPC=""
-#.else
-CONFIGURE_ARGS+=--disable-spc
-PLIST_SUB+= SPC="@comment "
-#.endif
-
.if !defined(NO_GSTREAMER_COMMON)
GST_PLUGIN_SUFFIX?= -${GST_PLUGIN}
-COMMENT= Gstreamer ${GST_PLUGIN} plugin
-
# Enable the right plugin
CONFIGURE_ARGS:=${CONFIGURE_ARGS:S|--disable-${GST_PLUGIN}|--enable-${GST_PLUGIN}|}
-# Build/Install directory. defaults to ext/${GST_PLUGIN}
-# few plugins are in sys/
-GST_PLUGIN_DIR?= ext/${GST_PLUGIN}
-
-#
GST_LIB_DIR= lib/gstreamer-${VERSION}
# Auto create PLIST
PLIST= ${NONEXISTENT}
-PLIST_FILES?= ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so \
- ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.a \
- ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.la
# a52dec
-.if ${GST_PLUGIN}=="a52dec"
-LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
-DIST= ugly
-.endif
+gst_a52dec_LIB_DEPENDS+= a52.0:${PORTSDIR}/audio/liba52
+gst_a52dec_DIST= ugly
# aalib
-.if ${GST_PLUGIN}=="aalib"
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
-PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so \
+gst_aalib_LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+gst_aalib_PLIST_FILES= ${GST_LIB_DIR}/libgstaasink.so \
${GST_LIB_DIR}/libgstaasink.a \
${GST_LIB_DIR}/libgstaasink.la
-.endif
+
+# annodex
+
+# bz2
+gst_bz2_DIST= bad
# cairo
-.if ${GST_PLUGIN}=="cairo"
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-.endif
+gst_cairo_LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
# cdparanoia
-.if ${GST_PLUGIN}=="cdparanoia"
-LIB_DEPENDS+= cdda_interface.0:${PORTSDIR}/audio/cdparanoia
-EXTRA_LIBS+= -lgstcdda-${VERSION}
-DIST= base
-.endif
+gst_cdparanoia_LIB_DEPENDS+= cdda_interface.0:${PORTSDIR}/audio/cdparanoia
+gst_cdparanoia_EXTRA_LIBS+= -lgstcdda-${VERSION}
+gst_cdparanoia_DIST= base
# dts
-.if ${GST_PLUGIN}=="dts"
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts.a:${PORTSDIR}/multimedia/libdts
-PLIST_FILES= ${GST_LIB_DIR}/libgstdtsdec.a \
+gst_dts_BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts.a:${PORTSDIR}/multimedia/libdts
+gst_dts_PLIST_FILES= ${GST_LIB_DIR}/libgstdtsdec.a \
${GST_LIB_DIR}/libgstdtsdec.la \
${GST_LIB_DIR}/libgstdtsdec.so
-DIST= bad
-.endif
+gst_dts_DIST= bad
# dv
-.if ${GST_PLUGIN}=="dv"
-LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv
-.endif
+gst_dv_LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv
-.if ${GST_PLUGIN}=="dvd"
-EXTRA_LIBS+= -ldvdnav
-LIB_DEPENDS+= dvdnav.4:${PORTSDIR}/multimedia/libdvdnav
-GST_PLUGIN_DIR= ext/dvdnav \
+# dvd
+gst_dvd_EXTRA_LIBS+= -ldvdnav
+gst_dvd_LIB_DEPENDS+= dvdnav.4:${PORTSDIR}/multimedia/libdvdnav
+gst_dvd_GST_PLUGIN_DIR= ext/dvdnav \
ext/dvdread
-PLIST_FILES= ${GST_LIB_DIR}/libgstdvdnav.a \
+gst_dvd_PLIST_FILES= ${GST_LIB_DIR}/libgstdvdnav.a \
${GST_LIB_DIR}/libgstdvdnav.la \
${GST_LIB_DIR}/libgstdvdnav.so \
${GST_LIB_DIR}/libgstdvdread.a \
${GST_LIB_DIR}/libgstdvdread.la \
${GST_LIB_DIR}/libgstdvdread.so
-DIST= ugly
-.endif
+gst_dvd_DIST= ugly
# esound
-.if ${GST_PLUGIN}=="esound"
-USE_GNOME+= esound
-GST_PLUGIN_DIR= ext/esd
-CONFIGURE_ENV+= ESD_CFLAGS="`pkg-config --cflags esound`" \
+gst_esound_USE_GNOME+= esound
+gst_esound_GST_PLUGIN_DIR= ext/esd
+gst_esound_CONFIGURE_ENV+= ESD_CFLAGS="`pkg-config --cflags esound`" \
ESD_LIBS="`pkg-config --libs esound`"
-PLIST_FILES= ${GST_LIB_DIR}/libgstesd.so \
+gst_esound_PLIST_FILES= ${GST_LIB_DIR}/libgstesd.so \
${GST_LIB_DIR}/libgstesd.a \
${GST_LIB_DIR}/libgstesd.la
-.endif
# faac
-.if ${GST_PLUGIN}=="faac"
-LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
-DIST= bad
-.endif
+gst_faac_LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+gst_faac_DIST= bad
# faad
-.if ${GST_PLUGIN}=="faad"
-LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
-DIST= bad
-.endif
+gst_faad_LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
+gst_faad_DIST= bad
# flac
-.if ${GST_PLUGIN}=="flac"
-LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
-.endif
+gst_flac_LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
# gconf
-.if ${GST_PLUGIN}=="gconf"
-USE_GNOME+= gconf2
-GST_PLUGIN_DIR= ext/gconf \
+gst_gconf_USE_GNOME+= gnomeprefix gconf2
+gst_gconf_GST_PLUGIN_DIR= ext/gconf \
gconf
-GCONF_SCHEMAS= gstreamer-${GST_VERSION}.schemas
-PLIST_FILES= ${GST_LIB_DIR}/libgstgconfelements.so \
+gst_gconf_CONFIGURE_ARGS+= --enable-schemas-install
+gst_gconf_GCONF_SCHEMAS= gstreamer-${GST_VERSION}.schemas
+gst_gconf_PLIST_FILES= ${GST_LIB_DIR}/libgstgconfelements.so \
${GST_LIB_DIR}/libgstgconfelements.a \
${GST_LIB_DIR}/libgstgconfelements.la
-.endif
# gnomevfs
-.if ${GST_PLUGIN}=="gnomevfs"
-USE_GNOME+= gnomevfs2
-CONFIGURE_ARGS+=--enable-gnome_vfs
-DIST= base
-.endif
+gst_gnomevfs_USE_GNOME+= gnomevfs2
+gst_gnomevfs_CONFIGURE_ARGS+=--enable-gnome_vfs
+gst_gnomevfs_DIST= base
# gsm
-.if ${GST_PLUGIN}=="gsm"
-LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
-DIST= bad
-.endif
+gst_gsm_LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+gst_gsm_DIST= bad
# ivorbis
-.if ${GST_PLUGIN}=="ivorbis"
-LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
-DIST= bad
-.endif
+gst_ivorbis_LIB_DEPENDS+= vorbisidec.1:${PORTSDIR}/audio/libtremor
+gst_ivorbis_DIST= bad
# hal
-.if ${GST_PLUGIN}=="hal"
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
-PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.a \
+gst_hal_LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+gst_hal_PLIST_FILES= ${GST_LIB_DIR}/libgsthalelements.a \
${GST_LIB_DIR}/libgsthalelements.la \
${GST_LIB_DIR}/libgsthalelements.so
-.endif
-
# jpeg
-.if ${GST_PLUGIN}=="jpeg"
-LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
-.endif
+gst_jpeg_LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
# ladspa
-.if ${GST_PLUGIN}=="ladspa"
-BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
-.endif
+gst_ladspa_BUILD_DEPENDS+= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
# lame
-.if ${GST_PLUGIN}=="lame"
-LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
-DIST= ugly
-.endif
+gst_lame_LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+gst_lame_DIST= ugly
# libcaca
-.if ${GST_PLUGIN}=="libcaca"
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
-PLIST_FILES= ${GST_LIB_DIR}/libgstcacasink.so \
+gst_libcaca_BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
+gst_libcaca_PLIST_FILES= ${GST_LIB_DIR}/libgstcacasink.so \
${GST_LIB_DIR}/libgstcacasink.a \
${GST_LIB_DIR}/libgstcacasink.la
-.endif
# libmms
-.if ${GST_PLUGIN}=="libmms"
-LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
-PLIST_FILES= ${GST_LIB_DIR}/libgstmms.so \
+gst_libmms_LIB_DEPENDS+= mms.0:${PORTSDIR}/net/libmms
+gst_libmms_PLIST_FILES= ${GST_LIB_DIR}/libgstmms.so \
${GST_LIB_DIR}/libgstmms.a \
${GST_LIB_DIR}/libgstmms.la
-DIST= bad
-.endif
+gst_libmms_DIST= bad
# libpng and the snapshot plugin
-.if ${GST_PLUGIN}=="libpng"
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
-GST_PLUGIN_DIR= ext/libpng
-PLIST_FILES= ${GST_LIB_DIR}/libgstpng.so \
+gst_libpng_LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+gst_libpng_GST_PLUGIN_DIR= ext/libpng
+gst_libpng_PLIST_FILES= ${GST_LIB_DIR}/libgstpng.so \
${GST_LIB_DIR}/libgstpng.a \
${GST_LIB_DIR}/libgstpng.la
-.endif
# libvisual
-.if ${GST_PLUGIN}=="libvisual"
-LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
-DIST= base
-.endif
+gst_libvisual_LIB_DEPENDS+= visual.0:${PORTSDIR}/graphics/libvisual
+gst_libvisual_DIST= base
# mad
-.if ${GST_PLUGIN}=="mad"
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
+gst_mad_LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
id3tag.0:${PORTSDIR}/audio/libid3tag
-DIST= ugly
-.endif
+gst_mad_DIST= ugly
# mpeg2dec
-.if ${GST_PLUGIN}=="mpeg2dec"
-LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
-DIST= ugly
-.endif
+gst_mpeg2dec_LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
+gst_mpeg2dec_DIST= ugly
# musepack
-.if ${GST_PLUGIN}=="musepack"
-LIB_DEPENDS+= mpcdec.4:${PORTSDIR}/audio/libmpcdec
-DIST= bad
-.endif
+gst_musepack_LIB_DEPENDS+= mpcdec.4:${PORTSDIR}/audio/libmpcdec
+gst_musepack_DIST= bad
# musicbrainz
-.if ${GST_PLUGIN}=="musicbrainz"
-LIB_DEPENDS+= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
-PLIST_FILES= ${GST_LIB_DIR}/libgsttrm.so \
+gst_musicbrainz_LIB_DEPENDS+= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
+gst_musicbrainz_PLIST_FILES= ${GST_LIB_DIR}/libgsttrm.so \
${GST_LIB_DIR}/libgsttrm.a \
${GST_LIB_DIR}/libgsttrm.la
-DIST= bad
-.endif
+gst_musicbrainz_DIST= bad
+
+# neon
+gst_neon_LIB_DEPENDS+= neon.25:${PORTSDIR}/www/neon
+gst_neon_CONFIGURE_ENV+= NEON_CFLAGS="-I${LOCALBASE}/include/neon"
+gst_neon_PLIST_FILES= ${GST_LIB_DIR}/libgstneonhttpsrc.a \
+ ${GST_LIB_DIR}/libgstneonhttpsrc.la \
+ ${GST_LIB_DIR}/libgstneonhttpsrc.so
+gst_neon_DIST= bad
# ogg
-.if ${GST_PLUGIN}=="ogg"
-LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
-EXTRA_LIBS+= -lgstriff-${VERSION}
-DIST= base
-.endif
+gst_ogg_LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
+gst_ogg_EXTRA_LIBS+= -lgstriff-${VERSION}
+gst_ogg_DIST= base
# pango
-.if ${GST_PLUGIN}=="pango"
-USE_GNOME+= pango
-DIST= base
-.endif
+gst_pango_USE_GNOME+= pango
+gst_pango_DIST= base
# sdl
-.if ${GST_PLUGIN}=="sdl"
-USE_SDL+= sdl
-GST_PLIST_SUFFIX= videosink
-DIST= bad
-.endif
+gst_sdl_USE_SDL+= sdl
+gst_sdl_PLIST_FILES= ${GST_LIB_DIR}/libgstsdlvideosink.a \
+ ${GST_LIB_DIR}/libgstsdlvideosink.la \
+ ${GST_LIB_DIR}/libgstsdlvideosink.so
+gst_sdl_GST_PLIST_SUFFIX= videosink
+gst_sdl_DIST= bad
# shout2
-.if ${GST_PLUGIN}=="shout2"
-LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
-.endif
+gst_shout2_LIB_DEPENDS+= shout.5:${PORTSDIR}/audio/libshout2
# sidplay
-.if ${GST_PLUGIN}=="sidplay"
-LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
-PLIST_FILES= ${GST_LIB_DIR}/libgstsid.so \
+gst_sidplay_LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
+gst_sidplay_PLIST_FILES= ${GST_LIB_DIR}/libgstsid.so \
${GST_LIB_DIR}/libgstsid.a \
${GST_LIB_DIR}/libgstsid.la
-DIST= ugly
-.endif
+gst_sidplay_DIST= ugly
# speex
-.if ${GST_PLUGIN}=="speex"
-LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
-.endif
+gst_speex_LIB_DEPENDS+= speex.3:${PORTSDIR}/audio/speex
# theora
-.if ${GST_PLUGIN}=="theora"
-LIB_DEPENDS+= theora.2:${PORTSDIR}/multimedia/libtheora
-DIST= base
-.endif
+gst_theora_LIB_DEPENDS+= theora.2:${PORTSDIR}/multimedia/libtheora
+gst_theora_DIST= base
# vorbis
-.if ${GST_PLUGIN}=="vorbis"
-USE_GSTREAMER+= ogg
-LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-EXTRA_LIBS+= -lgsttag-${VERSION} -lgstaudio-${VERSION}
-DIST= base
-.endif
+gst_vorbis_USE_GSTREAMER+= ogg
+gst_vorbis_LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+gst_vorbis_EXTRA_LIBS+= -lgsttag-${VERSION} -lgstaudio-${VERSION}
+gst_vorbis_DIST= base
# xvid
-.if ${GST_PLUGIN}=="xvid"
-LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
-DIST= bad
-.endif
+gst_xvid_LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+gst_xvid_DIST= bad
# wavpack
-.if ${GST_PLUGIN}=="wavpack"
-LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
-DIST= bad
-.endif
+gst_wavpack_LIB_DEPENDS+= wavpack.0:${PORTSDIR}/audio/wavpack
+gst_wavpack_DIST= bad
+
.endif # NO_GSTREAMER_COMMON
-.if ${DIST}=="base"
-EXTRACT_ONLY=${BASE_DISTFILE}
-WRKSRC=${WRKDIR}/${BASE_DISTNAME}
-PORTVERSION= ${BASE_PORTVERSION}
-DISTFILES+= ${BASE_DISTFILE}:base
-PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins/files
-.elif ${DIST}=="bad"
-EXTRACT_ONLY=${BAD_DISTFILE}
-WRKSRC=${WRKDIR}/${BAD_DISTNAME}
-PORTVERSION= ${BAD_PORTVERSION}
-DISTFILES+= ${BAD_DISTFILE}:bad
-PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-bad/files
-.elif ${DIST}=="ugly"
-EXTRACT_ONLY=${UGLY_DISTFILE}
-WRKSRC=${WRKDIR}/${UGLY_DISTNAME}
-PORTVERSION= ${UGLY_PORTVERSION}
-DISTFILES+= ${UGLY_DISTFILE}:ugly
-PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-ugly/files
-.elif ${DIST}=="makesum"
-DISTFILES+= ${BASE_DISTFILE}:base ${BAD_DISTFILE}:bad \
- ${UGLY_DISTFILE}:ugly ${GOOD_DISTFILE}:good
-.else
-EXTRACT_ONLY=${GOOD_DISTFILE}
-WRKSRC=${WRKDIR}/${GOOD_DISTNAME}
-PORTVERSION= ${GOOD_PORTVERSION}
-DISTFILES+= ${GOOD_DISTFILE}:good
-PATCHDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins-good/files
-.endif
+gst_${GST_PLUGIN}_DIST?= good
+DIST= ${gst_${GST_PLUGIN}_DIST}
.if !defined(NO_GSTREAMER_COMMON)
+gst_${GST_PLUGIN}_BUILD_DEPENDS?=
+gst_${GST_PLUGIN}_LIB_DEPENDS?=
+gst_${GST_PLUGIN}_RUN_DEPENDS?=
+gst_${GST_PLUGIN}_PLIST_FILES?=${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.so \
+ ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.a \
+ ${GST_LIB_DIR}/libgst${GST_PLUGIN}${GST_PLIST_SUFFIX}.la
+gst_${GST_PLUGIN}_EXTRA_LIBS?=
+gst_${GST_PLUGIN}_PREBUILD_DIR?=
+gst_${GST_PLUGIN}_GST_PLUGIN_DIR?= ext/${GST_PLUGIN}
+gst_${GST_PLUGIN}_POSTBUILD_DIR?=
+gst_${GST_PLUGIN}_USE_GNOME?=
+gst_${GST_PLUGIN}_CONFIGURE_ENV?=
+gst_${GST_PLUGIN}_GCONF_SCHEMAS?=
+gst_${GST_PLUGIN}_CONFIGURE_ARGS?=
+gst_${GST_PLUGIN}_USE_SDL?=
+gst_${GST_PLUGIN}_USE_GSTREAMER?=
+
+BUILD_DEPENDS+= ${gst_${GST_PLUGIN}_BUILD_DEPENDS}
+LIB_DEPENDS+= ${gst_${GST_PLUGIN}_LIB_DEPENDS}
+RUN_DEPENDS+= ${gst_${GST_PLUGIN}_RUN_DEPENDS}
+PLIST_FILES= ${gst_${GST_PLUGIN}_PLIST_FILES}
+EXTRA_LIBS+= ${gst_${GST_PLUGIN}_EXTRA_LIBS}
+USE_GNOME+= ${gst_${GST_PLUGIN}_USE_GNOME}
+CONFIGURE_ENV+= ${gst_${GST_PLUGIN}_CONFIGURE_ENV}
+.if ${gst_${GST_PLUGIN}_GCONF_SCHEMAS}!=""
+GCONF_SCHEMAS= ${gst_${GST_PLUGIN}_GCONF_SCHEMAS}
+.endif
+CONFIGURE_ARGS+=${gst_${GST_PLUGIN}_CONFIGURE_ARGS}
+.if ${gst_${GST_PLUGIN}_USE_SDL}!=""
+USE_SDL= ${gst_${GST_PLUGIN}_USE_SDL}
+.endif
+USE_GSTREAMER+= ${gst_${GST_PLUGIN}_USE_GSTREAMER}
+GST_PREBUILD_DIR=${gst_${GST_PLUGIN}_GST_PREBUILD_DIR}
+GST_PLUGIN_DIR= ${gst_${GST_PLUGIN}_GST_PLUGIN_DIR}
+GST_POSTBUILD_DIR=${gst_${GST_PLUGIN}_GST_POSTBUILD_DIR}
+
.if !target(do-build)
do-build:
.for dir in ${GST_PREBUILD_DIR} ${GST_PLUGIN_DIR} ${GST_POSTBUILD_DIR}
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index 6d4db1b17e03..165d6d07f72e 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,12 +1,12 @@
-MD5 (gst-plugins-base-0.10.9.tar.bz2) = cf0aa58f066c3a0e0258909b3ad9d4ad
-SHA256 (gst-plugins-base-0.10.9.tar.bz2) = 81906ea7471212bc376d509a843f113913618c2c93e352a0b5d890f69e1d35f7
-SIZE (gst-plugins-base-0.10.9.tar.bz2) = 1261167
+MD5 (gst-plugins-base-0.10.10.tar.bz2) = 7a51a3fabebe5f77235926ad65ba9593
+SHA256 (gst-plugins-base-0.10.10.tar.bz2) = 2246a5921ad060e86acd81cabec17a5022d1997849f950ac2c8f6f14f9291d3e
+SIZE (gst-plugins-base-0.10.10.tar.bz2) = 1333651
MD5 (gst-plugins-bad-0.10.3.tar.bz2) = 8545a02c408976c5e9f0c2cf3c6a362e
SHA256 (gst-plugins-bad-0.10.3.tar.bz2) = 648f1ef813c64c7eedd45d164eb41ba21366bba8ec5fcbff3100458721be489e
SIZE (gst-plugins-bad-0.10.3.tar.bz2) = 953949
-MD5 (gst-plugins-ugly-0.10.3.tar.bz2) = af6f238507b0040bf84fcbc6a241e559
-SHA256 (gst-plugins-ugly-0.10.3.tar.bz2) = 0cd916b3f0c8867cea77243d20d8d56ed45b7ef5ec5c5dd1603860ece8e88a10
-SIZE (gst-plugins-ugly-0.10.3.tar.bz2) = 605833
-MD5 (gst-plugins-good-0.10.3.tar.bz2) = a58bb825bd4b22412764f2a8d2f98b1c
-SHA256 (gst-plugins-good-0.10.3.tar.bz2) = 8c09374656aca4b8ffbe109a24dcdb98c5d519c4b05bf9eeeb3a34f16b26eaf5
-SIZE (gst-plugins-good-0.10.3.tar.bz2) = 1165391
+MD5 (gst-plugins-ugly-0.10.4.tar.bz2) = c10f40e3641d827ca7853b0a3d560257
+SHA256 (gst-plugins-ugly-0.10.4.tar.bz2) = 4871c52b2421b582330a0f9dc6a42da3b706140c346aa0cd690eb40758afe152
+SIZE (gst-plugins-ugly-0.10.4.tar.bz2) = 720893
+MD5 (gst-plugins-good-0.10.4.tar.bz2) = e189496e7987898823d28d26b79f63dc
+SHA256 (gst-plugins-good-0.10.4.tar.bz2) = f2b90ef5fb4b2d0b06d5fd8193a7c19b1d08d4f737abeafabf04d39673ea703b
+SIZE (gst-plugins-good-0.10.4.tar.bz2) = 1225739
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index f4720a089850..a732d89031ad 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -56,6 +56,9 @@ lib/gstreamer-%%VERSION%%/libgstdecodebin.so
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.a
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.la
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
+lib/gstreamer-%%VERSION%%/libgstgdp.a
+lib/gstreamer-%%VERSION%%/libgstgdp.la
+lib/gstreamer-%%VERSION%%/libgstgdp.so
lib/gstreamer-%%VERSION%%/libgstplaybin.a
lib/gstreamer-%%VERSION%%/libgstplaybin.la
lib/gstreamer-%%VERSION%%/libgstplaybin.so
@@ -68,6 +71,9 @@ lib/gstreamer-%%VERSION%%/libgsttcp.so
lib/gstreamer-%%VERSION%%/libgsttypefindfunctions.a
lib/gstreamer-%%VERSION%%/libgsttypefindfunctions.la
lib/gstreamer-%%VERSION%%/libgsttypefindfunctions.so
+lib/gstreamer-%%VERSION%%/libgstvideo4linux.a
+lib/gstreamer-%%VERSION%%/libgstvideo4linux.la
+lib/gstreamer-%%VERSION%%/libgstvideo4linux.so
lib/gstreamer-%%VERSION%%/libgstvideorate.a
lib/gstreamer-%%VERSION%%/libgstvideorate.la
lib/gstreamer-%%VERSION%%/libgstvideorate.so
@@ -142,3 +148,9 @@ share/locale/vi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
@dirrm include/gstreamer-%%VERSION%%/gst/cdda
@dirrm include/gstreamer-%%VERSION%%/gst/audio
+@dirrmtry share/locale/uk/LC_MESSAGES
+@dirrmtry share/locale/uk
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs