aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer/files
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /multimedia/gstreamer/files
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
downloadports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.tar.gz
ports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.zip
Notes
Diffstat (limited to 'multimedia/gstreamer/files')
-rw-r--r--multimedia/gstreamer/files/patch-configure30
-rw-r--r--multimedia/gstreamer/files/patch-gst::cothreads.c12
-rw-r--r--multimedia/gstreamer/files/patch-gst::gstthreaddummy.c10
-rw-r--r--multimedia/gstreamer/files/patch-libs::ext::cothreads::cothreads::cothreads.c19
-rw-r--r--multimedia/gstreamer/files/patch-libs::ext::cothreads::tests::Makefile.in11
-rw-r--r--multimedia/gstreamer/files/patch-ltmain.sh30
6 files changed, 41 insertions, 71 deletions
diff --git a/multimedia/gstreamer/files/patch-configure b/multimedia/gstreamer/files/patch-configure
index 11e54cb76694..4dafb1ddde0d 100644
--- a/multimedia/gstreamer/files/patch-configure
+++ b/multimedia/gstreamer/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig Sat Sep 27 14:13:57 2003
-+++ configure Sat Sep 27 14:18:37 2003
-@@ -8173,7 +8173,7 @@
+--- configure.orig Thu Feb 26 14:03:31 2004
++++ configure Thu Feb 26 14:03:31 2004
+@@ -21858,7 +21858,7 @@
+
+
+ EXP_VAR=LOCALEDIR
+- FROM_VAR=$datadir/locale
++ FROM_VAR=$prefix/share/locale
+
+ prefix_save=$prefix
+ exec_prefix_save=$exec_prefix
+@@ -21961,7 +21961,7 @@
echo $ECHO_N "checking to see if compiler understands -Werror... $ECHO_C" >&6
save_CFLAGS="$CFLAGS"
@@ -8,8 +17,8 @@
+ CFLAGS="$CFLAGS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
-@@ -8214,7 +8214,7 @@
+ /* confdefs.h. */
+@@ -22011,7 +22011,7 @@
CFLAGS="$save_CFLAGS"
if test "X$flag_ok" = Xyes ; then
@@ -17,13 +26,4 @@
+ GST_ERROR="$GST_ERROR"
true
else
-
-@@ -9607,7 +9607,7 @@
- :
- fi
-
--if test "$ac_cv_check_mcsc" == "yes"; then
-+if test "$ac_cv_check_mcsc" = "yes"; then
-
- cat >>confdefs.h <<_ACEOF
- #define HAVE_MAKECONTEXT $HAVE_MAKECONTEXT
+ GST_ERROR="$GST_ERROR"
diff --git a/multimedia/gstreamer/files/patch-gst::cothreads.c b/multimedia/gstreamer/files/patch-gst::cothreads.c
index 3519fb0e7e01..b66b7062f37b 100644
--- a/multimedia/gstreamer/files/patch-gst::cothreads.c
+++ b/multimedia/gstreamer/files/patch-gst::cothreads.c
@@ -1,6 +1,6 @@
---- gst/cothreads.c.orig Sat Feb 1 19:09:00 2003
-+++ gst/cothreads.c Mon Feb 3 10:57:44 2003
-@@ -41,12 +41,16 @@
+--- gst/cothreads.c.orig Mon Feb 2 06:56:53 2004
++++ gst/cothreads.c Fri Feb 6 13:05:26 2004
+@@ -42,6 +42,10 @@
#include <ucontext.h>
#endif
@@ -8,9 +8,11 @@
+#include <ucontext.h>
+#endif
+
- /* older glibc's have MAP_ANON instead of MAP_ANONYMOUS */
#ifndef MAP_ANONYMOUS
- #define MAP_ANONYMOUS MAP_ANON
+ #ifdef MAP_ANON
+ /* older glibc's have MAP_ANON instead of MAP_ANONYMOUS */
+@@ -52,7 +56,7 @@
+ #endif
#endif
-#define STACK_SIZE 0x200000
diff --git a/multimedia/gstreamer/files/patch-gst::gstthreaddummy.c b/multimedia/gstreamer/files/patch-gst::gstthreaddummy.c
index 479a05ba9c9b..71bace4805c9 100644
--- a/multimedia/gstreamer/files/patch-gst::gstthreaddummy.c
+++ b/multimedia/gstreamer/files/patch-gst::gstthreaddummy.c
@@ -1,12 +1,10 @@
---- gst/gstthreaddummy.c.orig Sat Aug 30 19:30:10 2003
-+++ gst/gstthreaddummy.c Sat Aug 30 19:30:34 2003
-@@ -17,7 +17,9 @@
+--- gst/gstthreaddummy.c.orig Mon Jun 30 14:31:13 2003
++++ gst/gstthreaddummy.c Fri Nov 14 15:36:22 2003
+@@ -17,6 +17,7 @@
* Boston, MA 02111-1307, USA.
*/
+#include <sys/types.h>
+ #include <unistd.h>
#include <sys/time.h>
-+#include <unistd.h>
#include <glib.h>
- #include "gstlog.h"
-
diff --git a/multimedia/gstreamer/files/patch-libs::ext::cothreads::cothreads::cothreads.c b/multimedia/gstreamer/files/patch-libs::ext::cothreads::cothreads::cothreads.c
deleted file mode 100644
index e0e229f97524..000000000000
--- a/multimedia/gstreamer/files/patch-libs::ext::cothreads::cothreads::cothreads.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- libs/ext/cothreads/cothreads/cothreads.c.orig Sat Feb 1 16:09:23 2003
-+++ libs/ext/cothreads/cothreads/cothreads.c Mon Mar 17 13:33:43 2003
-@@ -22,6 +22,7 @@
-
- #include "pth_p.h" /* this pulls in everything */
- #include <sys/mman.h>
-+#include <sys/time.h>
- #include <sys/resource.h>
- #include <stdlib.h>
-
-@@ -422,7 +423,7 @@
- *stack = malloc (_cothreads_chunk_size * (1.0 + 1.0/_cothreads_count));
- if (!stack)
- return FALSE;
-- *stack = (void*)((int)*stack &~ (int)(_cothreads_chunk_size / _cothreads_count - 1));
-+ *stack = (void*)((intptr_t)*stack &~ (intptr_t)(_cothreads_chunk_size / _cothreads_count - 1));
- *stack += 1;
- #endif
-
diff --git a/multimedia/gstreamer/files/patch-libs::ext::cothreads::tests::Makefile.in b/multimedia/gstreamer/files/patch-libs::ext::cothreads::tests::Makefile.in
deleted file mode 100644
index 4470b93eef61..000000000000
--- a/multimedia/gstreamer/files/patch-libs::ext::cothreads::tests::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libs/ext/cothreads/tests/Makefile.in.orig Mon Oct 13 15:10:38 2003
-+++ libs/ext/cothreads/tests/Makefile.in Mon Oct 13 15:11:13 2003
-@@ -83,7 +83,7 @@
- GLIB_CFLAGS = @GLIB_CFLAGS@
- GLIB_LIBS = @GLIB_LIBS@
- GTHREAD_CFLAGS = @GTHREAD_CFLAGS@
--GTHREAD_LIBS = @GTHREAD_LIBS@
-+GTHREAD_LIBS = -lc @GTHREAD_LIBS@
- INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
- LIBTOOL = @LIBTOOL@
- LN_S = @LN_S@
diff --git a/multimedia/gstreamer/files/patch-ltmain.sh b/multimedia/gstreamer/files/patch-ltmain.sh
index 284a2d7b15df..9b5b1ec3b9aa 100644
--- a/multimedia/gstreamer/files/patch-ltmain.sh
+++ b/multimedia/gstreamer/files/patch-ltmain.sh
@@ -1,15 +1,15 @@
---- ltmain.sh.orig Mon Oct 13 14:17:09 2003
-+++ ltmain.sh Sat Feb 21 15:44:32 2004
-@@ -1075,7 +1075,7 @@
+--- ltmain.sh.orig Tue Oct 28 09:26:50 2003
++++ ltmain.sh Sat Feb 21 15:30:25 2004
+@@ -1280,7 +1280,7 @@
esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
- *-*-openbsd* | *-*-freebsd*)
+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1085,8 +1085,16 @@
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
continue
;;
@@ -26,17 +26,17 @@
continue
;;
-@@ -2503,6 +2511,9 @@
- *-*-openbsd* | *-*-freebsd*)
- # Do not include libc due to us having libc/libc_r.
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
- # Add libc to deplibs on all other systems if necessary.
- if test $build_libtool_need_lc = "yes"; then
-@@ -4330,10 +4341,12 @@
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
fi
# Install the pseudo-library for information purposes.