aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer1-libav/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-16 13:35:01 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-16 13:35:01 +0000
commitc6e9859c13cd4827ad2782f678ec0a3633d122ce (patch)
tree9f5703f594896a48eae53e004be52fd12fcce700 /multimedia/gstreamer1-libav/Makefile
parent0d5a1fd6c437b0c40b926ff0920b2c65f4f6250b (diff)
downloadports-c6e9859c13cd4827ad2782f678ec0a3633d122ce.tar.gz
ports-c6e9859c13cd4827ad2782f678ec0a3633d122ce.zip
Notes
Diffstat (limited to 'multimedia/gstreamer1-libav/Makefile')
-rw-r--r--multimedia/gstreamer1-libav/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/multimedia/gstreamer1-libav/Makefile b/multimedia/gstreamer1-libav/Makefile
index f006de1b04f2..5d3322ff3c23 100644
--- a/multimedia/gstreamer1-libav/Makefile
+++ b/multimedia/gstreamer1-libav/Makefile
@@ -3,8 +3,7 @@
# $MCom: ports/multimedia/gstreamer1-libav/Makefile,v 1.4 2013/01/15 21:43:45 kwm Exp $
PORTNAME= gstreamer1-libav
-PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTVERSION= 1.4.4
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-libav/
DISTNAME= gst-libav-${PORTVERSION}
@@ -13,17 +12,22 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= GStreamer plug-in with many audio/video decoders/encoders
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
orc>=0.4.16:${PORTSDIR}/devel/orc
LIB_DEPENDS= liborc-0.4.so:${PORTSDIR}/devel/orc
-USES= compiler gmake libtool pkgconfig tar:xz
+USES= compiler:features gmake libtool pkgconfig tar:xz
USE_LDCONFIG= yes
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
+LIBAV_CONFIG= --cc=${CC} \
+ --enable-runtime-cpudetect \
+ --enable-pic
+LDFLAGS+= -Wl,-Bsymbolic
+
INSTALL_TARGET= install-strip
-PLIST_FILES= lib/gstreamer-1.0/libgstlibav.so
.include <bsd.port.pre.mk>